December 9, 20232 yr Advice and Solutions (Forum Knowledgebase) Disclaimer. Read before using materials. Issue During initial deployments you may encounter errors like this: Jun 3 12:50:13 ksmg postfix/smtpd[841]: NOQUEUE: reject: RCPT from ksmg.example.com[10.10.10.1]: 450 4.1.2 <test@example.com>: Recipient address rejected: Domain not found; from=<test@example.com> to=<test@example.com> proto=ESMTP helo=<example.com> This means that the recipient domain could not be verified in DNS. Solution There are multiple ways to avoid it: create a proper DNS records for the mentioned domain on the DNS server that is used by KSMG configure to use a different DNS server that has proper records just disable this check in Settings -> MTA -> Advanced Settings -> Reject messages for unknown recipient domains When that check is enable, requests are rejected, when the RCPT TO domain has no DNS MX and no DNS A record a malformed MX record (a record with a zero-length MX hostname)
Advice and Solutions (Forum Knowledgebase) Disclaimer. Read before using materials.
Issue
During initial deployments you may encounter errors like this:
Jun312:50:13ksmg postfix/smtpd[841]: NOQUEUE: reject: RCPT from ksmg.example.com[10.10.10.1]:4504.1.2<test@example.com>: Recipient address rejected: Domain not found; from=<test@example.com> to=<test@example.com> proto=ESMTP helo=<example.com>This means that the recipient domain could not be verified in DNS.
Solution
There are multiple ways to avoid it:
When that check is enable, requests are rejected, when the RCPT TO domain has