Jump to content

Fatal error: Your Apache is built with APR


Recommended Posts

Hello, an error occurred during the installation of the server on Linux Debian

Install KLMS UI Apache config file

Fatal error: Your Apache is built with APR library which is not compatible
with KLMS Web-UI module. Details: Apache version is 2.4, APR minor version
is 7.

You don't know where the error could be?

Link to comment
Share on other sites

Hello, the problem is that the APR library is max version APR 1.7.0

I have the current version

root@ns:~# apt-get install libapr1
Načítavajú sa zoznamy balíkov... Hotovo
Vytvára sa strom závislostí... Hotovo
Načítavajú sa stavové informácie... Hotovo
libapr1 is already the newest version (1.7.0-6+deb11u1).
0 aktualizovaných, 0 nových nainštalovaných, 0 na odstránenie a 0 neaktualizovaných.
root@ns:~# /opt/kaspersky/klmsui/bin/klmsui-setup.pl

Kaspersky Security for Linux Mail Server UI version 8.0.3.30/RELEASE


Setting up the Apache module

Apache service name: apache2
Installer found the following Apache server on your computer:

Apache server daemon executable: /usr/sbin/apachectl
Apache server configuration dir: /etc/apache2/conf-enabled
Apache server service name (or rc.d script name): apache2

Please enter 'Y' to confirm that you want to integrate with this Apache
server. Enter 'N' if Apache server has been detected incorrectly, or if you
do not want to use it [yes]:


Please select configuration type. Enter:
'name' - for name-based virtual host;
'port' - for port-based virtual host;
'dir' - for directory-based configuration.
[port]:


Please enter port number for virtual host or press Enter to use default
[9045]:


Please enter KLMS host and port in <hostname>:<port> format
[127.0.0.1:2711]:


Please select which certificate will be used for this virtual host.
Enter 'keep' to keep existing certificate, 'new' to generate a new
self-signed certificate, or enter 'file' to specify key and certificate
files manually [keep]:



Update Apache configuration

Keep Existing SSL Certficate

Install KLMS UI Apache config file

Fatal error: Your Apache is built with APR library which is not compatible
with KLMS Web-UI module. Details: Apache version is 2.4, APR minor version
is 7.

Some other help ?

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.