Jump to content

Connection Via OpenVPN

Recommended Posts

I configured a VPN connection through OpenVPN by saving a .ovpn file, but when I use openvpn to connect, the connection is blocked, although the same server I'm connecting to works fine when I connect from windows.

I tried both UDP and TCP protocols, both getting the same error (I used to see this error when my ISP blocks VPN connection)

2024-04-15 14:47:35 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
2024-04-15 14:47:35 TLS Error: TLS handshake failed

Does the windows app use some different protocol or settings that I can implement in openvpn in linux?

Link to comment
Share on other sites

@Belal Do you use vanilla OpenVPN or official Kaspersky VPN client to connect in Windows?

If vanilla OpenVPN in Windows works, please share details about

  1. Linux OS version
  2. Linux OpenVPN client version

Basically we supports 2.4.2 and newer vanilla OpenVPN clients with NCP enabled.

If you refer Kaspersky VPN client, please check if it works if force WireGuard protocol in app setting. If it works please consider to use WireGuard configuration instead of OpenVPN with Linux client.

Kaspersky VPN WIndows client by default uses Catapult Hydra protocol, right now there is no way to connect Linux device using it.

  • Thanks 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...