Skip to content
View in the app

A better way to browse. Learn more.

Kaspersky Support Forum

A full-screen app on your home screen with push notifications, badges and more.

To install this app on iOS and iPadOS
  1. Tap the Share icon in Safari
  2. Scroll the menu and tap Add to Home Screen.
  3. Tap Add in the top-right corner.
To install this app on Android
  1. Tap the 3-dot menu (⋮) in the top-right corner of the browser.
  2. Tap Add to Home screen or Install app.
  3. Confirm by tapping Install.

Alt-Linux-server-10.2 + mariadb-server-10.6.19

Всех приветствую !

Подскажите куда копать в плане устранения ошибки.

Имеем на борту:

1) Alt-Linux-server-10.2
2) mariadb-server-10.6.19

При пустом файле my.cnf mysql запускается с таким логом:

2024-10-28 12:22:16 0 [Note] Starting MariaDB 10.6.19-MariaDB-alt1 source revision  server_uid Zv4jGM3BmfGDe4+uFbWEwRNyfm0= as process 4957
2024-10-28 12:22:16 0 [Note] Plugin 'InnoDB' is disabled.
2024-10-28 12:22:16 0 [Note] Plugin 'FEEDBACK' is disabled.
2024-10-28 12:22:16 0 [Note] Starting MariaDB 10.6.19-MariaDB-alt1 source revision  server_uid Zv4jGM3BmfGDe4+uFbWEwRNyfm0= as process 5426
2024-10-28 12:22:16 0 [Note] InnoDB: Compressed tables use zlib 1.3.1
2024-10-28 12:22:16 0 [Note] InnoDB: Number of pools: 1
2024-10-28 12:22:16 0 [Note] InnoDB: Using crc32 + pclmulqdq instructions
2024-10-28 12:22:16 0 [Note] InnoDB: Using Linux native AIO
2024-10-28 12:22:16 0 [Note] InnoDB: Initializing buffer pool, total size = 134217728, chunk size = 134217728
2024-10-28 12:22:16 0 [Note] InnoDB: Completed initialization of buffer pool
2024-10-28 12:22:16 0 [Note] InnoDB: Starting crash recovery from checkpoint LSN=13571,13571
2024-10-28 12:22:16 0 [Note] InnoDB: To recover: 3 pages
2024-10-28 12:22:16 0 [Note] InnoDB: 128 rollback segments are active.
2024-10-28 12:22:16 0 [Note] InnoDB: Removed temporary tablespace data file: "./ibtmp1"
2024-10-28 12:22:16 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2024-10-28 12:22:16 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2024-10-28 12:22:16 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2024-10-28 12:22:16 0 [Note] InnoDB: 10.6.19 started; log sequence number 33097; transaction id 4
2024-10-28 12:22:16 0 [Note] InnoDB: Loading buffer pool(s) from /db/ib_buffer_pool
2024-10-28 12:22:16 0 [Note] Plugin 'FEEDBACK' is disabled.
2024-10-28 12:22:16 0 [Note] InnoDB: Cannot open '/db/ib_buffer_pool' for reading: No such file or directory
2024-10-28 12:22:16 0 [Note] /usr/sbin/mysqld: ready for connections.
Version: '10.6.19-MariaDB-alt1'  socket: '/mysql.sock'  port: 0  (ALT p10)
2024-10-28 12:23:29 0 [Note] /usr/sbin/mysqld (initiated by: unknown): Normal shutdown
2024-10-28 12:23:29 0 [Note] InnoDB: FTS optimize thread exiting.
2024-10-28 12:23:29 0 [Note] InnoDB: Starting shutdown...
2024-10-28 12:23:29 0 [Note] InnoDB: Dumping buffer pool(s) to /db/ib_buffer_pool
2024-10-28 12:23:29 0 [Note] InnoDB: Buffer pool(s) dump completed at 241028 12:23:29
2024-10-28 12:23:30 0 [Note] InnoDB: Removed temporary tablespace data file: "./ibtmp1"
2024-10-28 12:23:30 0 [Note] InnoDB: Shutdown completed; log sequence number 33109; transaction id 4
2024-10-28 12:23:30 0 [Note] /usr/sbin/mysqld: Shutdown complete 

Со страницы https://support.kaspersky.ru/ksc-linux/15/210277 беру новое содержимое для my.cnf

sort_buffer_size=10M
join_buffer_size=100M
join_buffer_space_limit=300M
join_cache_level=8
tmp_table_size=512M
max_heap_table_size=512M
key_buffer_size=200M
innodb_buffer_pool_size=100
innodb_thread_concurrency=20
innodb_flush_log_at_trx_commit=0
innodb_lock_wait_timeout=300
max_allowed_packet=32M
max_connections=151
max_prepared_stmt_count=12800
table_open_cache=60000
table_open_cache_instances=4
table_definition_cache=60000
optimizer_prune_level=0
optimizer_search_depth=8

И далее получаю следующий лог mysql

024-10-28 12:23:30 0 [Note] Starting MariaDB 10.6.19-MariaDB-alt1 source revision  server_uid Zv4jGM3BmfGDe4+uFbWEwRNyfm0= as process 5539
2024-10-28 12:23:30 0 [Note] Plugin 'InnoDB' is disabled.
2024-10-28 12:23:30 0 [Note] Plugin 'FEEDBACK' is disabled.
2024-10-28 12:23:30 0 [Warning] 'innodb-thread-concurrency' was removed. It does nothing now and exists only for compatibility with old my.cnf files.
2024-10-28 12:23:30 0 [Note] Starting MariaDB 10.6.19-MariaDB-alt1 source revision  server_uid Zv4jGM3BmfGDe4+uFbWEwRNyfm0= as process 6008
2024-10-28 12:23:30 0 [Warning] option 'innodb-buffer-pool-size': unsigned value 512 adjusted to 2097152
2024-10-28 12:23:30 0 [ERROR] InnoDB: innodb_page_size=16384 requires innodb_buffer_pool_size >= 5MiB current 2MiB
2024-10-28 12:23:30 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2024-10-28 12:23:30 0 [Note] Plugin 'FEEDBACK' is disabled.
2024-10-28 12:23:30 0 [Warning] 'innodb-thread-concurrency' was removed. It does nothing now and exists only for compatibility with old my.cnf files.
2024-10-28 12:23:30 0 [ERROR] Unknown/unsupported storage engine: InnoDB
2024-10-28 12:23:30 0 [ERROR] Aborting

 

Featured Replies

26 минут назад, leksstav сказал:
2024-10-28 12:23:30 0 [ERROR] InnoDB: innodb_page_size=16384 requires innodb_buffer_pool_size >= 5MiB current 2MiB
2024-10-28 12:23:30 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

Задайте правильное значение в переменной:

26 минут назад, leksstav сказал:
innodb_buffer_pool_size=

У Вас 100 - это в байтах.

Цитата

innodb_buffer_pool_size=реальное значение должно быть не менее 80% от ожидаемого размера базы данных KAV

+ у Вас какая версия "KSC"?

Для "15.1", другие рекомендации.

Edited by durtuno

  • Author
2 часа назад, durtuno сказал:

Задайте правильное значение в переменной:

У Вас 100 - это в байтах.

+ у Вас какая версия "KSC"?

Для "15.1", другие рекомендации.

 

Спасибо огромное я пропустил букву M после 100.

Сейчас дома на тестовой виртуалке исправил и mysql взлетела.

Посоветуйте с указанием правильного размера, чтобы не прогадать так сказать

innodb_buffer_pool_size=реальное значение должно быть не менее 80% от ожидаемого размера базы данных KAV. Даже затрудняюсь так сказать понять какой будет размер базы. Пользователей будет около 5 тыс. Какой оптимальный размер должен быть примерно для такого объема ?

Безымянный.png

8 часов назад, leksstav сказал:

Посоветуйте с указанием правильного размера, чтобы не прогадать так сказать

Можно в 50-70% от объёма доступной/ свободной оперативной памяти, если "KSC" и указанная БД это основные задачи на сервере.

После, уже во время работы сможете скорректировать - выбрать оптимальное, конкретно для Вас, значение.

Edited by durtuno

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

Account

Navigation

Search

Search

Configure browser push notifications

Chrome (Android)
  1. Tap the lock icon next to the address bar.
  2. Tap Permissions → Notifications.
  3. Adjust your preference.
Chrome (Desktop)
  1. Click the padlock icon in the address bar.
  2. Select Site settings.
  3. Find Notifications and adjust your preference.