Jump to content
mikethebike

Enabling Secure Screen Keyboard in KIS 2019

Recommended Posts

Last night my KIS 2017 was automatically updated to KIS 19.0.0.1088(d). I used to have the green icon for my Safe Money sites such as my online banking but that has disappeared. I went to the Secure Screen Keyboard and clicked on the setting icon and all were clicked for the green icon which gives a shortcut to the Secure Screen Keyboard. The only box out of the four that was not ticked was that for general internet so I ticked that as well then rebooted

That has worked in terms of the internet and for all sites reached via the internet( I use Google Chrome) the green icon now appears but when I use the K Safe Money section and click onto the online banking site listed under Safe Money the green icon does not appear. If I use the Online Banking site via my Google site as if it were just another site then the green icon does appear

I am at a loss to work out what I need to do to restore the green icon for those sites listed under my Safe Money section. Any help is much appreciated. Thanks

 

mikethebike

Share this post


Link to post

@mikethebike Re the Shield

I notice that the Green Shield appears on :normal' Chrome if the Kaspersky Extension is enabled via the  Chrome Tools Menu.

Strangely with the extension On or Off with 'normal' chrome use, When chrome is used as the browser for Safe Money the Kaspersky extension is Off hence no shield. It can be turned on by the Tools Menu

Safe money  can use other browsers.

Share this post


Link to post

Thanks for the reply. Yes, the Kaspersky extension remains on in Chrome. It looks as if something has changed when moving to KIS 2019 from KIS 2017 but what is it and how do I restore the same shortcut in KIS 2019? I find it difficult to believe that moving to KIS 2019 prevents using the Secure Keyboard icon when in Safe Money. I'd have expected to have seen a lot more complaints if there is no way to enable to the Secure Keyboard  in Safe money, especially when the green icon which allows the keyboard shortcut  can be added to the internet.   

mikethebike

  

Share this post


Link to post

@mikethebike

My previous post on this topic related to my experience with win 7 starter, -chrome 71.0.3578.98 & KIS 19.0.0.1088(d) on  an HP Note Book

I've nw started my Desktop Win 10 Pro 1083 same KIS and Chrome and I find that the Safe Keyboard Input does not appear to operate with my Barclays Bank Site.

[Previously I've had to exclude this site from using Safe Keyboard as I found security characters being carried over into (aka repeated ) in the wrong fields/boxes! - but now this appears to have been corrected]

However - Safe Keyboard excluded or not, the option to use is not presented!

Perhaps it's some interaction between newer versions of KIS and Chrome?

Share this post


Link to post

Thanks for second reply,wgcuser. I use the latest level of Chrome and KIS2019 the same as you do. The difference is that my Windows is Windows 7 Home Premium. It is still possible to "call-up" and use the Secure Keyboard but it was far more convenient simply to click on the green icon and then remove the Secure Keyboard as required as often as is needed. I note that there appears no way to simply minimise the keyboard once it is stuck on the screen and can get in the way so you have to get rid of it then bring it up by going back to the Safe Money part and clicking on the Secure Screen part.

Hopefully someone who has WIN 7 Home Premium, Chrome and KIS2019 will reply and either say how they do it or confirm that the Secure Keyboard icon does not work. If the latter is the case then it (a) seems a shame that K has abandoned this and (b) still appears to give the options in the Secure Keyboard settings of ticking all the boxes to allow access to the shortcut

mikethebike

    

Share this post


Link to post
On 12/13/2018 at 2:45 PM, mikethebike said:

Last night my KIS 2017 was automatically updated to KIS 19.0.0.1088(d). I used to have the green icon for my Safe Money sites such as my online banking but that has disappeared. I went to the Secure Screen Keyboard and clicked on the setting icon and all were clicked for the green icon which gives a shortcut to the Secure Screen Keyboard. The only box out of the four that was not ticked was that for general internet so I ticked that as well then rebooted

That has worked in terms of the internet and for all sites reached via the internet( I use Google Chrome) the green icon now appears but when I use the K Safe Money section and click onto the online banking site listed under Safe Money the green icon does not appear. If I use the Online Banking site via my Google site as if it were just another site then the green icon does appear

I am at a loss to work out what I need to do to restore the green icon for those sites listed under my Safe Money section. Any help is much appreciated. Thanks

 

mikethebike

Just a thought here. Do you think it might help if you were to delete the safe money sites and then re-add them in KIS 19? I keep thinking that this might be related to the transition of 17 to 19 in versions and maybe the dynamics are slightly different and it needs to be renewed somehow. I wish I could narrow this down for you, but, I personally don't use Safe Money, since I use Auto Logins with encrypted scannings.

Share this post


Link to post

Thanks plb4333. That sounds worth a try. I had wondered if the shortcut to Secure Keyboard on the user's nominated Safe money sites had been removed on the basis that once the "green square" was placed round the site the Secure Keyboard was unnecessary as it was protected from keyloggers( I think that's what they are called). However this may be me simply and falsely rationalising on the reason and it may be that this is not the case. Thus a deletion and fresh re-addition may be the real answer

mikethebike

 

Share this post


Link to post

plb4333, alas I just tried deleting one site and then adding it again and it made no difference. Looks like I am stuck with having to forego the green icon and thus any shortcut to Secure Keyboard. A pity that no-one else has replied who can either confirm that this is one of the drawbacks with KIS 2019 or better still tell me how it is possible to retain the green icon on Safe Money sites 

mikethebike

 

  

Share this post


Link to post
41 minutes ago, mikethebike said:

plb4333, alas I just tried deleting one site and then adding it again and it made no difference. Looks like I am stuck with having to forego the green icon and thus any shortcut to Secure Keyboard. A pity that no-one else has replied who can either confirm that this is one of the drawbacks with KIS 2019 or better still tell me how it is possible to retain the green icon on Safe Money sites 

mikethebike

 

  

Sorry to hear that! I really thought this might do the trick, but...no. Have you tried technical support about this? Sorry if I missed that part if you had already mentioned that. I didn't go thru the posts. Now I wish I had installed Safe Money with the Secure Keyboard, so I could follow-up better and see what's happening. How about, if you don't hear from technical support you let me know and I'll give it go with installing and try to replicate what you got going on. I also use Win7 premium and sometimes use Chrome, when not using FF 65.

Share this post


Link to post

OK, plb4333, and thanks for the offer. Tech Support may be the best bet - at least for an explanation if not a solution. I now seriously doubt if there is a way to do it as there seems to be nothing available within the options of Safe Money. However it still puzzles me that, you and one other user apart, no other user has responded, to say they noticed the same thing when switching to KIS 2019 or give a way of solving the problem. Fortunately I think I am an uncomplicated  user of the internet and maybe for that reason I have experienced no other issues on the switch which has seemed to give a lot of trouble to many others, judging by the forum's posts on KIS 2019 and those who have reverted to 2018  

mikethebike

 

 

 

Share this post


Link to post

I agree with you about this. It does seem odd there's no further feedback on this or other users' saying the same. Have you tried to reinstall KIS 2019? I know you just got updated to 2019, but maybe something didn't get installed properly when the update happened. Sometimes it happens. It's easy to think that it was just installed and must be OK since there's no time element involved for corruption, but nevertheless, it can and does happen periodically where, something gets missed for whatever reason. You might want to do a complete uninstall, restart, and install of 2019. If this is the case, it would get rid of this delimna and could save alot of time as well, as well as troubleshooting, which can really eat up time..

Share this post


Link to post

Thanks I just had to use Safe Money this morning and while it is a little more "faff" to use the Secure Keyboard than clicking on the absent green icon it is probably something I'll get used to and probably only takes a few seconds longer to do so I may just live with it as it is.

Your help has been much appreciated

mikethebike 

 

Share this post


Link to post

OK, sounds good! I do hope it corrects in the future tho. If you ever decide you'd like me to install it and check it out more, I always will.

Share this post


Link to post
On 12/13/2018 at 2:45 PM, mikethebike said:

Last night my KIS 2017 was automatically updated to KIS 19.0.0.1088(d). I used to have the green icon for my Safe Money sites such as my online banking but that has disappeared. I went to the Secure Screen Keyboard and clicked on the setting icon and all were clicked for the green icon which gives a shortcut to the Secure Screen Keyboard. The only box out of the four that was not ticked was that for general internet so I ticked that as well then rebooted

That has worked in terms of the internet and for all sites reached via the internet( I use Google Chrome) the green icon now appears but when I use the K Safe Money section and click onto the online banking site listed under Safe Money the green icon does not appear. If I use the Online Banking site via my Google site as if it were just another site then the green icon does appear

I am at a loss to work out what I need to do to restore the green icon for those sites listed under my Safe Money section. Any help is much appreciated. Thanks

 

mikethebike

Hello mikethebike! Sorry to bother you with this again, but I installed it and I'm trying to figure out what you're going thru. I admit I'm not familiar with this option called Safe Money, so it'll probably look like I have no clue. But I would really like to help, but only if you want me to. I installed Safe Money and added a banking site that I use. The pic below is what I think you're relating to, in regard to safe money icon not showing, or greyed out? but then I'm just not sure really. Anyways, is this what you're referring to? If not please let me know, otherwise, I'll drop the subject. :)

 

Untitled-2.JPG

Edited by plb4333

Share this post


Link to post

Thanks plb4333. Yes your screen shot looks like what I get. When you add the banking or any other site to the Safe Money list  and  click on it, Safe Money takes you to the protected browser but there is no green icon there, just the green border which tells you that you are protected. What I have to do then if I want to use Secure Keyboard before adding username , password etc, is click back on to the K Safe Money section where my list of Safe Money sites exist and click on the On Screen Keyboard at the top right . This brings up the On Screen Keyboard and I then delete the Safe Money site, leaving the On Screen Keyboard which I can then use to log-in. It can be moved around the screen but gets in the way to an extent so if I need it again I can go through the whole process again. Previously I had no need to click on the Safe Money site list at all but could delete the Secure Keyboard and simply click on the green icon( now missing)  on say the Online Banking site or any other site listed under Safe Money to bring up the On Screen Keyboard again.

mikethebike    

Share this post


Link to post

Ok, I'm starting to get a better grip on this. When I go to my banking site, I see like you mentioned, a green border to show privacy and no virtual keyboard, but when I press Control-ALT-Shift-P then the virtual keyboard comes out. I already had the login box already filled out because I use auto-logins in firefox, but I seen in the Kaspersky settings, I had to enable the feature of those 4 keys to enable virtual keyboard. Looked OK for its function.

Share this post


Link to post

plb4333, sorry I must have hit the wrong button and sent the reply after "thanks".  Thanks again for this further research. It is a better way than what I currently have to do. Can I clarify a coupe of points?

1. I was able to do what you say but only by a simultaneous press with one finger on the Shift and Ctrl key and another finger on the Alt key. Then I can separately press the P and it brings up the virtual keyboard in CAPS of course but that can be altered to small case on the virtual board. I take it that simultaneous pressing as above is required as pressing one after another did not work

2. This may sound "greedy" but is there any easy way to arrange a shortcut to the simultaneous pressing of Shift and Ctrl with one finger and Alt with a second finger? I suspect not but no harm in asking 

 

Thanks again

 

mikethebike  

Share this post


Link to post

@mikethebike 

Over the years I too have had (several) "problems" with the combo of KIS Safe Money and my bank's website!

I notice that with Google Chrome as my browser - there is no faint keyboard (which I take to be the Secure Data Input) in any of my bank's login  boxes.

If, however, Internet Explorer is set as the browser for Safe Money - then the box appears!!

This seems to be the case using both Windows 10 Pro 32 bit and Windows 7 Starter, KIS 19.0.0.1088(d) and Chrome  Version 71.0.3578.98 (Official Build) (32-bit)

wgcuser

Share this post


Link to post

Thanks for the reply,wgcuser. Can I clarify something? Are you saying that in Explorer(IE) and on your KIS Safe Money list of sites the green icon returns when you are on that site within the Green Protected Browser or are you saying that when logging on to,  say, your online bank site within IE and not within KIS Safe Money you get the green icon? If it is the latter then I am also able to get the Green Icon on both IE and Google but in neither can I get the Green Icon within Safe Money.

It may be that your issues with Safe Money and sites such as banking/money sites  are not the same as mine but clarification on my question would be appreciated. I have never experienced any problem with Safe Money in KIS 2017 nor any problem in Safe Money on KIS 2019 except for the matter of previously being able to have the Green Icon on any Safe Money site in KIS 2017 but not on KIS 2019

mikethebike 

 

Share this post


Link to post
6 hours ago, mikethebike said:

plb4333, sorry I must have hit the wrong button and sent the reply after "thanks".  Thanks again for this further research. It is a better way than what I currently have to do. Can I clarify a coupe of points?

1. I was able to do what you say but only by a simultaneous press with one finger on the Shift and Ctrl key and another finger on the Alt key. Then I can separately press the P and it brings up the virtual keyboard in CAPS of course but that can be altered to small case on the virtual board. I take it that simultaneous pressing as above is required as pressing one after another did not work

2. This may sound "greedy" but is there any easy way to arrange a shortcut to the simultaneous pressing of Shift and Ctrl with one finger and Alt with a second finger? I suspect not but no harm in asking 

 

Thanks again

 

mikethebike  

I noticed that I can press the 4 keys separately, but only if I press {CTRL - ALT} as together. I tried a control-Alt first, then did 1 key press of Shift, then after that did 1 key press of P and it worked ok. I also noticed that if you leave your physical keyboard as Caps Lock on, it will then default to Caps On in the Virtual Keyboard as well. I tried it both ways and the virtual keyboard corresponded accordingly, (as Kaspersky's). As far as this shortcut is concern, I find it about as easy to just go to the lower-right taskbar or, system Tray, (never could get it right for remembering), and right click the Kaspersky application Icon, then when the context menu pops upward, there's an option called 'Tools' in this menu. I'm not sure if you have it or not, but highlighting Tools will show a sub menu popout and then you'll see 'Onscreen Keyboard' and this works as well, so no shortcut needed. Whenever I do either those 4 keys to bring up the virtual keyboard, I seen where it can be done anytime, even if the browser's not opened and I'm looking at the computer Desktop screen is all. The same with the K-Icon in the taskbar and highlighting Tools, then Onscreen Keyboard. Nothing has to be running for it to pop up on screen. Hope this helps a little in your efforts. :)

Edited by plb4333

Share this post


Link to post
2 hours ago, mikethebike said:

Thanks for the reply,wgcuser. Can I clarify something? Are you saying that in Explorer(IE) and on your KIS Safe Money list of sites the green icon returns when you are on that site within the Green Protected Browser or are you saying that when logging on to,  say, your online bank site within IE and not within KIS Safe Money you get the green icon? If it is the latter then I am also able to get the Green Icon on both IE and Google but in neither can I get the Green Icon within Safe Money.

@mikethebike Hope the screen grabs explain? My other problems I'll leave for another my own post on another day!

 image.thumb.png.9ff92d765cef3c45ba8cd3d619352f60.png

Above ~ Image of site using IE

2039672911_MikeAnsChrome.thumb.jpg.6ab674fe107e2bafacaac36eaa4f926e.jpg

Above ~ Image of site using Google Chrome

 

Share this post


Link to post

Thanks for the reply and two screenshots,wgcuser. It would appear that within the Protected Browser banking site on both IE and Google you do have the green icon which I used to have in KIS2017 but no longer have. I note that in IE there is also the Secure Keyboard icon in your logon section and this is absent from the same logon section in Google but I am assuming that at least when you click on the icon it brings up the 3 items of: Private Browsing;Anti-Banner; Open On Screen Keyboard. 

If there was a way of bringing the green icon back to the Safe Money Protected Browser sites then I can easily live without the addition of the Secure Keyboard icon in the logon box

As things stand I either use my own work-around or plb4333's keyboard "trick" or "tools" route which is quicker. In fact it may be that using one finger across Shift Ctrl and another on Alt then P will be just as quick as clicking on the green icon if it were there but it still leaves me wondering why the green icon has disappeared. I suppose it is now a matter of intellectual curiosity as much as one of convenience

Thanks again

mikethebike

 

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.