Jump to content

Problem between Window AppLocker and Kaspersky EPS 11.8 ...- 11.9 ...


Go to solution Solved by DonKid,

Recommended Posts

We use OS: "Windows 10 enterprise"
Kaspersky Endpoint Security 11.8 ... - 11.9 ....
Hello, I will try to describe the problem we have in as much detail as possible.
Our company's workstations are running Windows 10 enterprise and are not yet included in the active directory, so we use local group policies.
We use Windows AppLocker to restrict limited users so that they can't run different applications, scripts…
We install Kaspersky Endpoint Security 11.8 ... - 11.9 .... successfully, but after starting the application to configure the following error "Falied to initialize Microsoft .Net Framework. Please reinstall it. " Kaspersky Endpoint Security 11.7 did not have this problem…
When I turn off the Windows AppLocker service I restart the computer Kaspersky Endpoint Security 11.8 ... - 11.9 .... I can log in and configure Kaspersky EPS locally.
I also noticed that when Windows AppLocker is running in the background, Kaspersky EPS works and blocks some sites (which are problematic…) but the icon at the bottom right of the taskbar when you start it gives the above error.
I tried to describe in the rules of Windows AppLocker Kaspersky EPS work folders with full permissions for all users but without success.
I did clean OS installations until the last update but the problem remains. I guess there is some incompatibility that I can not understand between Windows AppLocker and Kaspersky EPS.
I have tried everything from this link https://support.kaspersky.com/common/error/installation/11682 but the problem is between Windows AppLocker and Kaspersky EPS.

I apologize for my poor English.

If you have any additional questions I'm online!
Thank you very much in advance for your help.

 

Sincerely, N. Nikolov

Link to comment
Share on other sites

  • 2 weeks later...

Hello, Thank you very much for waiting and extending the ticket.

The solution for me is the following:

Only one exception needs to be added which needs to be added to:
Local Computer Policy / Computer Configuration / Windows Settings / Security Settings / Application Control / AppLocker / Script Rules

And there the following rule is added:

General Section:
Name:
% OSDRIVE% \ ProgramData \ Kaspersky Lab \ *
Action: Allow
User or group: Everyone (or which users you want)

Path section:
Path:
% OSDRIVE% \ ProgramData \ Kaspersky Lab \ *

That's all 😊 If I can be useful with something please email me!
Thanks again for the quick replies and for waiting.
Greetings with a wish for an easy and successful week!
Sincerely, N. Nikolov

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.