Jump to content

Mac App Store blocked by KIS [19 and 2020, "Cannot Connect to the App Store" ]


kenj
 Share

Recommended Posts

Hello! I have the same problem. I'm using a Mac mini 2018 i3 runing Mojave (10.14.6) and Kaspersky Internet Security (19.0.0.294b.c.d). iTunes is also up-to-date (12.9.5.5). In the reports i din't find 'iTunes/App store' events.
Link to comment
Share on other sites

  • Replies 64
  • Created
  • Last Reply

Top Posters In This Topic

Hello FLOOD ,
  1. I used this tool for removal : Uninstallation wizard,
  2. Full scan has been performed : nothing was detected,
  3. Non critical events is checked : File Anti virus tab is enclosed (issue has been replicated before saving this file), I have only 2 non empty tabs : the update one and the one with the full scan report. I don't think it is interesting,
  4. Console log is attached. iTunes has been open around 16:31:14 time frame. I did not manage to go back to the date of October 3rd,
  5. My KIS is licensed : I contacted the support (referenced under ID INC000010850829), waiting for an answer.
Thanks again for your help. Regards,
Link to comment
Share on other sites

Me t oo Using Mc OS Mojave version 10.14.6 on Mac (Retina 5K, 27-inch, 2017) running Kapersky Internet Security 19.0.0, 294b,c,d. iTunes can only be fully accessed by disabling Kapersky. Probelm occurred yesterday. Englaged usual troubeshooting drills but no joy .
Link to comment
Share on other sites

Hello SupR-Pingou, Thank you.
  1. The Lab may take a few days to get back to you.
  2. As the issue started when KIS19 was installed we know it's not due to KIS20, we also know KIS20 hasn't fixed it.
(a) If you haven't done so already, please set up Time Machine. (b) Please close all apps (not KIS), before doing the following:
  1. Select: Go To Folder in Finder’s Go menu (or select keyboard shortcut Shift (⇧)—Command (⌘)—G ) paste the full path ~/Library/Caches/com.apple.itunes in the field, select Go button.
  1. Hold the Command (⌘) key while selecting the fsCachedData folder and SubscriptionPlayCache folder, then release the key and select Move to Trash from the Finder’s File menu (alternatively, select Command (⌘)—Backspace (⌫) ).
  1. Repeat: open a Finder window, select “Go to Folder” in the Go menu.
Type in ~/Library/Caches select enter to proceed to this folder. Open each folder, delete everything, Note: Deleting contents NOT the folders.
  1. Repeat: open a Finder window, select “Go to Folder” in the Go menu.
Type in /Library/Caches select enter to proceed to this folder.
  1. Select Shut Down from Apple menu .
  2. Restart MAC, login, make sure KIS is active
  3. Retest iTunes
If the issue persists, please collect data using KL Logs Gather tool for Mac OS and upload to INC000010850829, along with the data and images you've collected (here). Let me know please? Thank you
Link to comment
Share on other sites

Hello, FLOOD I have the same issue that kenj reported. Unfortunately, in my case, upgrading KIS 20.0.0.829 didn't solve the problem. I'm using MacOS High Sierra operating system, and it has the latest updates applied.
Hello Rodolfo Barbosa, Welcome! (Additional to richbuff's post)
  1. In your case, did the issue pre-exist upgrading to KIS2020?
  2. In KIS Reports - are there any events matching "Mac App Store access blocked" ?
Have you:
  1. Uninstalled KIS, shutdown MAC completely using: Apple keyShut Down
  2. Restarted MAC, downloaded new KIS2020 exe, reinstalled, shutdown MAC completely using: Apple key→Shut Down, restarted MAC, rechecked?
  3. Have you tried kenj's "KeyChain Access "fix"?
Please post back? Thank you:pray_tone3:
In your case, did the issue pre-exist upgrading to KIS2020?
Yes. I was using KIS2019 before and starting on October the 3rd I was unable to access iTunes Store and App Store. Actually, on October the 3rd I identified the issue, I'm not sure since when it was happening.
In KIS Reports - are there any events matching "Mac App Store access blocked" ?
No. It has not.
Uninstalled KIS, shutdown MAC completely using: Apple key→Shut DownRestarted MAC, downloaded new KIS2020 exe, reinstalled, shutdown MAC completely using: Apple key→Shut Down, restarted MAC, rechecked?
No. I have not.
Have you tried kenj's "KeyChain Access "fix"?
Yes. It was the first thing I tried when researching about the issue.
Link to comment
Share on other sites

Hello SupR-Pingou, Thank you.
  1. The Lab may take a few days to get back to you.
  2. As the issue started when KIS19 was installed we know it's not due to KIS20, we also know KIS20 hasn't fixed it.
(a) If you haven't done so already, please set up Time Machine. (b) Please close all apps (not KIS), before doing the following:
  1. Select: Go To Folder in Finder’s Go menu (or select keyboard shortcut Shift (⇧)—Command (⌘)—G ) paste the full path ~/Library/Caches/com.apple.itunes in the field, select Go button.
  1. Hold the Command (⌘) key while selecting the fsCachedData folder and SubscriptionPlayCache folder, then release the key and select Move to Trash from the Finder’s File menu (alternatively, select Command (⌘)—Backspace (⌫) ).
  1. Repeat: open a Finder window, select “ Go to Folder” in the Go menu.
Type in ~/Library/Caches select enter to proceed to this folder.Open each folder, delete everything, Note: Deleting contents NOT the folders.
  1. Repeat: open a Finder window, select “Go to Folder” in the Go menu.
Type in /Library/Caches select enter to proceed to this folder.
  1. Select Shut Down from Apple menu .
  2. Restart MAC, login, make sure KIS is active
  3. Retest iTunes
If the issue persists, please collect data using KL Logs Gather tool for Mac OS and upload to INC000010850829, along with the data and images you've collected (here). Let me know please? Thank you
Hello FLOOD , Thank you for this but unfortunately problem is still present. Regards,
Link to comment
Share on other sites

I also have this very same problem. Since Kaspersky must have done some auto-update as 3 days ago iTunes was working fine, but now I cannot access iTunes store (ie buy any music) while Kaspersky is running! It was a right pain to figure out what was causing the problem too but after two days I finally figured it out! Pls fix :)
Link to comment
Share on other sites

I also have this very same problem. Since Kaspersky must have done some auto-update as 3 days ago iTunes was working fine, but now I cannot access iTunes store (ie buy any music) while Kaspersky is running! It was a right pain to figure out what was causing the problem too but after two days I finally figured it out! Pls fix :)
Hello Tamzin, Welcome! Have you contacted Kaspersky Technical Support? If not, please do so. The issue cannot be fixed here in the Community portal, nor by the Community. The more impacted people who communicate with the Technical Team, the more likely the issue is to be fixed, otherwise, if only one person communicates with the Lab, the Lab will naturally treat this as a single issue affecting a single user. Please let us know what the Lab advises? Thank you:pray_tone3:.
Link to comment
Share on other sites

Mac App Store blocked by KAV [19, "Cannot Connect to the App Store" ]
Hello kenj, I noticed you have a new topic, KIS 20.0.0.829, failed installation, components not running, and that installation/update issue is now resolved. Has the new install resolved the Mac App Store blocked issue? Please let me know? Thank you:pray_tone3:
Link to comment
Share on other sites

This latest install was the same version as the previous one installed yesterday. KAV did the update automatically as part of its "update check" *and* after it failed to start all components and suggested I re-install KAV... so, the update effectively did nothing other than re-install. Long story short, the Mac App Store was ok before and after the latest re-install.
Link to comment
Share on other sites

Hello everyone. First post. I found out that the issue is caused by the setting "Check secure connections (HTTPS) for Safe Money and Private browsing. That feature of Kaspersky is preventing access to http://itunes.apple.com which Apple Music depends on to function. You can test this by unchecking that option and opening your Apple Music App and seeing the error go away. The error will return when it is checked. You can also attempt to visit http://itunes.apple.com in your browser with that setting checked and it will fail. Uncheck it and it will work. Hopefully this gets resolved by Kaspersky's technicians soon.
Link to comment
Share on other sites

kenj, thank you for letting me know (again):pray_tone3: Guitar_t-bone, thank you:clap_tone3: Rodolfo Barbosa, SupR-Pingou, Astella P., Jelle, Iolis, Tamzin, Guitar_t-bone, please replicate the issue, then send the Console Logs to Kaspersky Lab Technical Support, with a note referring to Guitar_t-bone findings. The more impacted people who communicate with the Technical Team, the more likely the issue is to be fixed, otherwise, if only one person communicates with the Lab, the Lab will naturally treat this as a single issue affecting a single user. Thank you
Link to comment
Share on other sites

Hello FLOOD , All the files I sent here were forwarded to Kaspersky support (including the console log I provided here) along with a link to this discussion. Analysis of this issue by Kaskersky analysis team is on going. Unchecking "Check secure connections (HTTPS) for Safe Money and Private browsing" seems to fix the issue. I will forward this to the technical team. I will let you know of the outcome and kaspersky answer of this. Regards
Link to comment
Share on other sites

Excellent SupR-Pingou, good work:clap_tone3: Re disabling "Check secure conx", (imo), it's a workaround, not a fix. A very similar issue existed in the Windows environment, that "solution" was "offered" as a fix until the Lab finally realised disabling a core component of the software was not what subscribers have paid for. Do keep us posted please? Thank you:pray_tone3:
Link to comment
Share on other sites

FLOOD , Yes this is only a workaround and it needs to be fixed. If issue is not fixed, I will not renew subscription after my license is over. Catalina is now available, maybe issue is not present in this new macOS version but I did not do the update yet. I will let you know of Kaspersky team findings
Link to comment
Share on other sites

You're absolutely correct SupR-Pingou, it's not a fix. It's true the issue may not present in Catalina, however, not everybody will be able to upgrade to Catalina, so, the issue must be fixed. Also, don't be in too much of a hurry to do the OS upgrade, the distribution of KIS 20, Mac OS Catalina, has not been seamless. Do keep us posted please? Thank you.
Link to comment
Share on other sites

Yesterday I updated my iMac 2019 with the new Catalina MacOs and the problems with connected Apple Music and Apple Store started. I uninstalled and reinstalled KIS20 but the problem persists. Tonight when I return home I check the status of the option "Check secure connections (HTTPS) for Safe Money and Private browsing". The same problem I already had last week with an iMac 2009 (High Sierra) and iTunes and also on this computer I will check the status of "Check ...". Regards.
Link to comment
Share on other sites

I have the same problem after updating on Catalina. Apple Music is blocked! Workaround, disable "Check secure connections (HTTPS) for Safe Money and Private browsing", otherwise Apple Music won't work! Please provide a correction as soon as possible, THANK YOU.
Link to comment
Share on other sites

Hello juerg Welcome!
  1. The issue cannot be fixed here in the Community portal, nor by the Community.
  2. Please replicate the issue, collect the Console Logs & KL Logs Gather tool for Mac & contact Kaspersky Lab Technical Support
  3. The more impacted people who communicate with the Technical Team, the more likely the issue is to be fixed, otherwise, if only one person communicates with the Lab, the Lab will naturally treat this as a single issue affecting a single user.
Thank you
Link to comment
Share on other sites

I understand that this problem cannot be solved here. It's a pity that I should contact the technical support, although this is the official community board of Kaspersky. This generates a lot of time and effort for me! Why don't you just send the reproducible problem described here directly to the technical department? I don't understand that...
Link to comment
Share on other sites

Hello juerg, Thank you for replying. I don't have the data. The data is what the Lab needs. This issue is impacting multiple people, however, taking the 10 people who've raised the issue in this post, it would be "unusual" if every single person had exactly the same software, network, hardware, and environmental conditions. The more people who raise the issue with Technical Support the greater the likelihood the Lab will come up with a fix rather than a "workaround". The Community is made up of users of Kaspersky software (like you), all who volunteer their time freely, to help other Community members (like you). Where we can replicate issues and take our time to log issues on behalf of other Community members (like you), we frequently do. Thank you
Link to comment
Share on other sites

Hello, Just got an update by the support team : Bug is acknowledged by Kaspersky team under bug number 3571602 and a fix will come up however the time required to fix it is not known. it will be corrected via software update. No other fix other than disabling the "Check secure..." option. If anyone reads french or want to google translate the answer by the support hereafter the mail I received :
Cher client(e) Bonjour, Je vous remercie pour votre patience. Le souci que vous nous avez indiqué n'a pas pu être résolu encore. Le temps requis pour que la résolution soit disponible n'est toujours pas déterminé, mais veuillez savoir que ce souci sera corrigé à travers une mise à jour du logiciel. Un numéro de bug lui a été attribué: 3571602 En ce moment il n'existe pas d'autre solution que de décocher l'option d'analyses des connexions chiffrées (HTTPS), mais nous travaillons vers cette direction, afin que la résolution arrive le plus tôt possible. Soyez assuré que dès que nous en saurons davantage, nous reviendrons directement vers vous Veuillez nous excuser pour la gêne occasionnée. Dans l'attente nous gardons votre dossier ouvert jusqu'à sa complète résolution.Merci de votre compréhension.Cordialement,
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share




×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.