Jump to content

Kaspersky Hardware Virtualization


MRoutt
 Share

Recommended Posts

Greetings,

I am having a problem similar to what Veerain described in Kaspersky Hardware virtualization error from back in May.

1)      Which Windows OS version & build?

a)      Windows 10 version 22H2, build 19045.2251

2)      Have all Windows updates & patches been applied successfully?

a)      Yes, including KB5019959 released on 11/8/2022.

3)      Which KIS version & patch(x), x=letter, is installed, on the Windows taskbar, or hidden icons, rightclick the Kaspersky icon, select About?

a)      21.3.10.391 (j)

As far as I am able to determine all of the UEFI settings for virtualization are correct, the processor (an Intel Core i7-8700K) supports virtualization, Core Isolation and Device Guard are off, Hyper-V was never installed, and I have even uninstalled VMWare Workstation Player.  I have had a couple of power outages recently, however, I do not think that would have any impact on this.  I am hoping someone can provide guidance from here.

Regards,

Matt Routt

Screenshot 2022-12-01 105052.png

Link to comment
Share on other sites

56 minutes ago, MRoutt disse:

Greetings,

 

I am having a problem similar to what Veerain described in Kaspersky Hardware virtualization error from back in May.

 

1)      Which Windows OS version & build?

 

a)      Windows 10 version 22H2, build 19045.2251

 

2)      Have all Windows updates & patches been applied successfully?

 

a)      Yes, including KB5019959 released on 11/8/2022.

 

3)      Which KIS version & patch(x), x=letter, is installed, on the Windows taskbar, or hidden icons, rightclick the Kaspersky icon, select About?

 

a)      21.3.10.391 (j)

 

As far as I am able to determine all of the UEFI settings for virtualization are correct, the processor (an Intel Core i7-8700K) supports virtualization, Core Isolation and Device Guard are off, Hyper-V was never installed, and I have even uninstalled VMWare Workstation Player.  I have had a couple of power outages recently, however, I do not think that would have any impact on this.  I am hoping someone can provide guidance from here.

Regards,

Matt Routt

Screenshot 2022-12-01 105052.png

1- open windows security

2- click on device security

3- click on core isolation 

4- disable memory integrity

5- reboot system

6- now hardware virtualization in kaspersky will work.

1.jpg

2.jpg

3.jpg

Link to comment
Share on other sites

Just now, MRoutt disse:

Memory Integrity is off by default, I have never turned it on, and thus it remains off.  Should I turn it on, reboot, turn it off, then reboot again?

you can test. Turn off kaspersky virtualization too before you reboot your pc

Also check if virtualization is enabled in task manager

22.jpg

Link to comment
Share on other sites

I tried the sequence we discussed earlier – turn off hardware virtualization in Kaspersky > turn on Core Isolation Memory Integrity > reboot > turn off Core Isolation Memory Integrity > reboot > turn on hardware virtualization in Kaspersky.  No change, I still see the same message in Kaspersky about the OS not being stable when using hardware virtualization

Link to comment
Share on other sites

12 minutes ago, MRoutt disse:

I tried the sequence we discussed earlier – turn off hardware virtualization in Kaspersky > turn on Core Isolation Memory Integrity > reboot > turn off Core Isolation Memory Integrity > reboot > turn on hardware virtualization in Kaspersky.  No change, I still see the same message in Kaspersky about the OS not being stable when using hardware virtualization

 

in your case I believe you just need to disable the option "use the advanced features of hardware virtualization". I believe it will solve the problem

Maybe your pc doesn't have these "advanced features", for example my pc doesn't even give me this option in kaspersky, only the option "use the hardware virtualization if available"

Link to comment
Share on other sites

I will teach the method for anyone who has the following virtualization error message in kaspersky: "Hardware virtualization is not available; Incompatible hardware or software detected"

do it at your own risk

METHOD:

windows 10/11 pro

Steps:
turn off hyper-v
go to "turn windows features on or off"
make sure hyper-v is not ticked.
if it is ticked, untick it and click "ok".

open command prompt window as an administrator
run: bcdedit /enun {current}
note down the hypervisorlaunchtype in case this needs to be reverted
run: bcdedit / set hypervisorlauch off 
to disable hypervisor close the command prompt after executing the commands and restart the system

edit group policy (gpedit)
go to local computer policy > computer configuration > administrative templates > system
double click on device guard on the right hand side to open.
double click on turn on virtualization security to open a new window
it would be "not configured", select "disable" and click ok
close the group policy editor
restart the system


windows 10/11 home

steps:
turn off hyper-v
go to "turn windows features on or off"
make sure hyper-v is not ticked.
if it is ticked, untick it and click "ok".

open registry editor
go to HKEY_LOCALMACHINE > SYSTEM > CurrentControlSet > Control > DeviceGuard
on the right-hand side, wtrite a new key
   a. right click > new > DWORD (32 bit) value
   b. name this value: EnableVirtualizationBasedSecurity
by default, it should be 0, double click, and confirm the value

go to HKEY_LOCALMACHINE > SYSTEM > CurrentControlSet > Control > Lsa
on the right-hand side, wtrite a new key
   a. right click > new > DWORD (32 bit) value
   b. name this value: LsaCfgFlags
by default, it should be 0, double click, and confirm the value
close the registry editor
restart the system

Link to comment
Share on other sites

Checked Windows Features (Control Panel > Programs & Features > Turn Windows Features On or Off), Hyper-V was not checked.  As suggested I changed “turn on virtualization based security” from “not configured” to “disabled”.  Checked HKLM\System\CurrentControlSet\Control\DeviceGuard and HKLM\System\Control\LSA after making the local polity change, EnableVirtualizationBasedSecurity and LsaCfgFlags were both set to 0.  When I ran bcedit /enum I did not see an entry for hypervisorlaunchtype.  Am I missing something?  Should I go ahead and run bcdedit / set hypervisorlauch off anyway?  The OS here is Windows 10 Pro.

Windows Boot Manager

--------------------

identifier              {bootmgr}

device                  partition=\Device\HarddiskVolume1

path                    \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI

description             Windows Boot Manager

locale                  en-US

inherit                 {globalsettings}

default                 {current}

resumeobject            {f460c2e4-47e5-11ec-8bc1-cb9986eebfcb}

displayorder            {current}

toolsdisplayorder       {memdiag}

timeout                 30

 

 

Windows Boot Loader

-------------------

identifier              {current}

device                  partition=C:

path                    \WINDOWS\system32\winload.efi

description             Windows 10

locale                  en-US

inherit                 {bootloadersettings}

recoverysequence        {f460c2e6-47e5-11ec-8bc1-cb9986eebfcb}

displaymessageoverride  Recovery

recoveryenabled         Yes

isolatedcontext         Yes

allowedinmemorysettings 0x15000075

osdevice                partition=C:

systemroot              \WINDOWS

resumeobject            {f460c2e4-47e5-11ec-8bc1-cb9986eebfcb}

nx                      OptIn

bootmenupolicy          Standard

Edited by MRoutt
Link to comment
Share on other sites

bcdedit /enum and bcdedit /set hypervisorlaunchtype  my bad, I fixed

 

 

windows 10/11 pro

Steps:
turn off hyper-v
go to "turn windows features on or off"
make sure hyper-v is not ticked.
if it is ticked, untick it and click "ok".

open command prompt window as an administrator
run: bcdedit /enum {current}
note down the hypervisorlaunchtype in case this needs to be reverted
run: bcdedit /set hypervisorlaunchtype off 
to disable hypervisor close the command prompt after executing the commands and restart the system

edit group policy (gpedit)
go to local computer policy > computer configuration > administrative templates > system
double click on device guard on the right hand side to open.
double click on turn on virtualization security to open a new window
it would be "not configured", select "disable" and click ok
close the group policy editor
restart the system


windows 10/11 home

steps:
turn off hyper-v
go to "turn windows features on or off"
make sure hyper-v is not ticked.
if it is ticked, untick it and click "ok".

open registry editor
go to HKEY_LOCALMACHINE > SYSTEM > CurrentControlSet > Control > DeviceGuard
on the right-hand side, wtrite a new key
   a. right click > new > DWORD (32 bit) value
   b. name this value: EnableVirtualizationBasedSecurity
by default, it should be 0, double click, and confirm the value

go to HKEY_LOCALMACHINE > SYSTEM > CurrentControlSet > Control > Lsa
on the right-hand side, wtrite a new key
   a. right click > new > DWORD (32 bit) value
   b. name this value: LsaCfgFlags
by default, it should be 0, double click, and confirm the value
close the registry editor
restart the system

Edited by promo30
Link to comment
Share on other sites

26 minutes ago, MRoutt disse:

Checked Windows Features (Control Panel > Programs & Features > Turn Windows Features On or Off), Hyper-V was not checked.  As suggested I changed “turn on virtualization based security” from “not configured” to “disabled”.  Checked HKLM\System\CurrentControlSet\Control\DeviceGuard and HKLM\System\Control\LSA after making the local polity change, EnableVirtualizationBasedSecurity and LsaCfgFlags were both set to 0.  When I ran bcedit /enum I did not see an entry for hypervisorlaunchtype.  Am I missing something?  Should I go ahead and run bcdedit / set hypervisorlauch off anyway?  The OS here is Windows 10 Pro.

Windows Boot Manager

--------------------

identifier              {bootmgr}

device                  partition=\Device\HarddiskVolume1

path                    \EFI\MICROSOFT\BOOT\BOOTMGFW.EFI

description             Windows Boot Manager

locale                  en-US

inherit                 {globalsettings}

default                 {current}

resumeobject            {f460c2e4-47e5-11ec-8bc1-cb9986eebfcb}

displayorder            {current}

toolsdisplayorder       {memdiag}

timeout                 30

 

 

Windows Boot Loader

-------------------

identifier              {current}

device                  partition=C:

path                    \WINDOWS\system32\winload.efi

description             Windows 10

locale                  en-US

inherit                 {bootloadersettings}

recoverysequence        {f460c2e6-47e5-11ec-8bc1-cb9986eebfcb}

displaymessageoverride  Recovery

recoveryenabled         Yes

isolatedcontext         Yes

allowedinmemorysettings 0x15000075

osdevice                partition=C:

systemroot              \WINDOWS

resumeobject            {f460c2e4-47e5-11ec-8bc1-cb9986eebfcb}

nx                      OptIn

bootmenupolicy          Standard

if you use windows pro, don't do windows home method

Edited by promo30
Link to comment
Share on other sites

Finished out the Windows 10 Pro method by running bcdedit /set hypervisorlaunchtype off and rebooting.  No change.  Still get the message about OS being found to not be stable with virtualization turned on.  I also just saw your suggestion about turning off the use of advanced features of virtualization and have done so.  The message still appears though and thus I am curious about whether it specifically applies to the advanced features or virtualization as a whole.

Link to comment
Share on other sites

Just a quick update: it appears I have resolved this on my own by uninstalling and reinstalling Kaspersky Internet Security.  Saved license data and operational settings during the uninstall process and they were restored successfully.  Virtualization is back to just the single checkbox labeled "use hardware virtualization if available" and I have not seen the notification about the OS not being stable when using hardware virtualization.  Let me know if you have any questions.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.