Jump to content

Issues connecting with Slack (port 443 problems)


Recommended Posts

Posted (edited)

Hi

I have been using Kaspersky and Slack together for many years. Very recently, Slack has broken for me and is unable to connect. I went through all the troubleshooting with Slack, including a total reset and was still unable to connect. However, when I disabled Kaspersky, it started to work again.

I narrowed this down further by going to 'Settings -> Network Settings -> Monitor selected ports only -> deselect 443'. Confirming and reopening Slack will cause the application to work again.

Naturally, I don't want to disable 443.

To reitterate: This appears to be a recent change as I have used both for years together without an issue.

Any ideas on how to fix this?

System:

  • Windows 10 21H1
  • Kaspersky Total Security - 21.3.10.39(i)

Screenshots:

With 443 enabled:

image.png.c09229c788d57d02d0790084eb2c584f.png

With 443 disabled, Slack connection is okay:

image.thumb.png.d0694cee8704fa76cc309fd6203e053b.png

 

Thanks

 

Edited by Agent
Link to comment
Share on other sites

Hello @Agent, Welcome.

You can add Slack to your trusted addresses. Then the traffic through port 443 will not be scanned only at this address.
'Settings->Network settings->Trusted addresses->Add'.

Spoiler

image.png.28dadf38c30cf096c3ee63d09eb2b243.png

 

  • Like 2
Link to comment
Share on other sites

  • 3 weeks later...

Thanks for the reply.

The 'trusted addresses' option is greyed out, as I had "Do not scan encrypted connections" selected. This was due to previous issues with web development and the certificate. It appears that even with this selected, some issues can still happen.

I've kept 443 disabled for now, as I don't have time to further troubleshoot.

 

This issue now seems to be hitting more than just Slack however. Battle.net from Blizzard is now experiencing the same issue. It it unable to update games (connection failing). Disabling Kaspersky instantly resolves the issue, and games can be downloaded and updated. Port 443 scanning is still disable as mentioned above.

 

I'll look into what ports Battle.net is using and see what options I have. Much like Slack, I've used Battle.net and Kaspersky together for years without issue. It's a shame to see multiple applications suddenly having issues.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.