Jump to content

Firefox Update Issue when opening Kaspersky Safe Money session


Recommended Posts

I have discovered a problem with Firefox updates when opening a Kaspersky Safe Money browser session.

In Firefox, Tools - Settings, Firefox Updates, it shows Firefox is being updated by another instance and the option to Check for Updates has been greyed out (screenshot attached).

When you use the Help, About Firefox option it also says that Firefox is being updated by another instance (see screenshot attached).

When you check the same Settings in the Safe Money 2nd session, it shows exactly the same information and you cannot update Firefox in any session.

Previously In Firefox, when you opened a 2nd session it said that Firefox was being updated by another instance and the option to Check for Updates was greyed out but you could still update Firefox in the main session.

This is not a problem when using Chrome or Edge and if you open a bookmark in a Private Window in Firefox, there isn't a problem so it must be related to the way Safe Money works with Firefox so can anyone suggest anything to fix this or does it need Tech Support to look into it for fixing?

Thanks.

Firefox Update option gone 1.jpg

Firefox Update option gone 2.jpg

Link to comment
Share on other sites

FYI here is the information about Windows and Kaspersky:

 

Windows Version - Windows 10 Pro 21H2 (OS Build 19044.1766)

Kaspersky Internet Security - Application Version 21.3.10.391 (i)

Link to comment
Share on other sites

Hello @Hawkeye

Welcome back!

Spoiler

image.thumb.jpeg.8e3b1ddf79075a5522bb21de86825fc0.jpeg

  1. Is there more than one Firefox user profile
  2. Using (Firefox) about:support, is the Firefox Profile folder aligned with: C:\ProgramData\Kaspersky Lab\SafeBrowser\~
  3. Just so we're clear, is the actual issue that you're unable to manually control Firefox updates
  4. Is the "Firefox is being updated by another instance", message there all the time ?
  5. We're not sure how " if you open a bookmark in a Private Window in Firefox, there isn't a problem " ties into the SafeMoney / Firefox update issue, can you explain more please? 
  6. Logging a Support request is a good idea as well👍 

Please let us know? 

Thank you🙏

Flood🐳+🐋

Edited by Flood and Flood's wife
Link to comment
Share on other sites

Thanks again for being the first to come to my rescue as you've been very helpful in the past. 😀 👍

To answer your points above:

1) No

2) I'm not quite sure what you mean but the Firefox Profile folder shows as  C:\Users\david\AppData\Roaming\Mozilla\Firefox\Profiles\o7oohydm.DWA

3) Yes

4) As you discovered yourself, no.  It only appears when a Safe Money window is opened and once it has been closed the Firefox updating returns to normal.

5) Sorry, I should have been clearer. If Safe Money is disabled and you open a bookmark in a New Private Window, then the normal update message is there. If Safe Money is enabled and you open a bookmark in a New Private Window which then opens a Safe Money Window, the update message changes to "Firefox is being updated by another instance" in all windows and the Settings. Once you close the Safe Money window, the Firefox updating and message returns to normal in all windows, so there is something about opening a Safe Money Window that changes it.

I hope this is helpful and don't hesitate to ask for more details. 👍

 

Link to comment
Share on other sites

Hello @Hawkeye

You're more than welcome😊!

Thank you for the information!

  • We're not sure we've come to the same conclusions as you in relation to Q.4, however, that may be due to our not fully understanding the issue🤔
  • Re 5. "If Safe Money is disabled", what do you actually mean by "disabled"? 
  • Re 5. Please provide an example/steps, with URL(s) please, we'll see if we can replicate the issue? 
  • We do think it's worthwhile logging a support case as well. 

 

Thank you🙏

Flood🐳+🐋

Link to comment
Share on other sites

Re 5: Right click the KIS icon in the tray and select Settings. In the Protection section, scroll down and select Safe Money to open the Safe Money Settings and switch it Off and save it.

This is what I was referring to when I said Safe Money is disabled.

  • Thanks 1
Link to comment
Share on other sites

  • 4 weeks later...

1. In a new tab in Firefox, type or paste "about:config" in the address bar and press Enter/Return. Click the button promising to be careful. 2. In the search box above the list, type or paste "roots" and pause while the list is filtered 3. Double-click the "security.enterprise_roots.enabled" preference to switch the value from false to true.

 

Check with this. I found on Mozilla website.

 

Regards,
J Wick

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.