Jump to content

Error installing Kaspersky Endpoint Security 11.3.0 for Linux


Recommended Posts

The latest version, 11.3.0, of Debian package (.deb) from Kaspersky Endpoint Security for Linux is not installing correctly inside chroot.

I can install version 11.2.0 without problems.

 

The /var/log/kaspersky/kesl/kesl_launcher.log have this error:

2023-03-24 13:59:30 launcher {pid:6493}: <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< exit(1) <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
2023-03-24 13:59:42 launcher {pid:6498}: =================== --install 1679666321 --package-type deb ===================
2023-03-24 13:59:42 launcher {pid:6498}: Mode: Install
2023-03-24 13:59:42 launcher {pid:6498}: Product not running (Can't open "/var/run/wdserver.pid" file. Reason: No such file or directory)
2023-03-24 13:59:42 launcher {pid:6498}: Is running: 0
2023-03-24 13:59:42 launcher {pid:6498}: Running cp -rplvPT /var/opt/kaspersky/kesl/install_11.3.0.7441/ /var/opt/kaspersky/kesl/11.3.0.7441_1679666321 ...
2023-03-24 13:59:42 launcher {pid:6498}: Setting 'en_US.UTF-8' localization ...
2023-03-24 13:59:42 launcher {pid:6498}: Loc directory: "/var/opt/kaspersky/kesl/11.3.0.7441_1679666321/opt/kaspersky/kesl/shared/loc/"
2023-03-24 13:59:42 launcher {pid:6498}: Localization 'en_US.UTF-8' has been set
2023-03-24 13:59:42 launcher {pid:6498}: Language: en
2023-03-24 13:59:42 launcher {pid:6498}: Product name: Kaspersky Endpoint Security 11.3.0 for Linux
2023-03-24 13:59:42 launcher {pid:6498}: Error installing the application
2023-03-24 13:59:42 launcher {pid:6498}: /home/builder/a/c/d_00000000/s/product/kesl/supervisor/utils.cppThrow in function lfs::supervisor::Path lfs::supervisor::ResolvePath(const char*)
Dynamic exception type: boost::exception_detail::error_info_injector<std::runtime_error>
std::exception::what: chkconfig not found

 

The chkconfig binary is not available in Debian based distros.

WhatsApp Image 2023-03-23 at 18.59.14.jpeg

Edited by Wilton Rodrigues
Link to comment
Share on other sites

  • 8 months later...

Столкнулся с той же проблемой, после установки KICS for Linux nodes 1.3

Нигде не написано, но после установки, скрипт принятия пользовательского соглашения,

в консоли выполнить с правами рута скрипт  /opt/kaspersky/kics/bin/kics-setup.pl

типа так su -c "/opt/kaspersky/kics/bin/kics-setup.pl" root

и ответить на вопросы.

 

Link to comment
Share on other sites

  • 2 weeks later...

У меня аналогичная проблема с версией 11.3.0-7508 (пакет kesl-11.3.0-7508.cert.x86_64.rpm) на Oracle Linux 8.

В логе после запуска скрипта настройки (после установки) или запуска руками через "systemctl start kesl":

2023-12-29 04:34:48 launcher {pid:1243}: Product not running (Can't open "/var/run/wdserver.pid" file. Reason: No such file or directory)

Поставить более новую версию не могу, т.к. нужен именно сертифицированный KESL, а более свежих сертифицированных версий нет.

Есть подозрение, что это связано с особенностями обработки символических ссылок в некоторых дистрибутивах. Если раньше сервисы работали с ссылкой "/var/run/" на папку "/run/" без проблем (а "/var/run/" это именно ссылка, а не каталог), то сейчас некоторые сервисы как раз выдают ошибку "Can’t open PID file /var/run/*.pid". Думаю, копать надо в эту сторону.

Я пытался поправить файл "/opt/kaspersky/kesl/shared/kesl.service":

PIDFile=/var/run/wdserver.pid
заменить на
PIDFile=/run/wdserver.pid

Но это не помогло. Судя по логу pid-файл всё равно пытается открываться по адресу "/var/run/wdserver.pid". Либо правлю не там, либо где-то глубоко зашито.

Link to comment
Share on other sites

  • 1 month later...

Здравствуйте. 

Что то удалось решить по данному вопросу?

т.к. тоже столкнулся с этой бедой (с сертифицированным KESL), и подозреваю, что дело именно в ЗПС, если ее отключить или перевести в отладочный режим, все запускается.

Link to comment
Share on other sites

  • 4 months later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now


×
×
  • Create New...