Skip to content
View in the app

A better way to browse. Learn more.

Kaspersky Support Forum

A full-screen app on your home screen with push notifications, badges and more.

To install this app on iOS and iPadOS
  1. Tap the Share icon in Safari
  2. Scroll the menu and tap Add to Home Screen.
  3. Tap Add in the top-right corner.
To install this app on Android
  1. Tap the 3-dot menu (⋮) in the top-right corner of the browser.
  2. Tap Add to Home screen or Install app.
  3. Confirm by tapping Install.

Восстановил сервер,но KSC не подключается

Что имеем:
Сервер с KSC
OS: Windows server 2016 (Версия 1607 сборка ОС 14393.2248)
Программа: Kaspersky Security Center, версия 14.2.0.26967 

Сервер c SQL
OS: Windows server 2008 R2 / Версия 6.1 (сборка 7601: Service Pack 1)
SQL: MSSQL 2012

Проблема кратко: KSC не подключается к серверу SQL.
Проблема развёрнуто:
До проблемы, на сервере с БД была установлена MSSQL 2008
Сервер сломался и унёс с собой 2 винта (1 hdd = OS; 2 hdd = Логи БД и сама SQL)
OS я восстановил, SQL установил новую MSSQL 2012, Базу данных KAV я тоже восстановил (бекапы делаются ежедневно посредством SQL)
Однако KSC не подключается к SQL... ну или проблема в чем то еще...

проблемы которые я накопал на сервере KSC
1) Журнал событий показывает такую ошибку: Время попытки подключения к базе данных истекло после 600 (сек).. #1950 (18456) Generic db error: "18456 'Ошибка входа пользователя "sa".{42000};' LastStatement='ADODB.Connection'"
2) Сервер администрирования выдаёт ошибку подключения (скрин)

так же не знаю, может какие то роли или пользователя надо выдавать на БД KAV ?

подскажите пожалуйста, куда копать ?
 два месяца пытаюсь восстановить, но я новичок в сфере сис админа, по этому могу копать вообще не туда.

tvnviewer_29.01.25_15.45.31.png

Solved by Misketik

Featured Replies

Здравствуйте, обновите версию SQL Server. 2012 версия уже не поддерживается вроде. 

  • Author
12 часов назад, mike 1 сказал:

Здравствуйте, обновите версию SQL Server. 2012 версия уже не поддерживается вроде. 

это будет сложновато конечно... Но разве в данной ситуации это имеет смысл ?  если до падения сервера с sql была версия вообще 2008 года и работало.

  • Author

Хочу еще добавить замечание. (внести изменение в первый пост не получается)
Если сделать полную переустановку KSC и создать БД KAV, то всё прекрасно работает.
Но если я попытаюсь перезаписать KAV своим бекапом от старой рабочей KAV, то KSC опять начинает хандрить и показывать проблемы в работе как в первом моём сообщении.

  • 3 weeks later...
  • Author
  • Solution

Проблема так и не решилась.
Пришлось всё удалять и создавать всё с нуля...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

Account

Navigation

Search

Search

Configure browser push notifications

Chrome (Android)
  1. Tap the lock icon next to the address bar.
  2. Tap Permissions → Notifications.
  3. Adjust your preference.
Chrome (Desktop)
  1. Click the padlock icon in the address bar.
  2. Select Site settings.
  3. Find Notifications and adjust your preference.