Help - Search - Members
Full Version: [solved]Virus won't let me install Kaspersky on my computer
Kaspersky Lab Forum > English User Forum > Virus-related issues
Omar DD
This is the second time in happens to me, one was a very long time ago and I came here for help, and you guys were able to resolve my issue, well here I'm back! biggrin.gif
Anyways, I have a virus on my computer that will not let me install kaspersky for some reason, so here is the AVZ file log:Click to view attachment
Also, I tried creating the GSI log, but I had it running for a long time and nothing happened, and also there was no progress bar, is it supposed to work like that?
I also ran the AVPTOOL, scanned everything and it found a few viruses and got rid of them, butt I think my computer might still be infected, thanks for your help smile.gif
Omar DD
I've been trying to get that GSI log while you guys go over my AVZ file log, but the time counter keeps resetting itself, after 1.5-2 hours it goes back to 0 and starts over, and then again there's no progress bar, is that normal?
will not let me install kaspersky for some reason
Please post the exact error message.

GSI: Please right click gsi.exe and run as Administrator, and also try in Safe mode.

Please try this: click Stop Report. Then when prompted with "Do you really want to stop scan?", click "No".

If still no go, please review these two threads/posts: and
Omar DD
Here's the image of the error I get when I try to install Kaspersky, also I have tried restoring my computer from a save point but it always fails, it says that it could not access a file and so nothing happened :|
Click to view attachment

P.S: I have to go swimming right now I will try getting the GSI report in a bit
Omar DD
I followed this first thread:;#entry1157586
like you asked me and when I press "execute," a message appears and tells me "class not registered"
and then I tried everything on the second thread with no avail either, I even went to this folder like the guy over there did
BUt..... it won't let me delete the items I have there :\
any ideas on what to do?
I know this problem from Optix Pro.....

Could you please post your Process-List ?

(Use the Taskmanager and go to "Processes")
Omar DD
Haha, well I said "f..k it" and restored my computer to factory settings biggrin.gif!
problem fixed, hehe
anyways thank you guys for your time smile.gif

that was my second possibility...xD

Keep Rocking b_punk.gif
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2017 Invision Power Services, Inc.