Jump to content

Recommended Posts

Same issue here

 

Network sharing does not work properly with KIS 2009 enabled. The firewall blocks it. Disabling KIS 2009 temporarily is necessary for network sharing.

 

Any mods or users have a solution?

 

edit: Well not every time I update. I started using KIS 7 about a month ago, and they updated to KIS 2009 just recently, so I installed it on my computers. KIS 7 network sharing worked fine.

 

Using two Vista computers, one laptop, one desktop, both on a wireless network (WRT54G router, stock firmware, not DD-WRT modded). Laptop is 32-bit Vista Home Premium, the desktop is 64-bit Vista Ultimate. Cannot access either computer from the other with KIS 2009 enabled.

 

Should also add that I can see the computers on the network, but cannot access them.

Edited by shiarua

Share this post


Link to post

1) Update your NIC drivers

2) Make sure network type is Local Area Network

3) If you use v7, turn OFF stealth mode

4) I have 3 Vista SP1 32 bit machines sharing files just fine (make sure you set Vista settings to Home Network too)

5) Make sure your NTFS + Share permissions = give you enough access

Edited by Whizard

Share this post


Link to post

1)Using latest drivers

2)Check

3)Using v8

4)All settings set properly

5)I'll have to try resetting them. My D drive was set to be shared with all users on the network and they have full access.

 

*********SOLVED**************

 

 

Here is the solution.

 

1)Right click on the Kaspersky tray icon.

2)Select Settings

3)Go to the System Security page

4)Click on the Firewall settings button

5)Switch to the "Networks" tab

6)Select your home network connection

7)Right click and change from "Public Network" to "Local"

8)Click Ok to close the window

9)Click apply at the bottom of the settings window

10)Click Ok to close the settings window

11)Apply these settings to all the computers on the network

 

Edited by shiarua

Share this post


Link to post

Of course! Public category is for hostile networks :)

 

All network connections on your computer are monitored by the Firewall. The Firewall assigns a certain network status to each connection. Depending on the network status, the Firewall will apply various network activity filtering rules.

 

Once you get connected to a new network, the Firewall will display a notification on the screen. You will be offered to assign a status to the detected network, depending on which the network activities will be filtered:

 

Public network (Internet). We recommend that you select this status for networks not protected by any anti-virus applications, firewalls or filters (for example, for Internet cafe filters). Users of such networks are not allowed access to files and printers located on or connected to your computer. Even if you have created a shared folder, the information in it will not be available to users from networks with this status. If you allowed remote access to the desktop, users of this network will not be able to obtain it. Filtering of the network activity for each application is performed according to the rules for this application. By default this status is assigned to Internet.

 

Local Network. We recommend that you assign this status to networks to which users you wish to grant access to files and printers on your computer (for example, for your internal corporate network or home network).

 

Trusted network. This status is only recommended for areas that you consider absolutely safe within which your computer will not be subjected to attacks or unauthorized attempts to gain access to your data. If you select this status, all network activity is allowed within this network.

Types of network activities allowed for networks with a certain status depend on the settings of the default packet rules. You change these rules.

 

The network status is defined the a set of rules being used for filtering the network activities for the particular network.

Edited by Whizard

Share this post


Link to post

Ah, I dont recall getting prompted by KIS 2009 at all about selecting the network type. Probably why it was overlooked. Mind posting where that was copied from? Looks like it has a ton of information and probably a good read/tutorial. Is is in the sticky?

edit: Nvm, I'll just read through the stickies... tons of info there. I'm interested in learning the program inside and out. As far as I've seen, it is one of the most comprehensive internet security suites I've seen. Very nice user control for advanced configuration.

Edited by shiarua

Share this post


Link to post
Mind posting where that was copied from? Looks like it has a ton of information and probably a good read/tutorial.

Help file. Yes.

Share this post


Link to post

I think Automatic mode defaults to Internet, thats the reason for all the troubles :)

Share this post


Link to post
1) Update your NIC drivers

2) Make sure network type is Local Area Network

3) If you use v7, turn OFF stealth mode

4) I have 3 Vista SP1 32 bit machines sharing files just fine (make sure you set Vista settings to Home Network too)

5) Make sure your NTFS + Share permissions = give you enough access

 

Hi, It doesn't work for me! I mean your bullets 1 to 5.

I have a local Microsoft network for 3 pcs:

1. Hardwired XP Media Center SP3

2. Hardwired Vista SP1

3. Wireless XP Pro

 

Yesterday I upgraded to KIS 2009 and my network stopped working along with my shared printer.

If I disable Kaspersky Firewall - it's working.

 

And I read the entire thread and made sure I did everything suggested but it's still not working.

 

Please help.

Share this post


Link to post

1) Ping the machines by their LAN IP

2) Try accessing them via UNC path \\IP Address \\NETBios name

3) What error messages you get?

Share this post


Link to post
1) Ping the machines by their LAN IP

2) Try accessing them via UNC path \\IP Address \\NETBios name

3) What error messages you get?

 

I have KIS 2009 installed on my XP SP3 pc. From this pc I can ping my Vista, and then able to get there through Win Explorer (I have to type in login and password).

 

Vice versa doesn't work - my Vista pc doesn't see my XP pc. Ping brings 100% loss. BTW on the Vista there is Mc Afee internet security installed, but with KIS 7 on my XP machine it worked just fine.

 

The error occurs when my KIS firewall enabled on my XP pc. When I disable it - everything is fine.

Share this post


Link to post

I also have this problem. I have a laptop and a pc. The firewall on the PC has no problems but on the laptop i can not change the network to local, the option is grayed out.

 

Both the PC and the laptop have 2 nics. The laptop has a wireless and an onboard nic. The wireless works fine but the onboard nic is experiencing the problem. The laptop is an older Dell Latitude C840. It's the same issue as the above person, when the Kaspersky firewall is turned off it works fine, and it seems the problem is related to not having the option to make it a local network.

 

Any advice for me?

 

 

Share this post


Link to post

>>I have KIS 2009 installed on my XP SP3 pc. From this pc I can ping my Vista, and then able to get there through Win Explorer (I have to type in login and password).

Your permissions are incorrectly setup. Set your Vista for Home Network mode.

 

>>Vice versa doesn't work - my Vista pc doesn't see my XP pc. Ping brings 100% loss. BTW on the Vista there is Mc Afee internet security installed, but with KIS 7 on my XP machine it worked just fine.

You would have to suspend it for troubleshooting. Also make sure your NIC drivers are up to date

 

>>I also have this problem. I have a laptop and a pc. The firewall on the PC has no problems but on the laptop i can not change the network to local, the option is grayed out.

Screenshot please?

 

>>It's the same issue as the above person, when the Kaspersky firewall is turned off it works fine, and it seems the problem is related to not having the option to make it a local network.

Its a complete different issue. Having one NIC enabled at a time is a better idea for troubleshooting.

 

Please ensure you have SAME products with same version numbers installed on both machines .

Edited by Whizard

Share this post


Link to post

Please ensure you have SAME products with same version numbers installed on both machines .

 

 

8.0.0.454 on both (from the same installer) - just upgraded from v6.0 (or was it v7... I forget)

 

I'll keep trying different things, just a bit limited on time until Thursday

 

Thanks for the reply

Edited by jbe

Share this post


Link to post
Hi, It doesn't work for me! I mean your bullets 1 to 5.

I have a local Microsoft network for 3 pcs:

1. Hardwired XP Media Center SP3

2. Hardwired Vista SP1

3. Wireless XP Pro

 

Yesterday I upgraded to KIS 2009 and my network stopped working along with my shared printer.

If I disable Kaspersky Firewall - it's working.

 

And I read the entire thread and made sure I did everything suggested but it's still not working.

 

Please help.

 

 

This is the same for me. I have uploaded my info for you to see

 

http://gsi.kaspersky.fr/lire.php?hl=en&amp...amp;Microsoft=0

 

Same story, everything working fine until the upgrade.

 

I hope we can get this fixed very soon....

 

many thanks in advance

Share this post


Link to post

I've had endless trouble trying to get my XP Home SP3 desktop to network and share its files and printers with my new Vista Home Premium laptop. Each time I tried to set this up, I could no longer access my router or the internet from my desktop and the laptop could not see the desktop machine. I was about to give it up completely, but after reading this thread, I looked at the KIS firewall setting on the desktop and the home network was already set to Local. So, next, I, disabled the KIS firewall and after yet another re-boot, suddenly everything seemed to work. I then re-enabled the KIS firewall and things are still working, even after a re-boot. I did have to set the home network to Local on the laptop, though, as that was set to Public Network. I just thought people might find this experience useful.

Share this post


Link to post
Please ensure you have SAME products with same version numbers installed on both machines .

 

I have two DIFFERENT products - XP SP3 has KIS 2009 and Vista has Mc Afee internet security installed, but with KIS 7 on my XP machine it worked just fine .

 

I also tried the suggestion to disable firewall and then reboot and then enable it again - it didn't help either.

With disabled firewall - it's fine and with enabled it's broken.

 

I have the latest build of KIS - 8.0.0.454 installed.

 

Is there any other way than to rollback to KIS7 ???

Share this post


Link to post
I also tried the suggestion to disable firewall and then reboot and then enable it again - it didn't help either.

With disabled firewall - it's fine and with enabled it's broken.

 

1) Ping from one machine to another. Do this test two times

2) If that does not work, you have a configurational problem

3) Ensure you have updated your drivers (http://gsi.kaspersky.fr) will aid you

4) Exit McAfee product and try again

 

Share this post


Link to post
shall do and report back thank you:-)

 

I have upgraded both machines to 8.0.0.454 and updated it. My vista machine still cant see my xp machine and vice versa. Can you please suggest something please.

 

Many thanks for your time and trouble.

 

Dross :-)

Share this post


Link to post
I have upgraded both machines to 8.0.0.454 and updated it. My vista machine still cant see my xp machine and vice versa. Can you please suggest something please.

 

Many thanks for your time and trouble.

 

Dross :-)

On your xp machine look into IrpStackSize, a registry entry that is often missing: http://support.microsoft.com/kb/285089. If you need to add this entry start with number 25 decimal. Be sure to restart after making change. You also may need to experiment with number. If so be sure to restart after each change. You should back up the registry before making changes. "ERUNT" is a free program that does it. You can also export from the registry itself.

Share this post


Link to post
On your xp machine look into IrpStackSize, a registry entry that is often missing: http://support.microsoft.com/kb/285089. If you need to add this entry start with number 25 decimal. Be sure to restart after making change. You also may need to experiment with number. If so be sure to restart after each change. You should back up the registry before making changes. "ERUNT" is a free program that does it. You can also export from the registry itself.

 

shall try tonight and report back :rolleyes:

Share this post


Link to post
shall try tonight and report back :rolleyes:

 

 

Did that and even raised the number to 40 but to no avail. My laptop just cannot see my Home pc. what has happened with upgrading to the 2009 version?

 

hope you can help.

 

:icon20:

Share this post


Link to post
Guest
This topic is now closed to further replies.

×

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.