HughJass

Cant Print with network printer

7 posts in this topic

Greetings,

Just installed a new HP3210 printer via network cable instead of the USB since it wouldnt reach where I wanted to put the printer.

Anyway, I cannot print unless I turn off Kap AntiHacker (1.8).

I have looked in the settings but do not see how to allow this to happen.

Plus I get messages that KAH has blocked an attack from the same IP as the printer.

 

Thanks in advance

Share this post


Link to post
Share on other sites

This will depend on your setup (you did not mention if this was a connection by router, or a connection directly to your PC via ethernet/modem).

 

If you have a fixed IP for the printer on your network then a simple rule can fix this:-

Open AH, select "Packet filter rules" / New.

In the rules window that appears-

Protocol, select "Other IP protocol"

Properties, tick "Remote address"

In the rules description, change to "allows" then click on "Specify the address", in the window that appears, select "Subnet address" and enter the address of your printer (and the subnet mask, which is normally 255.255.255.0)

Click "Next" and enter a name for the rule

Click "finish"

 

NOTE: This rule will allow ALL comms between the PC and the remote IP

Share this post


Link to post
Share on other sites

Thanks for the answer,

Yes I am connected through a router.

Worked Perfect!!

This will depend on your setup (you did not mention if this was a connection by router, or a connection directly to your PC via ethernet/modem).

 

If you have a fixed IP for the printer on your network then a simple rule can fix this:-

Open AH, select "Packet filter rules" / New.

In the rules window that appears-

Protocol, select "Other IP protocol"

Properties, tick "Remote address"

In the rules description, change to "allows" then click on "Specify the address", in the window that appears, select "Subnet address" and enter the address of your printer (and the subnet mask, which is normally 255.255.255.0)

Click "Next" and enter a name for the rule

Click "finish"

 

NOTE: This rule will allow ALL comms between the PC and the remote IP

Share this post


Link to post
Share on other sites

I also am having intermittent problems with a network printer and turning off various parts of the software sometimes allows printing and sometimes does not. I'm using internet security 6 and the post above has instructions that are slightly different to my version and I've tried many different combinations of ip addresses etc etc and still can't print. Interestingly I can print from Excel and Publisher and other programs, but not Word or PDF files. Can you help me please?

Share this post


Link to post
Share on other sites

hello

go under settings->Anti-hacker->settings->zones and uncheck stealth for every zone, also on the zone with your printer make sure it's set to either local network or trusted. reboot after making those changes.

Share this post


Link to post
Share on other sites

Hi,

 

Sorry to threadjack, but I have the same problem with my Epson printer after installing Kaspersky Internet Suite 6.0.2.621

 

The printer is connected to my computer through a USB connection, it is also a shared network printer. Another computer on the network tried to print, but the printer wouldn't respond (I saw it's file on the printing queue, but printer just wouldn't start).

 

I've tried scanning using the printer, it works fine, so I assumed the connection between my printer and the computer is working fine.

 

Any solution to this? How do I get the network shared printer to print files from another computer?

Share this post


Link to post
Share on other sites

hello

does it help to disable anti-hacker and try to print with it disabled?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now