lapin

Autorun is not working

15 posts in this topic

I did the System Restore check from KIS 2009 and found some problems. Maybe i didn't see well or this feature from KIS is not working fine but i was told to fix some problems with autorun. From that time autorun is not working.

I've tried too many things. I've searched in google about fixing reg keys, policies, services and none of them worked.

The problem is that i cannot boot from DVD/CD in Virtual PC so i cannot install any OS in Virtual PC.

My autorun's future is in your hands.

Share this post


Link to post
Share on other sites

hello

did you actually disable autorun in system restore. is the cd woring ( can you open cds via double click etc)

Share this post


Link to post
Share on other sites
hello

did you actually disable autorun in system restore. is the cd woring ( can you open cds via double click etc)

Yes i disabled the autorun from the KIS System Restore.

CD/DVD is working and i can open the CD/DVD via double click.

Share this post


Link to post
Share on other sites

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

delete NODriveTypeAutorun

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

set Autorun Value to 1.

reboot. does it work afterwards?

Edited by Lucian Bara

Share this post


Link to post
Share on other sites

Also try Start>Run>gpedit.msc

ComputerConfiguration>AdministrativeTemplate>System... Disable "Turn off autoplay"

UserConfiguration>AdministrativeTemplate>System... Disable "Turn off autoplay"

Share this post


Link to post
Share on other sites
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

delete NODriveTypeAutorun

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

set Autorun Value to 1.

reboot. does it work afterwards?

Nope :(

Here are the links that i followed exactly the instructions that they gave and still nothing:

http://www.howtogeek.com/howto/windows-vis...-windows-vista/

http://www.mydigitallife.info/2008/01/14/a...-windows-vista/

Also i noticed that after i changed the hexadecimal value of NoDriveTypeAutoRun to 0x00000091 or to 0x00000080 and i restarted the system the value was automatically set to 0x000000FF which according to the second site means that autorun is disabled.

 

Now i restarted the system and autorun isn't working.

3 differences:

1)Virtual PC Boot is working

2)there is an icon in the DVDrom while previously there wasn't:

post-83630-1212827653_thumb.jpg

3)The key that you told me to delete didn't appeared again.

Thank you for your help so far but now there is a small problem:

Can you help me fully restore the autorun?

Share this post


Link to post
Share on other sites
Also try Start>Run>gpedit.msc

ComputerConfiguration>AdministrativeTemplate>System... Disable "Turn off autoplay"

UserConfiguration>AdministrativeTemplate>System... Disable "Turn off autoplay"

I don't have this "Turn off autoplay"in my policy.

Anything else guys?

It can't have just disappeared from one time to the other. Is it a bug, what?

I am currently installing Windows Vista SP1 on a Virtual PC and i will do the same. I will let you know the results.

Share this post


Link to post
Share on other sites
It can't have just disappeared from one time to the other. Is it a bug, what?

of course it's a bug :dash2: , you disable autoplay and autoplay isn't working...wow the logic behind it is amazing.

Try importing this reg:

1.zip

Edited by Lucian Bara

Share this post


Link to post
Share on other sites
of course it's a bug :dash2: , you disable autoplay and autoplay isn't working...wow the logic behind it is amazing.

Try importing this reg:

1.zip

Please man don't be ironic.

I disabled the autoplay but i can't revert it back. You think this is usual?(you surprised me by saying that)

Why you don't check it on yourself? Make exactly what i did and we will see if it is a bug or not.

Don't play the expert(besides we know you are) if you have never come up with the situation.

I have already done many times what the reg file does. Autoplay is not still working.

Finally i want to ask any beta tester to reproduce the steps and post the results here. But first better make a system restore point.

Share this post


Link to post
Share on other sites

actually i did, i even used a software to trace what was changed, those 2 keys are the only things which are changed on an xp system.

Edited by Lucian Bara

Share this post


Link to post
Share on other sites

...he's not the one being ironic.

 

 

I can't reproduce this. It disables autorun like it should and I can reenable it at will.

Share this post


Link to post
Share on other sites

That's why i asked about being or not a bug. Maybe it is only in Vista. Maybe it is only in my system. Maybe my Vista got crazy. In 10 minutes i will install it on Virtual machine with Vista and let you know. If the same results come up i will check it in Virtual machine again but with XP this time.

Anyway thanks a lot for your help. Appreciated and sorry if i was rude before.

Share this post


Link to post
Share on other sites
...he's not the one being ironic.

I can't reproduce this. It disables autorun like it should and I can reenable it at will.

Same here Baz...running SP3. Everything seems to run like it should?????

Share this post


Link to post
Share on other sites
Same here Baz...running SP3. Everything seems to run like it should?????

Thanks Lucian I had the same problem but importing that reg fixed it.

Share this post


Link to post
Share on other sites
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

delete NODriveTypeAutorun

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

set Autorun Value to 1.

reboot. does it work afterwards?

 

Brilliant Lucian, this has fixed a problem that has been driving me nuts for weeks - many thanks

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.