Jump to content
Jeff-22

Chrome self signed certificate, Cannot guarantee... ... [merged]

Recommended Posts

I think I might have stumbled onto something. Yesterday I opened Google Home app on my phone and went into the device settings for both of my chromecast devices. In the privacy section I turned off "send chromecast device usage data and crash reports to Google" then rebooted the chromecast device. After finishing the same for both devices, I then rebooted my Windows 7 machine. After doing so everything seemed to be working fine. No more self signed certificate warnings, the "Cast" button on Chrome toolbar was working correctly, all 4 of my Google devices (2 chromecast & 2 Google Home) were functioning  and communicating on port 8009 with no issues... read my post from above: 

A couple of hours later I installed some windows updates and had to reboot my machine. After the reboot when I opened chrome the self signed certificate warnings came back and the "cast" button on Chrome toolbar was no longer functioning correctly (couldn't find any devices to cast to). 

I decided to try the same thing again and when I went into the settings for my chromecast devices one of them had the "send chromecast device usage data and crash reports to Google" turned on. I turned it off, rebooted both chromecast devices as well as my windows 7 machine and everything was fixed again. After about 18 hours of no "certificate warnings" I decided to reboot my windows 7 machine again to see what would happen. Success!!! After reboot, everything was still working correctly.

The thing that puzzled me was the people posting on here that have the same "self signed certificate warnings' that do not have a Chromecast device. Why are they having the same issue that for me seems to be caused by my chromecast devices connecting with Google to send usage and crash reports.

I decided to go into my Chrome settings to look them over. I had usage and error reporting turned off, so I  to turned it on to see what happened. As I expected, the certificate warnings came back and the "cast" button on Chrome toolbar wasn't working again. I went back into Chrome settings turned usage and error reporting off, rebooted my machine and Voila!!!!! No more self signed certificate warnings and cast button on chrome toolbar is working again.

Here's what I would suggest for everyone that's having the "self signed certificate" warnings. Hopefully this will work for everyone whether they have Chromecast devices or not.

With Chromecast: 

  • Go into the settings for your Chromecast device(s) and turn off usage and error reporting, then reboot the Chromecast device(s)
  • On your affected computer(s), open chrome and go into settings, turn off usage and error reporting, close chrome, reboot computer.

Without Chromecast:

  • On your affected computer(s), open chrome and go into settings, turn off usage and error reporting, close chrome, reboot computer.

I should also add that I never turned off SSL scanning, or added any exclusions at all to Kaspersky, or Disabled Encrypted connections scanning, or anything else which was suggested several times in this thread. For those of you that did any of those things, I would suggest you put everything back to how it was and try my suggestion above.

Share this post


Link to post
3 hours ago, Ray5on said:

I am having the same problem when opening chrome,  This started happening when I updated to the latest version of Kaspersky a few days ago. I also get the message to continue or disconnect. Clicking continue, I also have to click don't warn me for 30 mins then click multiple times on continue again for chrome to work. I do not have a Chromecast device and only use the Chrome browser. This is happening on 2 x laptops and a desktop in my home after updating to the latest Kaspersky version.

 

V

If I disable encrypted connections it prevents safe money from running. this is not the fix I need

kaspersky 2.jpg

kaspersky.jpg

Share this post


Link to post
6 minutes ago, Ray5on said:

If I disable encrypted connections it prevents safe money from running. this is not the fix I need

First I would like to say that I would never click "continue" on a certificate warning, I always click "disconnect."

Did you try my suggestion of turning off usage and error reporting to Google in your Chrome settings (also chromecast settings if you have chromecast).  You're won't have to disable any encrypted connections, add any exclusions, or compromise the security of your computer in any way. It worked for me, no more "self signed certificate warnings"

Share this post


Link to post
15 minutes ago, VyperD65 said:

First I would like to say that I would never click "continue" on a certificate warning, I always click "disconnect."

Did you try my suggestion of turning off usage and error reporting to Google in your Chrome settings (also chromecast settings if you have chromecast).  You're won't have to disable any encrypted connections, add any exclusions, or compromise the security of your computer in any way. It worked for me, no more "self signed certificate warnings"

Thanks for this suggestion. changed chrome reporting but can't fund chromecast settings for reporting.. still looking

Share this post


Link to post

Here's how I solved this problem: One of the suggestions that I saw in a different form to fix this problemwas to remove the Privacy Badger extension on Chrome, so I went to my Chrome extensions to see if I had installed that extension. checked my Chrome extensions and I did not have that one installed, but while looking over the other Extensions I noticed that I did have the Kaspersky Protection extension installed--but it was not switched on. I flipped the toggle on to enable the extension, and then when I launched Chrome, the error message "cannot guarantee authenticity of the domain to which encrypted connection is established" completely disappeared. I've been playing around with Chrome, going to various sites (encrypted and not), and I also re-installed the extension that I'd originally suspected had had something to do with the problem before I found it was one that others had experienced. I'm no longer getting this pop-up message from Kaspersky in Chrome.
 

Share this post


Link to post

I had the same problem.  I cleared my browsing history and cache in Chrome and, so far, it seems to have fixed the problem.  Hopefully permanently!

Share this post


Link to post
19 minutes ago, Teke said:

Here's how I solved this problem: One of the suggestions that I saw in a different form to fix this problemwas to remove the Privacy Badger extension on Chrome, so I went to my Chrome extensions to see if I had installed that extension. checked my Chrome extensions and I did not have that one installed, but while looking over the other Extensions I noticed that I did have the Kaspersky Protection extension installed--but it was not switched on. I flipped the toggle on to enable the extension, and then when I launched Chrome, the error message "cannot guarantee authenticity of the domain to which encrypted connection is established" completely disappeared. I've been playing around with Chrome, going to various sites (encrypted and not), and I also re-installed the extension that I'd originally suspected had had something to do with the problem before I found it was one that others had experienced. I'm no longer getting this pop-up message from Kaspersky in Chrome.
 

 

The problem occurs after a reboot typically.  Try rebooting and see if it's still clear.  Your solution did not work for me.  Nothing works that i've seen described in this forum, so far.

Share this post


Link to post
1 hour ago, VyperD65 said:

First I would like to say that I would never click "continue" on a certificate warning, I always click "disconnect."

Did you try my suggestion of turning off usage and error reporting to Google in your Chrome settings (also chromecast settings if you have chromecast).  You're won't have to disable any encrypted connections, add any exclusions, or compromise the security of your computer in any way. It worked for me, no more "self signed certificate warnings"

2

Usage and error reporting to Google in your Chrome settings are already turned off. Still getting the warning. If I click disconnect my page is closed. This only started happening after Kaspersky update. Surely I should not have to alter settings because of an update. My laptop has run for the past 2 years with the same setup and no problems. For this to happen on all 3 of my devices it has to be a software update fault.

Edited by Ray5on
extra added

Share this post


Link to post

The last 7 days I keep getting the same message from kaspersky when I start my computer:

 (in Swedish) SSL-anslutning med ogiltigt certifikat upptäckt    43d5eefb-b033-1372-9a8e-d6f07c6b9947

Kaspersky wants me to choose to proceed or to deny when Google Chrome generates an Invalid certificate with URL 43d5eefb-b033-1372-9a8e-d6f07c6b9947. Both works to remove the message but next time I start my computer the same message appears. This is true an all 4 computers in the family on same Kaspersky account.

What is this? How can I fix it???

 

Edited by JoB
found same question from other person, will try solutions from there

Share this post


Link to post
19 minutes ago, Ray5on said:

Usage and error reporting to Google in your Chrome settings are already turned off. Still getting the warning. If I click disconnect my page is closed. This only started happening after Kaspersky update. Surely I should not have to alter settings because of an update. My laptop has run for the past 2 years with the same setup and no problems. For this to happen on all 3 of my devices it has to be a software update fault.

18 minutes ago, Ray5on said:

Usage and error reporting to Google in your Chrome settings are already turned off. Still getting the warning. If I click disconnect my page is closed. This only started happening after Kaspersky update. Surely I should not have to alter settings because of an update. My laptop has run for the past 2 years with the same setup and no problems. For this to happen on all 3 of my devices it has to be a software update fault.

Ok so Kaspersky has just updated its database again and the error has gone!!! Both PC and laptop updated and running ok now. 

kaspersky 3.jpg

Share this post


Link to post
2 hours ago, Ray5on said:

Ok so Kaspersky has just updated its database again and the error has gone!!! Both PC and laptop updated and running ok now. 

 

That's good news, let's hope it stays that way!

Share this post


Link to post
On 2/1/2019 at 8:04 PM, G0Nz0 said:

I just blocked chromecast from the network and problem gone.

 

When will Kaspersky fix this?

Great idea, but just how do I do this? I want to use my chromecasts on the tv`s but block them from our computers....

15 minutes ago, Fruts said:

That's good news, let's hope it stays that way!

Really good news! Hope you are right:)

Share this post


Link to post
9 minutes ago, JoB said:

Great idea, but just how do I do this? I want to use my chromecasts on the tv`s but block them from our computers....

Really good news! Hope you are right:)

Just updated my daughter's laptop and it's working fine now. Fingers crossed the problem is fixed.

Share this post


Link to post

I updated db to see if that solved issue as posters mentioned above, but it didn't.

Edited by rizkola

Share this post


Link to post
1 hour ago, rizkola said:

I updated db to see if that solved issue as posters mentioned above, but it didn't.

Same here.  Updated, rebooted and no change.  I've also tried all the previous suggestions and nothing has worked.  Win10 Home 1803 17134.590

Share this post


Link to post

I've uninstalled and reinstalled and updated db to see if that would help at all but it didn't.

Share this post


Link to post
On 2/14/2019 at 6:55 PM, XsiliconX said:

A) Not a fix, a workaround. (in regards to disabling SSL scanning, blocking ports, disabling encrypted scanning or etc. actions a user must complete to have software function "properly")
B) Some have no Chromecast.
C) That compromises security (from Jan-09-2019):  https://gizmodo.com/dual-upnp-chromecast-exploit-allows-hacker-to-hijack-de-1831446345 .
D) Etcetera: https://www.speedguide.net/port.php?port=8009

5 hours ago, jjflash7 said:

The problem occurs after a reboot typically.  Try rebooting and see if it's still clear.  Your solution did not work for me.  Nothing works that i've seen described in this forum, so far.

4 hours ago, Ray5on said:

Usage and error reporting to Google in your Chrome settings are already turned off. Still getting the warning. If I click disconnect my page is closed. This only started happening after Kaspersky update. Surely I should not have to alter settings because of an update. My laptop has run for the past 2 years with the same setup and no problems. For this to happen on all 3 of my devices it has to be a software update fault.

1.  The issues occurs on households without Chromecast.  It occurs when a system does not have usage and error reporting enabled.

2.  The issue may be gone UNTIL RESTART.  Restart your computer (NOT SHUTDOWN as it behaves differently on Win8/10) and open Chrome to identify if the issue is corrected.

3.  See 1 and 2, AKA problem occurs WITHOUT CHROMECAST OR ERROR REPORTING.

Share this post


Link to post
7 hours ago, TomC24 said:

Thanks for this suggestion. changed chrome reporting but can't fund chromecast settings for reporting.. still looking

You can access chromecast settings from the Google Home app on your smartphone or tablet.

Remember your phone or tablet must be on the same wifi connection as the chromecast device. From the Google Home app main screen click on the icon for your chromecast device, click the settings gear icon on the top right to go to the device settings, scroll down to the Privacy Section, toggle the button to turn off "send chromecast device usage data and crash reports to Google." Next click the three dots on the top right for the extended menu and click reboot.

Do the same for all chromecast devices.

Share this post


Link to post
6 hours ago, Fruts said:

Many thanks VyperD65. I have done as you suggest and so far since reboot the message has disappeared. I have been in touch with technical support here in Spain, they have asked me which version of Internet Security I'm using. I have the latest, 19.0.0.1008(d), but I was surprised to see a warning stating "This version is not for intended for use in the European Union" I bought the anti virus at the beginning of this year from a computer store here!

You are quite welcome Fruts! I'm glad my suggestion worked for someone besides me.

I'm sure Kaspersky will fix the issue but I'm not keen on sending usage reports anyway so it's not an issue for me to turn it off.

Share this post


Link to post
19 hours ago, MoggizAV said:

Hi all

I'm watching this with interest since it is also happening to me. I just wanted to check something though. I am also getting the lock up of Kaspersky after clicking continue or disconnect. It also appears to knock me offline although I haven't managed to nail down exactly when so that might be unrelated. If I right click on the system tray and exit Kaspersky (the only function that does anything), when I reboot Kaspersky it tells me I have to reboot my computer to complete the disinfection. This points at it being a virus. No one else seems to have mentioned this so I'm wondering whether it is just coincidence?

Anyone else seeing this?

Dave

Hey    MoggizAV   /Dave,

There may be more than 1 issue going on, your post indicates this. Can you please post:

Kaspersky Application & version?

System, (e.g. w7, w10)?

Browsers used & v (e.g. Google Chrome v72x, Mozilla Firefox v65x)?

And, do you have any reports?

If not can you go to [More tools][Reports][Detailed Reports][All Events] & from the reporting time period select [7 days] -> [Export], save exported txt file to desktop and post back please?

Cheers.

Share this post


Link to post
6 hours ago, Ray5on said:

Usage and error reporting to Google in your Chrome settings are already turned off. Still getting the warning. If I click disconnect my page is closed. This only started happening after Kaspersky update. Surely I should not have to alter settings because of an update. My laptop has run for the past 2 years with the same setup and no problems. For this to happen on all 3 of my devices it has to be a software update fault.

I'm not trying to say the software update wasn't at fault nor am I trying to say that anyone should have to change their settings.

I found a solution that worked for me without compromising the security of my computer. I was just sharing what I did and made a suggestion for others to try the same.

 

Share this post


Link to post
hace 10 horas, Teke dijo:

Here's how I solved this problem: One of the suggestions that I saw in a different form to fix this problemwas to remove the Privacy Badger extension on Chrome, so I went to my Chrome extensions to see if I had installed that extension. checked my Chrome extensions and I did not have that one installed, but while looking over the other Extensions I noticed that I did have the Kaspersky Protection extension installed--but it was not switched on. I flipped the toggle on to enable the extension, and then when I launched Chrome, the error message "cannot guarantee authenticity of the domain to which encrypted connection is established" completely disappeared. I've been playing around with Chrome, going to various sites (encrypted and not), and I also re-installed the extension that I'd originally suspected had had something to do with the problem before I found it was one that others had experienced. I'm no longer getting this pop-up message from Kaspersky in Chrome.
 

As Teke said,  I noticed that I did have the Kaspersky Protection extension installed--but it was not switched on  so I flipped the toggle on to enable the extension, this works fine for me too.

Share this post


Link to post

Hey! Guys the same topic about : Chrome Self signed certificate that trigger the infamous warning

"Cannot guarantee authenticity of the domain to which encrypted connection is established" it's

being discussed on KTS - Forum too : Reading the solutions applied for some members 

I decided to post the link here..So those affected by this bug, can try these fixes

Link : https://forum.kaspersky.com/index.php?/topic/407939-cannot-guarantee-authenticity-of-the-domain-to-which-encrypted-connection-is-established-google-chrome-merged : Hope the link opens and if kaspersky, could find a way to make these links shorter will be great - Haha!

I post in other forums, where these long links get shorten - when the user Send the post. Hope they copy :lol:

Share this post


Link to post
3 hours ago, roy-marquez said:

As Teke said,  I noticed that I did have the Kaspersky Protection extension installed--but it was not switched on  so I flipped the toggle on to enable the extension, this works fine for me too.

I have this extension installed and enabled.  Still have the issue.

 

47 minutes ago, i n d i o said:

Hey! Guys the same topic about : Chrome Self signed certificate that trigger the infamous warning

"Cannot guarantee authenticity of the domain to which encrypted connection is established" it's

being discussed on KTS - Forum too : Reading the solutions applied for some members 

I decided to post the link here..So those affected by this bug, can try these fixes

Link : https://forum.kaspersky.com/index.php?/topic/407939-cannot-guarantee-authenticity-of-the-domain-to-which-encrypted-connection-is-established-google-chrome-merged : Hope the link opens and if kaspersky, could find a way to make these links shorter will be great - Haha!

I post in other forums, where these long links get shorten - when the user Send the post. Hope they copy :lol:

This is the same fix from earlier in this thread, with the exception that it adds port 8008.  So I tried that too, but no dice: the issue still occurs on my pcs.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.