Jump to content

Recommended Posts

Всем привет, установлен KIS 19 и MySQL 5,7 на порту 3306

В KIS (в пакетных правилах) :
1 правило - порт 3306 открыт только с моего ip
2 правило - порт 3306 закрыт для всех

Все работает нормально только с единичными  запросами, если запросы выполняются в цикле примерно на 10 запросе MySQL вываливается с ошибкой 

Lost connection to MySQL server at ‘reading authorization packet’, system error: 2

mysql сервер регистрирует прерывание подключения (увеличивается счетчик Aborted_connections)

Если убираю 2 правило из брандмауэра (блокировать порт 3306) то все работает нормально и с цикличными.

Увеличивал max_connections и connect_timeout, не помогает... 
Проблема явно в KIS, как его настроить правильно? Ранее у меня такой способ ограничения доступа работал но я перенес вторую базу на сервер и вот с этого момента началось... При цикличном запросе данных с нее отбивает коннект, причем только если из вне подключаюсь. 

Share this post


Link to post

А зачем вам вообще эти правила в KIS?

По умолчанию в MySQL внешний доступ к базам и так закрыт.

Share this post


Link to post
2 часа назад, andrew75 сказал:

А зачем вам вообще эти правила в KIS?

По умолчанию в MySQL внешний доступ к базам и так закрыт.

ну так закрыт, мне его открыть нужно, причем только для своего ип адреса.

Только на ограничения MySQL как то полагаться не хочется, было бы не плохо так же ограничить и доступ к порту, типа первый рубеж обороны. В конце концов сетевой экран для этого и нужен...

Edited by remus-xe2@yandex.ru

Share this post


Link to post

ANGElDRAGON попробовал поменять местами, ситуация аналогичная.

Остальные правила отключал, тоже самое, не помогает.

Что имеется ввиду под другим компонентом? Другие модули защиты касперского ? Отключил все кроме файловой защиты и сетевого экрана, тоже самое не помогло...

Share this post


Link to post
6 минут назад, ANGElDRAGON сказал:

remus-xe2@yandex.ru после отключения каждого компонента (настройка-->Защита), попробуйте перезагрузить компьютер  и проверить ситуацию повторно.
Отключение файлового антивируса помогает?

Пока отключил все разом и перезагрузил, затем включил, не помогло.

отдельно по каждому модулю пока не могу, много времени уйдет, сервер не доступен будет. По практикую позже,но что то мне подсказывает что это не то )  И саппорт как на зло молчит... вроде сегодня еще рабочий день...

Share this post


Link to post

remus-xe2@yandex.ru после перезагрузки включать не нужно было, сперва проверьте ситуацию, потом включайте.
Думаю им (support) нужны будут трассировки проблемной ситуации только сетевым экраном, если вы не найдете другой компонент.

Edited by ANGElDRAGON

Share this post


Link to post
10 минут назад, ANGElDRAGON сказал:

после перезагрузки включать не нужно было, сперва проверьте ситуацию, потом включайте

ну да, я так и сделал) не так написал.

Я понял что нужно исключить конфликты с другими модулями а для этого попытаться воспроизвести проблему без них...

 

Насчет трассировки спасибо, глянем что напишут....

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.