Jump to content
Bobson

KSC 10.5.1781 Контроль над устройством потерян.

Recommended Posts

День добрый. Обновил сервер KSC до версии 10.5.1781, не без косяков, пришлось переустанавливать всё вручную, простое обновление вылетало с ошибками. После обновления восстановил данные из резервной копии. Теперь все компьютеры в сети со статусом "контроль над устройством потерян". На нескольких машинах контроль остался, но из 50 их 5. На всех компьютерах Kaspersky Endpoint Security 10 и Агент администрирования 10.2.434 и 10.3.407. Пробовал установить 11 версию и агента (10.5.1781) из пакетов сервера, обновления проходят, агенты установлены, в службах запущены. Но статус попрежнему не меняется. Приложу скриншот из консоли сервера. Помогите с решением вопроса контроля.

ksc-10-error.jpg

Share this post


Link to post

Здравствуйте,

Пожалуйста, приложите к своему ответу отчет GSI с машины, которая не подключена к KSC.

Спасибо!

Share this post


Link to post

А агенты вообще коннектятся к KSC?

Запустите на проблемном компе утилиту klnagchk из папки агента.

Share this post


Link to post
14 часов назад, aigir сказал:

А агенты вообще коннектятся к KSC?

Запустите на проблемном компе утилиту klnagchk из папки агента.

Отчет во вложении, судя по всему агент не коннектится к серверу, причина мне не ясна...

klnagchk.log

Share this post


Link to post
14 часов назад, Nikolay Arinchev сказал:

Здравствуйте,

Пожалуйста, приложите к своему ответу отчет GSI с машины, которая не подключена к KSC.

Спасибо!

День добрый. Весь отчет не влез по ограничениям. Я создал запрос в компани аккаунт, его номер

INC000009569563

вот ссылка на него. https://companyaccount.kaspersky.com/request/view/SR445F15861117482A8EE1D8A4FE88EA36

Share this post


Link to post
1 hour ago, Bobson said:

Отчет во вложении, судя по всему агент не коннектится к серверу, причина мне не ясна...

klnagchk.log

Нет соединения с KSC. Пожалуйста, убедитесь, что в сети открыты необходимые для работы порты: https://support.kaspersky.ru/9297#block1

Убедитесь, что верно указан адрес Сервера администрирования. На одной машине попробуйте выполнить переподключение к серверу с помощью утилиты klmover. Это поможет, если изначально адрес сервера был указан неверно.

Спасибо.

Share this post


Link to post

Попробуйте выполнить на проблемном компе из папки агента:

klmover -address (адрес_KSC) - nossl

и после этого еще раз проверьте через klnagchk

Share this post


Link to post
13 минут назад, aigir сказал:

Попробуйте выполнить на проблемном компе из папки агента:

klmover -address (адрес_KSC) - nossl

и после этого еще раз проверьте через klnagchk

Сделал klmover, создал отчет, проблема не ушла. Порты открыты, до обновления сервера всё прекрасно работало, адрес сервера не менялся, есть компьютеры без проблем подцепившиеся к серверу, без переустановок агента. Логи во вложении.

klnagchk-problem.log

klnagchk-noproblem.log

Share this post


Link to post

Обратите внимание, что в логе noproblem агент использует SSL-соединение, а в логе problem агент не использует SSL-соединение
Т.е. возможно сервер не принимает незашифрованые соединения.
Попробуйте на проблемном компе выполнить klmover без ключа -nossl
Кажется где-то попадалась инфа, что в KSC 10.5 по-умолчанию используется шифрованое соединение.

Share this post


Link to post
42 минуты назад, aigir сказал:

Обратите внимание, что в логе noproblem агент использует SSL-соединение, а в логе problem агент не использует SSL-соединение
Т.е. возможно сервер не принимает незашифрованые соединения.
Попробуйте на проблемном компе выполнить klmover без ключа -nossl
Кажется где-то попадалась инфа, что в KSC 10.5 по-умолчанию используется шифрованое соединение.

Весьма странное поведение агента, или сервера. Когда обновлял агента вручную из инсталлера, до последней версии, указывал все параметры: и шифрование и откуда брать сертификат, не тупо далее-далее-готово, а как положено. Однако агент так и не законектился никуда. А из cmd - пожалуйста, работает. Последний лог с проблемной машины приложил. Пойду закину задачу в гпо. Спасибо за советы.

klnagchk-after-cmd-klmover-with-ssl.log

Share this post


Link to post
2 часа назад, Kirill Tsapovsky сказал:

Нет соединения с KSC. Пожалуйста, убедитесь, что в сети открыты необходимые для работы порты: https://support.kaspersky.ru/9297#block1

Убедитесь, что верно указан адрес Сервера администрирования. На одной машине попробуйте выполнить переподключение к серверу с помощью утилиты klmover. Это поможет, если изначально адрес сервера был указан неверно.

Спасибо.

Порты открыты, klmover отрабатывает нормально, лог klnagchk чистый, на компьютере запущен касперский (endpoint security 11), но на сервере статус устройства: Не запущена программа защиты, не включена защита. Вообще не понимаю что происходит, хоть заново всё переделывай с нуля и без восстановления из бэкапа.

Edited by Bobson

Share this post


Link to post

проверьте, среди установленных компонентов KES11 присутствует "коннектор к агенту администрирования"?

т.е. запускаем локально установщик KES, и выбираем пункт "изменить"

Edited by aigir

Share this post


Link to post
1 минуту назад, aigir сказал:

проверьте, среди установленных компонентов KES11 присутствует "коннектор к агенту администрирования"?

т.е. запускаем локально установщик KES, и выбираем пункт "изменить"

Да, присутствует. В момент установки проверял этот пункт.

Edited by Bobson

Share this post


Link to post

а плагин для KES11 на сервере и консоли установлен?
 

Share this post


Link to post
9 минут назад, aigir сказал:

а плагин для KES11 на сервере и консоли установлен?
 

Да, все возможные плагины установлены. На всякий случай экспорт списка прилагаю. Есть у меня подозрение на восстановленный бэкап, могла база криво встать, или иная причина. Буду в понедельник чистую установку делать, с ручной настройкой.

plugins-ksc.csv

Share this post


Link to post
1 hour ago, Bobson said:

Порты открыты, klmover отрабатывает нормально, лог klnagchk чистый, на компьютере запущен касперский (endpoint security 11), но на сервере статус устройства: Не запущена программа защиты, не включена защита. Вообще не понимаю что происходит, хоть заново всё переделывай с нуля и без восстановления из бэкапа.

Если под "лог klnagchk чистый" имеется в виду, что после переподключения с помощью klmover машина, имевшая проблемы с подключением к KSC, успешно с ним соединяется, то следует проверять статус не исходного значка в Консоли, а его дубликата — klmover меняет ID Сетевого агента. Старую запись компьютера можно удалить.

Спасибо.

Share this post


Link to post

Всем участникам обсуждения спасибо большое за мысли и подсказки. Проблема была, по всей вероятности, связана с восстановлением из резервной копии старой версии сервера. Я переустановил сервер полностью, с удалением базы данных и содержимым папки KLSHARE, вручную настроил всё с нуля и устройства подцепились сервером без проблем. Все устройства на конроле, защита включена и агенты рапортуют ОК.

Единственный минус во всей этой свистопляске - потерялись настройки политик веб-контроля, а они очень нужны и важны. Есть ли возможность вытащить их из файла бэкапа, не затрагивая других настроек?

Share this post


Link to post
2 hours ago, Bobson said:

Всем участникам обсуждения спасибо большое за мысли и подсказки. Проблема была, по всей вероятности, связана с восстановлением из резервной копии старой версии сервера. Я переустановил сервер полностью, с удалением базы данных и содержимым папки KLSHARE, вручную настроил всё с нуля и устройства подцепились сервером без проблем. Все устройства на конроле, защита включена и агенты рапортуют ОК.

Единственный минус во всей этой свистопляске - потерялись настройки политик веб-контроля, а они очень нужны и важны. Есть ли возможность вытащить их из файла бэкапа, не затрагивая других настроек?

К сожалению, частичное восстановление бэкапа. за исключением только сертификата сервера, в KSC не предусмотрено. Настройки веб-контроля — часть политики KES, если у вас есть экспорт этой политики или возможность создать его (требуется работоспособный сервер, на котором хранится эта политика) — его можно импортировать на новом сервере и при необходимости конвертировать для более новых версий KES.

Спасибо.

Share this post


Link to post
28 минут назад, Kirill Tsapovsky сказал:

К сожалению, частичное восстановление бэкапа. за исключением только сертификата сервера, в KSC не предусмотрено. Настройки веб-контроля — часть политики KES, если у вас есть экспорт этой политики или возможность создать его (требуется работоспособный сервер, на котором хранится эта политика) — его можно импортировать на новом сервере и при необходимости конвертировать для более новых версий KES.

Спасибо.

Нет, работоспособного сервера с этими политиками нет. На некоторых компьютерах остались политики, после того как они отключились от сервера администрирования, вытащил правила веб-контроля с них.

По сути мой вопрос решен, через костыли, но решен. Тему можно закрыть.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.