Jump to content
18i

KRD 2018 + PXE

Recommended Posts

Hello!
I use a fairly simple PXE server: I decompress the iso image in subfolder, adds a menu entry.
I can then boot a machine on the LAN to perform a installation, make material diagnosis, or... disinfection...

I seem to be missing knowledge. KRD 2018 cannot finish to start for the two following reasons:

  1. it can't find data/krd.iso
  2. it can't mount sda and sda1-6

The only thing I have is a mini-shell (already not bad).
Precision: I do not use NFS for the moment since useless with what's in place. I'll use it if I have no other solution.

After many unsuccessful tests, the menu entry was returned as found in krd/boot/grub/x86_64-efi/cfg/kav_menu.cfg :

linux krd/boot/grub/k-x86_64 net.ifnames=0 lang=en dostartx (isoloop=krd.iso)
initrd krd/boot/grub/initrd.xz

It's a syntax for GRUB, not for PXElinux...

Do you know of any arguments to give to the kernel that might to succeed? Or maybe some documentation?

 

a few remarks @K :
1. it would be very nice to have easily an azerty map, (or even better, azerty and bepo) in KRD/xfce B)
2. It would be nice if the giants would stop making us train AI..
   Please stop using captcha, recaptcha or any other tools their resembling. I'm sure you can be more inventive...
   If I work for a company's AI, shouldn't I be paid for this?

Best regards and thanks you for your attention.

Share this post


Link to post

It is not just only a matter of the right pxelinux arguments, it also requires of an additional INITRD_N24.1.GZ

See what Serva does for PXE booting KRD 2018 here:

https://www.vercot.com/~serva/an/NonWindowsPXE3.html

Share this post


Link to post

Hello!
(sorry, can't post answer since few days due to javascript/ckeditor issue)

It has worked on 1st try with :

LABEL KRD
    MENU LABEL ^B  KRD
    KERNEL        krd2018/boot/grub/k-x86_64
    APPEND initrd=krd2018/boot/grub/initrd.xz,krd2018/boot/grub/INITRD_N24.1.GZ net.ifnames=0 dostartx dodhcp netboot=http://[IP-address]/krd2018/data/* loadsrm=000-core.srm,001-xorg.srm,002-xfce.srm,003-kl.srm,004-krt.srm,005-bases.srm

Many thanks for this useful link!

Share this post


Link to post

you have to coy the whole content of the distribution ISO under your TFTP_ROOT/krd2018/

did you do that?

Share this post


Link to post

Hello!

two things can be useful :

- say "hello" or something else… :)

- provide informations about what you want to do, how and -shortly- describe the environment

I encountered the same issue as you. Using Serva's initrd solved it because it does what

a classic initrd doesn't: lauch the .srm files.

Regards,

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.