Jump to content
Itsall2hard

Bluetooth photos from my phone to my PC blocked after KIS2018 install

Recommended Posts

Hi.

I hope I've posted this in the right place - new to the forum.

I'm running Windows 10 Home on a desktop PC. I've have just installed a trial of KIS 2018 after my Norton subscription expired.  I now cannot Bluetooth photos from my phone to my PC.  Is there a setting in Kaspersky Internet security that I need to change to allow Bluetooth?  I don't absolutely know that KIS is the issue, but suspect it is, as I have done this before the  KIS install.

Sorry for the newbie question, but I am not yet familiar with the KIS interface.  Any help is appreciated. 

Edited by Itsall2hard

Share this post


Link to post

To add to my post:

The "Select Bluetooth Device" screen on the Android phone shows my PC under "Paired Devices", but after it searches does NOT show it under "Available Devices"

On the PC: "Settings -> Bluetooth and Other Devices" shows the PC as discoverable. Screenshot attached.

Capture.png

Share this post


Link to post
On 6/1/2018 at 6:30 PM, Itsall2hard said:

Anyone else had this issue?

I do, took me 2 days or maybe more of trying everything until I realized it was a kaspersky issue

Share this post


Link to post

Upgrading to version 2019 might solve this issue. Also something to try, and it is a stab in the dark, in KIS settings, try changing your network status to trusted or local.

Share this post


Link to post

Hi rudger79

I tried changing the network properties in KIS from "Prompt for Group - Network not identified" to "Local Network" and then to "Trusted Network" with a reboot after each change - neither worked.

On my phone, when I click to share the photo with Bluetooth, the phone shows my Desktop PC under "Paired Devices" - from previous transfers before installing KIS.  It does not list the PC under available devices.  

Share this post


Link to post

If upgrading to version 2019 doesn't help, please contact official tech support.

Share this post


Link to post

I have had this issue with KIS 2018 since I upgraded from windows 1703 to 1803, when I uninstalled KIS I was able to use bluetooth normally, the trouble came back when reinstalling KIS 2018.

So I contacted technical support because I kinda want to keep buying kaspersky as my next antivirus.

With their advice my phone can see my computer listed but I was not able to transfer photos, also I can't add new devices on the computer (the dialog closes), but I was able to connect my xbox controller again (I had it paired before  installing KIS so I'm not sure how much this will help you), this is the advice they gave me:

 

For security, by default Kaspersky Internet Security restricts certain communication on new networks. 
Please follow the steps in the following article to set any known networks to 'Trusted':
http://support.kaspersky.com/us/12043?cid=pe#block2

*Note: the article is applicable to 2018.

Kaspersky restricts certain local communication on networks even when the network is set to Trusted. 
Please make this change:

Open Kaspersky.
Click on 'Settings'.
Click on 'Protection' on the left.
Scroll down the right side and click on 'Firewall'.
Click on 'Configure packet rules'.
Right-click on 'Local Services (TCP)' and click 'Edit'.
Change the 'Action' from 'Block' to 'Allow'.
Click the 'Save' button.
Right-click on 'Local Services (UDP)' and click 'Edit'.
Change the 'Action' from 'Block' to 'Allow'.
Click the 'Save' button.
Close the window.
Click the Back arrow in the upper left twice to return to the main window.

 

They asked me for system information and a trace report, my ticket has been escalated and I'm waiting for a solution.

I might try installing KIS 2019 when I have time but for now it is more likely that my ticket is answered before.

Share this post


Link to post

Hi danielocdh.  Thanks for the response.  I tried that, and it worked!

Now time to admit my mistake. After I made packet rule changes as you suggested and successfully did a bluetooth transfer, I realized it might have been user error.  I opened the Bluetooth icon on the task bar and clicked "receive a file".  I can't remember having to do that - my recollection was that transfer was driven by the phone with a "is this ok" prompt from Windows - but I don't use bluetooth often, so .... crappy memory !!

I regressed the packet rule changes back to "blocked" with reboot - and BT transfer still works.

The other change I had made was KIS settings -> Protection -> Firewall -> Bluetooth properties from Prompt to Local Network.  I find I need that - when I regressed it to Prompt as a test, BT transfer fails.

I'm on Windows 10 Home build 17134 with KIS 2018.  Hope this helps someone else, and sorry for wasting your time !

 Edit: fixed  readability of a sentence 

Edited by Itsall2hard

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.