Jump to content

Recommended Posts

If I have kaspersky turned on I can connect to my OpenVPN server but I cannot reach any device over the VPN. If I turn Kaspkersky off I have no issues.

I've tried opening the port for OpenVPN but since it does make a connection I think it might be something else stopping it.

 

Any help would be great

Share this post


Link to post

Not sure if this will help, but read the thread below. it fixed my opera vpn problem

This may be a long shot...and may not be your problem, but maybe worth a try?

 

 

 

 

Share this post


Link to post

I've tried those and none of them fix the problem. Its strange because OpenVPN shows connected and I can see that my computer is connected from the server side but RDP, HTTP etc doesn't work.

My current work around is to disable Kaspersky, connect to the VPN connect to Remote Desktop then re-enable KIS. That seems to work but is not an ideal situation.

Edited by mafiaboy01

Share this post


Link to post
On 2/7/2018 at 8:47 PM, kojo+oi said:

Hi welcome to the forum.

Try this.

Uninstall Kaspersky (do not save settings)>>reboot.

Uninstall<>OpenVpn>>reboot.

Re-intall<>OpenVpn.

Reinstall Kaspesky Internet Security 2018>>reboot.

https://support.kaspersky.com/kis2018

 

 

I've tried this and it still doesn't work. the VPN connects but I can't access anything on the network with Kaspersky on. Tried multiple computers, different ports and have everything allowed in Kaspersky.

My Cisco AnyConnect VPN works perfectly fine so Kaspersky has a problem with either OpenVPN or the TAP network adapter that it installs.

Share this post


Link to post

Hi, okay have you tried using settings<>vpn options<> try different VPN Protocol.

Normally it is set at automatic, but you should be able to change it.

Have  you tried this.

In order for the OpenVPN client to successfully establish a VPN session, it needs to be added as a trusted application to Kaspersky.

Try this , go to settings>protection> turn off "application control"

Whats happens now?

Or try this also go to settings>additional>threats an exclusions>manage exclusions>(if OpenVPN is not there "add it")

What happens now?

 

 

 

 

Share this post


Link to post

I tried all of those options. Nothing helped I added all rules and exclusions for open vpn. Tried UDP and TCP connections with no success

Opened port 1194 in firewall. Tried configuring on other ports to no avail.

Gave up and ran OpenVPN through my router instead. 

Share this post


Link to post

Yes can be compatibility setting issues with Kaspersky.

The best way to setup open source VPN is to install it without Kaspersky installed, then  install Kaspersky that is preferred method.

So well done great choice,  also Open Vpn works best with open source "dual" router setup.

 

 

Share this post


Link to post
Posted (edited)

It does work, thanks

But also it is totally drastic!

It also applies to Built-in Windows 10 VPN (AlwaysON IKEv2)

Edited by spgsitsupport

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.