Jump to content
l1511s

"Your connection is not secure Error code: sec_error_unknown_issuer" Firefox Problem with kapersky [KAV/KIS/KTS 2018]

Recommended Posts

i`m having some troubles with kapersky and Firefox connection, i was using normally and i closed Firefox, 5 minutes later i tried to access Facebook and for my surprise i got "Your connection is not secure Error code: SEC_ERROR_UNKNOWN_ISSUER ".

So i start searching solutions for this problem and the only one that works for me is options>additional>Network> In the Encrypted connections scanning section check the Do not scan encrypted connections option and confirm this change.

What i have to do to avoid this extreme solution ?

Share this post


Link to post

Hello,

1) Please clarify FF version at this moment?

2) Craete requests to Tech support via my.kaspersky.com site + provide traces (enable tracing - reboot - wait till KTS main window appearance - reproduce the issue - diable tracing) + provide description of the issue reproduction during traces record + provide screenshots of the issue.

Thanks!

 

Share this post


Link to post

I have the same also since the Firefox update to 58.0 64bits, there are 2 ways to fix this all be it temporairy fixes:

1:  Encrypted connections scanning section check the Do not scan encrypted connections  ( Not recomended long term as it lowers security ) but it does fix the issue.

2: Leave the Kaspersky settings alone and do not change the Encrypted connections scanning section, instead if you go to about:preferences#privacy  in firefox then scroll down and click view certifcates then scroll down to 'Kaspersky Anti-Virus Personal Root Certificate' then click it then click 'edit trust' and you will see 3 tick boxes, make sure all are ticked and then save.  Now you will not experiance the issue for aslong as you have the browser open however the settings do not hold after you close the browser so you have to go back in and change it every time you open firefox.

 

Number 2 leads me to beleve that it is an issue with the Kaspersky Certificate

Share this post


Link to post

INC000008774325

I'm currently using the workaround in Firefox 58.0 x64 by adjusting the AO Kaspersky Security Certificate in Firefox's "about:preferences#privacy".

Update:  Just saw the request to provide trace data again.  Will do so in a moment.

Update 2:  Done (07:25 GMT 2018/01/25).

Edited by snask
More information.

Share this post


Link to post

As an update I found this kaspersky suport page about the issue and it seams to confurm what I thought in that its the certificate thats the issue https://support.kaspersky.com/general/error/13585

In it they show how to install the certificate and at the end they say wat I said a few posts back to make sure the 3 options are ticked then save, however forsomereason firefox does not perminantly save the trust setting

Share this post


Link to post

Similar problem this morning. Working fine with Firefox 58.0 installed some weeks ago, then after this morning's restart of Firefox was unable to get a connection to any https website. 

Chrome and IE working as before with no issues on HTTPS websites.

Can get Firefox to work on HTTPS websites only by selecting "Do not Scan Encrypted Connections" in Network Settings.

Latest Kaspersky database files already installed. Kaspersky scan showed no problems. Malwarebytes scan found no problems.

Please advise.

Share this post


Link to post

It's a known bug. I already submitted it around 12 days ago, but no one has done any countermeasure by now.

 

Edited by Helios

Share this post


Link to post

Same problem with Firefox 58.0 64 bit. The certificate option does not work for me. The only thing that works is if I disable scanning of secure connections.

I hope there will be an update for this annoying problem very soon, especially as it has happened before!

Share this post


Link to post
11 часов назад, ANMason сказал:

Same issue (see example attachment)

KTS 18.0.0.405 (f)
Win10 x64 16299

issue_kts-firefox_secureConnect.png

 

The same issue like ANManson has

KIS 18.0.0.405 (f)

Windows 10 x64 1709 (16299.192)

Firefox 58.0 x64

Share this post


Link to post

Workaround for this issue if you don't want to disable HTTPS scanning is to open about:config in Firefox and set

security.enterprise_roots.enabled

to true. Then Firefox will not display certificate error and HTTPS scanning will work.

Edited by Sass Drake

Share this post


Link to post
2 hours ago, Sass Drake said:

Workaround for this issue if you don't want to disable HTTPS scanning is to open about:config in Firefox and set

security.enterprise_roots.enabled

to true. Then Firefox will not display certificate error and HTTPS scanning will work.

Thanks for that - but is there a security issue with this at least as bad as disabling the chcking of https via the KIS ctrl panel?

Edited by Allsoulsday

Share this post


Link to post
7 hours ago, Sass Drake said:

Workaround for this issue if you don't want to disable HTTPS scanning is to open about:config in Firefox and set

security.enterprise_roots.enabled

to true. Then Firefox will not display certificate error and HTTPS scanning will work.

thanks this works for me

Share this post


Link to post
On 24/1/2018 at 4:59 PM, eqinox187 said:

I have the same also since the Firefox update to 58.0 64bits, there are 2 ways to fix this all be it temporairy fixes:

1:  Encrypted connections scanning section check the Do not scan encrypted connections  ( Not recomended long term as it lowers security ) but it does fix the issue.

2: Leave the Kaspersky settings alone and do not change the Encrypted connections scanning section, instead if you go to about:preferences#privacy  in firefox then scroll down and click view certifcates then scroll down to 'Kaspersky Anti-Virus Personal Root Certificate' then click it then click 'edit trust' and you will see 3 tick boxes, make sure all are ticked and then save.  Now you will not experiance the issue for aslong as you have the browser open however the settings do not hold after you close the browser so you have to go back in and change it every time you open firefox.

 

Number 2 leads me to beleve that it is an issue with the Kaspersky Certificate

Thank you a lot! It works, and even if firefox lose the configuration when closed, it is a better solution than decreasing the security!

Share this post


Link to post

Hello,

Most probably the issue fixed in the next patch. Fix is on our test update source now.

Could anybody who experienced the issue on KAV/KIS/KTS 2018  to update from the test source and confirm the fix?

1) Open Update source settings (KIS - Settings - Additional - Update) - Add there the following update source:
http://dnl-test.kaspersky-labs.com/ap
2) Disable common update source (thus there should be only one update source enabled).
3) Perform an update
4) Check the issue
5) Then reboot and check the issue again.

Thanks!

Share this post


Link to post

Hello! Could we have some approximate time table for fixing this problem? I don't like using the workarounds. I'm using Firefox 57 wich is also a workaround.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.