Jump to content
Rich H

Can I turn off certificate warnings?

Recommended Posts

It's bad enough that I get certificate warnings about almost every website I go to, but after I click to go to th website, I get a screen blackout followed by another pop-up that I have to click to give me thirty minutes of freedom from that second, time-wasting, pop-up.  How do I at least turn off the second one, and preferably also the first?

Share this post


Link to post

Welcome. Please pass your mouse cursor over the red K tray icon and tell us the full, complete name and version number of your Kaspersky product. 

Share this post


Link to post
4 minutes ago, richbuff said:

Welcome. Please pass your mouse cursor over the red K tray icon and tell us the full, complete name and version number of your Kaspersky product. 

I hope this is the desired information:  17.0.0.611(g)

Share this post


Link to post

Please see the second pinned topic for instructions to download and install Kaspersky version 2018. 

Uninstall Kaspersky version 2017 > reboot, then install Kaspersky version 2018. 

After you install Kaspersky version 2018, activate with your current activation code > do a databases update > reboot.

Any better with the current version?

Please see the small print that is located at the bottom of this message. 

Share this post


Link to post

I'm using 18.0.0.405 (c) and get these annoying popups as well. Whether I click on "Continue" or "Discontinue" doesn't seem to do anything. 

ssl connection with invalid certificate detected... Is this a valid warning or just a bug? A Google search reveals that I'm not the only one being pestered with these popups.

Share this post


Link to post

To make the messages stop, within the network section I selected "do not scan encrypted connections".

Kaspersky > Settings > Additional > Network > Do not scan encrypted connections.

Share this post


Link to post
20 hours ago, JaManU said:

To make the messages stop, within the network section I selected "do not scan encrypted connections".

Kaspersky > Settings > Additional > Network > Do not scan encrypted connections.

THANKS!  Worked for me.........................................was driving me crazy.    ;^)

Edited by azinn

Share this post


Link to post

18.01.5 bc whatever, has no options as described here, so we suffer the relentless "invalid certificate" warnings.
Dontcha just love the "knowledge base economy?"  We get to be both beta testers and technical support.  

Share this post


Link to post

Pure speculation. Sometimes the warnings are legitimate. Its shame most users just click through them.

Share this post


Link to post

Most users are trying to use their computers to get work done, not spend their time trying to ascertain why their printer is a certificate exception.  If we don't "click through them" we get lost in unsolvable certificate security exceptions.  If we try to figure out why the certificate is invalid, we just went down a rabbit hole.:unsure:

So maybe it might be helpful if there were options rather than on/off, such as stop scanning behind my firewall, or stop reminding me every time I want to print a page that the printer has an invalid certificate.

Unless, wait.   Maybe when I bought Kapersky Internet Security I inadvertently joined a cabal intent on changing the printer industry so that all printers in the future will have valid certificates!  Now it makes sense!

Share this post


Link to post

You can check yourself if the certificate is valid or not by plugging it into here https://www.digicert.com/help/

Unfortunately the home devices use a self-signed certificates, which is a weak security practice. You get a notice about it, which is totally legitimate. Even Google Chrome will now warn aggressively about a site that is not HTTPS secured.

Kaspersky already provides an option NOT to scan encrypted connections on a per application basis. The tools are there and its up to the users to educate themselves about this issue.

Share this post


Link to post
On 8/2/2018 at 4:01 AM, Whizard said:

Kaspersky already provides an option NOT to scan encrypted connections on a per application basis. The tools are there and its up to the users to educate themselves about this issue.

This is not helpful. If I click on any links in Twitter to external sites I get the "Secure Connection Failed" message every time. Surely it would make sense for an exception to be made available. I don't want to turn off the feature 'on a per application basis' even if that option was made easily available, which it's not. If I turn it off for Firefox, then I have effectively disabled that aspect of security entirely. Do I really have to use different browsers for different activities?

I find this statement below rude and dismissive. Not what I expect from this company, at all. I've been using Kaspersky for around ten years, and never encountered such a reply.

"up to the users to educate themselves about this issue"

 

Share this post


Link to post
On 9/28/2017 at 5:17 AM, JaManU said:

To make the messages stop, within the network section I selected "do not scan encrypted connections".

Kaspersky > Settings > Additional > Network > Do not scan encrypted connections.

THANKSSSSSSS!!!!!!! it was make me crazy

Share this post


Link to post

It is recommended that you have an encrypted message scan always on.

There is an alternative to it. 

 Kaspersky > Settings > Additional > Network > Manage exclusions.

Then punch in the domains that you don't want Kaspersky to block.

Your outlook and emails should work absolutely fine. This works for me, I guess it will work for all. 

Share this post


Link to post
On 8/18/2018 at 5:00 PM, gwales said:

This is not helpful. If I click on any links in Twitter to external sites I get the "Secure Connection Failed" message every time. Surely it would make sense for an exception to be made available. I don't want to turn off the feature 'on a per application basis' even if that option was made easily available, which it's not. If I turn it off for Firefox, then I have effectively disabled that aspect of security entirely. Do I really have to use different browsers for different activities?

I find this statement below rude and dismissive. Not what I expect from this company, at all. I've been using Kaspersky for around ten years, and never encountered such a reply.

"up to the users to educate themselves about this issue"

 

This is a user forum, and as far as I know, Whizard is a user just like you and me who gives his time voluntarily, as others do.

It's in everyone's interest to increase their knowledge about the AV product they use, and you are free to accept or ignore advice from any member.

Just my 2C !

Edited by Fenderman1

Share this post


Link to post

Hello!

I am a recently new user of Kaspersky, using the Free edition and being satisfied with it. With the exception of this continuous warning about a certificate that pops up every time I run Chrome, even if I am not browsing. That makes me suspicious because I wonder how this can even happen, since I am not visiting any website at all. The URL provided by the warning is more than cryptic: e90f9283-31ba-6599-44f3-aeb75db426c6 - this is not something I can easily investigate myself.

I learned in this thread I can disable the scanning of encrypted connections but I would really not like to do it since it can be really useful as it may be in this very case. 

Is there some setting that I can change so that Kaspersky would automatically not run that very certificate without asking me each time to manually do it? 

Thanks!

Share this post


Link to post

Thank you very much for the info!

Much appreciated. ;)

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.