Jump to content
  • Announcements

    • Rodion Nagornov

      Долгое сохранение сообщений || Delays while posting   09/20/2017

      По техническим причинам возможно визуально долгое отправление сообщений на форуме. Фактически ваше сообщение публикуется мгновенно - долго отрабатывает графика. В случае подобной ситуации, пожалуйста, сначала обновите страницу (F5) и проверьте, появилось ли ваше сообщение. Не пытайтесь сразу отправить его заново.  || Due to some technical reasons visual delays are possible while message sending. Actually your message is published immediately - just interface works long. In such case, please, do not re-send your message immediately! Press F5 to reload the page and check if your message/topic is published.
taylora

Printer blocked by Kaspersky

Recommended Posts

taylora   

We have one new plotter printer that is being blocked by Kaspersky. We can add the printer, but not print to it with the Kaspersky client running. When we turn the client off on the computers connected to the printer, everything works fine. Here is some detail about our Kaspersky installation:

  • Running Kaspersky Endpoint Security 10 v.10.2.5.3201 on clients
  • Running Kaspersky Security Center 10 on server
  • Device Control on, but nothing is being blocked (everything is allowed)
  • We are not using the Firewall feature and have it disabled
  • We are not using any specialized software
  • No other printers are being blocked on these computers, just the new one.

I am kind of stumped as to why Kaspersky would block it and how it is doing so. Any insight into this would be greatly appreciated. Thanks!

 

Share this post


Link to post
Share on other sites
2 hours ago, taylora said:

We have one new plotter printer that is being blocked by Kaspersky. We can add the printer, but not print to it with the Kaspersky client running. When we turn the client off on the computers connected to the printer, everything works fine. Here is some detail about our Kaspersky installation:

  • Running Kaspersky Endpoint Security 10 v.10.2.5.3201 on clients
  • Running Kaspersky Security Center 10 on server
  • Device Control on, but nothing is being blocked (everything is allowed)
  • We are not using the Firewall feature and have it disabled
  • We are not using any specialized software
  • No other printers are being blocked on these computers, just the new one.

I am kind of stumped as to why Kaspersky would block it and how it is doing so. Any insight into this would be greatly appreciated. Thanks!

 

 Hello,

is it possible to try the latest KES version ?

please list all installed and enabled KES components.

Please attach a screenshot of error message which pops-up after attempt to print.

Is it possible to delete KES components which you actually don't use ?

Thank you.

 

Share this post


Link to post
Share on other sites

Hello,

I'd ask about the model of the printer and if there's some restrictrion in  Device Control in the startegy.

Because i faced the same problem with an HP Printer that contains an integrated flash memory and Kaspersky blocks it thinking that it's a USB key. I needed to disable it using HP tool contained in the setup CD.

Hope that helps.

Regards

Share this post


Link to post
Share on other sites
taylora   

Hello,

We updated to the latest KES. We can now print, but we cannot view any details about the printer on the computer (Paper size, paper type, etc.). Since we need to switch paper size sometimes, we need to see and be able to edit this information. If Kaspersky is turned off, this information populates.

The KES components we have enabled are Application Startup Control, Application Privilege Control, Device Control, Web Control, File Anti-Virus, Web Anti-Virus, IM Anti-Virus, and System Watcher. We will be turning the Firewall back on at a later date, so I would not delete that one. I don't know how to delete components though. I just know how to disable them.

There is no error message when pulling up the printer. All the details are blank.

Device Control is on, but is not set to block anything. It allows all connections. I have attached a screenshot.

The printer is a Canon imagePROGRAF PRO-6000S plotter printer.

kaspersky_screenshot_1.PNG

kaspersky_screenshot_2.PNG

kaspersky_screenshot_3.PNG

Share this post


Link to post
Share on other sites
2 hours ago, taylora said:

Hello,

We updated to the latest KES. We can now print, but we cannot view any details about the printer on the computer (Paper size, paper type, etc.). Since we need to switch paper size sometimes, we need to see and be able to edit this information. If Kaspersky is turned off, this information populates.

The KES components we have enabled are Application Startup Control, Application Privilege Control, Device Control, Web Control, File Anti-Virus, Web Anti-Virus, IM Anti-Virus, and System Watcher. We will be turning the Firewall back on at a later date, so I would not delete that one. I don't know how to delete components though. I just know how to disable them.

There is no error message when pulling up the printer. All the details are blank.

Device Control is on, but is not set to block anything. It allows all connections. I have attached a screenshot.

The printer is a Canon imagePROGRAF PRO-6000S plotter printer.

kaspersky_screenshot_1.PNG

kaspersky_screenshot_2.PNG

kaspersky_screenshot_3.PNG

Hello,

in order to delete unused components launch the task "change KES components..." in KSC console. For instance, device control and others.

Please attach screenshots where you don't see print settings.

Thank you.

Share this post


Link to post
Share on other sites
taylora   

For the Canon printer, under Printer Properties->Device Settings there is an 'Update Media Information' option. When you click it and then click 'Execute', if Kaspersky is running you get an error. I have attached both when running it with Kaspersky and without. Kaspersky is blocking it somehow, but without the Firewall running I am not sure why. Thanks!

kaspersky_screenshot_4.PNG

kaspersky_screenshot_5.PNG

Share this post


Link to post
Share on other sites

Hello!

Please check, which exactly component is causing the trouble. 

To do this, please disable the components one by one and check if the issue reproduces after every disabling.

After you find out the faulting component, please collect the traces and process monitor log. 

Thanks! 

Share this post


Link to post
Share on other sites
taylora   

Is there an email or ftp I can send the log to? I cannot get the filesize under 4mb to be able to post. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×