Jump to content
dunetails

KSWS - Acceptance of KSN statement via policy

Recommended Posts

We're running Kaspersky Security 10 for Windows Server (v10.0.0.486) and have enabled KSN usage in the policy under Real-time protection.

In the policy we have ticked the "I accept KSN statement".  I have confirmed that this policy is being enforced successfully on our servers, however, when I check on the servers themselves in the admin tool I can see that KSN refuses to start and gives the error:

"End User License Agreement has been violated. Reason: user did not accept the KSN Statement."

 

I don't want to have to go and tick the statement manually on every server in our environment individually, KSN acceptance should be applied via the policy.

 

Has anyone else come across this issue?

 

Share this post


Link to post
Share on other sites

Hello!

Could you please tell us the exact version of your KSC and please attach the output of the klnagchk utility. 

Thanks!

Share this post


Link to post
Share on other sites

It's version 10.4.343 of security Center.

 

I assume you want the klnagchk from the client server, not management server:

 

Starting utility 'klnagchk'...
Checking command line options...OK
Initializing basic libraries...OK
Current device is 'xxxxxxxxxx\xxxxxxxxxxxx'
Network Agent version is '10.4.343'


Reading the settings...OK
Settings verification...OK
Network Agent settings:
  Administration Server address: 'RL01KAV10.release.local'
  Use SSL connection: 1
  Compress traffic: 1
  Numbers of the Administration Server SSL ports: '13000'
  Numbers of the Administration Server ports: '14000'
  Use proxy server: 0
  Administration Server certificate: available
  Open UDP port: 1
  Numbers of UDP ports: '15000'

  Synchronization interval (min): 15
  Connection timeout (sec): 30
  Send/receive timeout (sec): 180
  Device ID: 96288ef4-2e9e-4cce-82b6-a41d501a40af


Attempt to connect to the Administration Server...OK

Attempt to connect to the Network Agent...OK
Network Agent is running
Receiving the Network Agent statistical data...OK
  Network Agent statistical data:
  Total number of synchronization requests: 77
  The number of successful synchronization requests: 77
  Total number of synchronizations: 2
  The number of successful synchronizations: 2
  Date/time of the last request for synchronization:13/08/2017 08:20:59 GMT (13/
08/2017 09:20:59)


Deinitializing basic libraries...OK

 

 

Share this post


Link to post
Share on other sites

Hi,

Цитата

however, when I check on the servers themselves in the admin tool I can see that KSN refuses to start and gives the error:

"End User License Agreement has been violated. Reason: user did not accept the KSN Statement."

Could you please provide us with a screenshot of an error and with a screenshot that shows that policy is applied to one of affected hosts?

Please clarify do you use KSC as a KSN proxy?

Share this post


Link to post
Share on other sites

Policy is applied (see screenshot 1)

KSN isn't running despite being enabled in the policy, if I try to start is manually in the Admin Tool on that server, I see the error in screenshot 2 showing that the user did not accept the KSN statement

Policy shows as enforced on all servers successfully in the security center (screenshot 3)

KSN proxy is set to the KSC server (screenshot 4)

KSN statement is accepted within that part of the policy also (screenshot 5)

Admin server properties shows it's configured and I've agreed to participate in the KSN (screenshot 6)

Connection to KSN looks to be good and working (screenshot 7)

 

Let me know if I've missed something though!

1.png

2.png

3.PNG

4.png

5.png

6.PNG

7.PNG

Share this post


Link to post
Share on other sites
On 8/12/2017 at 10:40 PM, dunetails said:

We're running Kaspersky Security 10 for Windows Server (v10.0.0.486) and have enabled KSN usage in the policy under Real-time protection.

In the policy we have ticked the "I accept KSN statement".  I have confirmed that this policy is being enforced successfully on our servers, however, when I check on the servers themselves in the admin tool I can see that KSN refuses to start and gives the error:

"End User License Agreement has been violated. Reason: user did not accept the KSN Statement."

 

I don't want to have to go and tick the statement manually on every server in our environment individually, KSN acceptance should be applied via the policy.

 

Has anyone else come across this issue?

 

Hello.

Please make sure you have the latest critical fix installed: https://support.kaspersky.com/13463

Let us know if the error keeps happening even after installing the fix.

Thank you.

Share this post


Link to post
Share on other sites

Hi,

 

The link you've provided doesn't work currently.

Are you able to tell me whether this critical fix contains a specific KSN fix?

Share this post


Link to post
Share on other sites

I think there's a DNS issue,I've got to the article on another connection.

Did this patch get distributed via the software module update, or does it have to be applied manually?  Is it includes within the latest software download for KS4WS, I downloaded my install packages last Tuesday so wasn't expecting to be applying critical updates from March.

Many thanks

Share this post


Link to post
Share on other sites
1 hour ago, dunetails said:

I think there's a DNS issue,I've got to the article on another connection.

Did this patch get distributed via the software module update, or does it have to be applied manually?  Is it includes within the latest software download for KS4WS, I downloaded my install packages last Tuesday so wasn't expecting to be applying critical updates from March.

Many thanks

No, it wasn't included in distribution package.

Thank you.

 

Share this post


Link to post
Share on other sites
19 hours ago, dunetails said:

Policy is applied (see screenshot 1)

KSN isn't running despite being enabled in the policy, if I try to start is manually in the Admin Tool on that server, I see the error in screenshot 2 showing that the user did not accept the KSN statement

Policy shows as enforced on all servers successfully in the security center (screenshot 3)

KSN proxy is set to the KSC server (screenshot 4)

KSN statement is accepted within that part of the policy also (screenshot 5)

Admin server properties shows it's configured and I've agreed to participate in the KSN (screenshot 6)

Connection to KSN looks to be good and working (screenshot 7)

 

Let me know if I've missed something though!

1.png

2.png

3.PNG

4.png

5.png

6.PNG

7.PNG

Yes, you forgot to close the padlock on "KSN Statement" tab.

Share this post


Link to post
Share on other sites
5 hours ago, dunetails said:

I think there's a DNS issue,I've got to the article on another connection.

Did this patch get distributed via the software module update, or does it have to be applied manually?  Is it includes within the latest software download for KS4WS, I downloaded my install packages last Tuesday so wasn't expecting to be applying critical updates from March.

Many thanks

Please follow the advice to close the padlock.

Thank you.

 

Share this post


Link to post
Share on other sites

Aha, I think you have found the solution guys, it is the padlock.  I've managed to push that policy and all servers are reporting back correctly.  

Many thanks for you assistance on this one, much appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×