Jump to content
  • Announcements

    • Rodion Nagornov

      Долгое сохранение сообщений || Delays while posting (click here to read the full text RU/EN)   09/20/2017

      Due to some technical reasons visual delays are possible while message sending. Actually your message is published immediately - just interface works long. In such case, please, do not re-send your message immediately! Press F5 to reload the page and check if your message/topic is published. || По техническим причинам возможно визуально долгое отправление сообщений на форуме. Фактически ваше сообщение публикуется мгновенно - долго отрабатывает графика. В случае подобной ситуации, пожалуйста, сначала обновите страницу (F5) и проверьте, появилось ли ваше сообщение. Не пытайтесь сразу отправить его заново.
EJ

Kaspersky keeps upgrading Firefox without authorization

Recommended Posts

About a week ago, Kaspersky informed me that Firefox had a new version. I upgraded it through Kaspersky, but after discovering many extensions do not work with the latest version, I went back to an older one. Kaspersky now keeps downloading the upgrade in the background without informing me until it's ready to install, so I have to keep going back and re-installing the old version, which is a PAIN IN THE BUTT. How do I stop this auto-updating?

Share this post


Link to post

I think I figured it out. I caught it when it was downloading again and selected the never option from the drop-down menu. This is very inconvenient, however. Is there a way to preemptively black list or white list programs?

Edited by EJ

Share this post


Link to post

A few times a year Kaspersky updates Firefox to the latest version without my permission while I have the browser's auto-update turned off. This REALLY pisses me off as the latest version is always crap that eliminates even more of my extensions. I generally go back to an older version, but every now and then, for some unknown reason, even when I install from the software saved on my computer, that version no longer allows all of the extensions it did right before the stupid update. THIS is one of those times! I do NOT want Kaspersky auto-updating ANY software.

Share this post


Link to post

I also have this problem.  I have found a work around though.  As soon as the message appears that Kaspersky is downloading Firefox, I unplug the modem.  When I re-connect the modem Kaspersky says it cannot update Firefox and the update dialogue comes up and allows skipping this update.  Cumbersome but prevents having to reload an older Firefox.  In Firefox under tools, options, general (FF56) is an option "Never check for updates" and an option "Use a a background service to install updates".  Even when these are set to No, Firefox and Kaspersky both try to update Firefox.

It would be great if Kaspersky could permanently prohibit unwanted updates from any program as required.

Share this post


Link to post

Dear friends, I made a mistake yesterday and I accept the Firefor update for Kpersky and now I can not use Firefox,  any page opens, even my gmail or my bank page, I want to go back, and I do not know how, what could I do? somebody help me please

Share this post


Link to post

T o stop Kaspersky Internet Security updating software automatically select Settings then Protection.  Scroll down to Software Updater and turn it off.  There will then be warnings about updates to various programs with the option to Install or Ignore.  I should have checked this in the first place.

To Mirosorio.   Try reinstalling Firefox.  On the Mozilla website it is possible to download earlier versions.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×