Jump to content
Michel-B

Pulse Secure client setup error

Recommended Posts

When KES 10.3.0.6294 is installed on a Windows 7 x64 PC, the Pulse Secure VPN client cannot be installed. The setup does a rollback halfway during the installation and the MSI fails with error 1603. When KES is shut down, it still doesn't work. Only when completely removing KES I can install the client and it works fine afterwards (with KES installed).

On Windows 10, there don't seem to be any issues.

You can download the latest version of Pulse Secure here: https://nmddrive.twc.nl/my-pub/FileLink/e5b6cd87-10db-30cf-c552-8dfba55a2ae2/false

Share this post


Link to post

Hi,

Could you please clarify is there some events related to Pulse Secure VPN installation registered at KES interface?

 

Thank you!

Share this post


Link to post

No, nothing is shown. No events. But even when I turn off KES (Exit), it still fails. I have to completely uninstall KES for Pulse to install.

Could it have something to do with a filter driver conflict?

Share this post


Link to post

Hello,

did you try to install VPN client at first and a second step - KES  ?

Please attach GSI report with event logs included.

Thank you.

 

Share this post


Link to post

First KES is installed. After that, I try to install the VPN client with KES running. It will not install, even if I shut down KES. I can only install the VPN client when I completely uninstall KES. After installing the VPN client, I can install KES again and both will function normally.

The logs were created on a clean installation of Windows 7.

So:

  1. Install Windows 7 Pro x64
  2. Update Windows completely
  3. Install KES and update, reboot
  4. Install Pulse Secure client

Download new trace + GSI logs here: 

https://nmddrive.twc.nl/my-pub/FileLink/7fc0f6f1-a316-1336-b476-b3828e9b8be5/false

Share this post


Link to post
On 7/14/2017 at 11:09 AM, Michel-B said:

First KES is installed. After that, I try to install the VPN client with KES running. It will not install, even if I shut down KES. I can only install the VPN client when I completely uninstall KES. After installing the VPN client, I can install KES again and both will function normally.

The logs were created on a clean installation of Windows 7.

So:

  1. Install Windows 7 Pro x64
  2. Update Windows completely
  3. Install KES and update, reboot
  4. Install Pulse Secure client

Download new trace + GSI logs here: 

https://nmddrive.twc.nl/my-pub/FileLink/7fc0f6f1-a316-1336-b476-b3828e9b8be5/false

Hello

Apparently KES self-defense is interfering with the installation. Please provide VPN installation logs to confirm.
As a workaround, turning KES self-defense off until after the installation of VPN could be attempted.

Thank you.

Share this post


Link to post

Thanks for the reply. You are correct that this is because of self defense. When I disable it, the setup continues succesful even with all KES components enabled.

I've created 2 install logs, one with self-defense (install fail) and the other without (install success).

Is this something that has to be fixed by Pulse or can Kaspersky create a fix for this?

pulseclient_install_logs.zip

Share this post


Link to post
6 minutes ago, Michel-B said:

Thanks for the reply. You are correct that this is because of self defense. When I disable it, the setup continues succesful even with all KES components enabled.

I've created 2 install logs, one with self-defense (install fail) and the other without (install success).

Is this something that has to be fixed by Pulse or can Kaspersky create a fix for this?

pulseclient_install_logs.zip

The data has been provided to the developer for further investigation. We will provide more information as soon as we receive a reply.

Thank you.

Share this post


Link to post
On 7/17/2017 at 9:07 AM, Michel-B said:

Thanks for the reply. You are correct that this is because of self defense. When I disable it, the setup continues succesful even with all KES components enabled.

I've created 2 install logs, one with self-defense (install fail) and the other without (install success).

Is this something that has to be fixed by Pulse or can Kaspersky create a fix for this?

pulseclient_install_logs.zip

Hello,

developers provided workaround for the problem :

please add the process C:\Windows\System32\msiexec.exe in self-protection exclusions.

Self-protection blocks the program, because the PulseVPN installer tries to change the network driver stack.

Thank you.

 

Share this post


Link to post

Thank you. As this is a workaround, is a permanent solution being developed?

I'd like to know, because msiexec.exe is a very generic and widely used process.

Share this post


Link to post
vor 59 Minuten schrieb Michel-B:

Thank you. As this is a workaround, is a permanent solution being developed?

I'd like to know, because msiexec.exe is a very generic and widely used process.

We face the same problem in our company, aswell with Junos PulseSecure. 

I don't want to permit the msiexec.exe on the longterm aswell, so I would be greatful for a longterm solution, thanks!

Edited by men_paddy

Share this post


Link to post

Hi,

Is there any proper solution for this problem or still we need to follow the workaround?

Thanks.

Share this post


Link to post

Hello. 

Please provide information described in following article. 

 

Share this post


Link to post

Any updates to this issue.  We are also experiencing the same problem on some clients computers and don't want to add that exception.

Share this post


Link to post
1 час назад, UOFM_Kaspersky сказал:

Any updates to this issue.  We are also experiencing the same problem on some clients computers and don't want to add that exception.

Hi,

Could you please specify versions and product that you use and describe your problem in more details.

Thank you!

Share this post


Link to post

KES 10.3.0.6294

Pulse client 5.3r4.1-b1183-64bitinstaller

 

Issues reported on Windows 7 64 bit and Window 10 64 bit

Share this post


Link to post
Posted (edited)

On some computers, clients cannot install the Junos Pulse Client.  The install starts, but does not complete and then performs a roll back operation.  This is the exact symptoms that the first poster Michel-B mentioned and as described here:

https://kb.pulsesecure.net/articles/Pulse_Secure_Article/KB40851

The only 'fix' is to completely remove Kaspersky, Install Pulse and re-install Kaspersky after.

 

 

 

 

Edited by UOFM_Kaspersky

Share this post


Link to post

Hi,

Please provide us with KES traces  during Junos Pulse Client installation and with GSI log from that host.

Thank you!

Share this post


Link to post

Thank-you for the information.  Can you provide me instructions on obtaining the KES traces and GSI log grabs?

 

Edited by UOFM_Kaspersky

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.