Michel-B

Pulse Secure client setup error

11 posts in this topic

When KES 10.3.0.6294 is installed on a Windows 7 x64 PC, the Pulse Secure VPN client cannot be installed. The setup does a rollback halfway during the installation and the MSI fails with error 1603. When KES is shut down, it still doesn't work. Only when completely removing KES I can install the client and it works fine afterwards (with KES installed).

On Windows 10, there don't seem to be any issues.

You can download the latest version of Pulse Secure here: https://nmddrive.twc.nl/my-pub/FileLink/e5b6cd87-10db-30cf-c552-8dfba55a2ae2/false

Share this post


Link to post
Share on other sites

Hi,

Could you please clarify is there some events related to Pulse Secure VPN installation registered at KES interface?

 

Thank you!

Share this post


Link to post
Share on other sites

No, nothing is shown. No events. But even when I turn off KES (Exit), it still fails. I have to completely uninstall KES for Pulse to install.

Could it have something to do with a filter driver conflict?

Share this post


Link to post
Share on other sites

To identify the root cause we need KES traces collected during Pulse installation.

 

Thank you!

Share this post


Link to post
Share on other sites

Hello,

did you try to install VPN client at first and a second step - KES  ?

Please attach GSI report with event logs included.

Thank you.

 

Share this post


Link to post
Share on other sites

First KES is installed. After that, I try to install the VPN client with KES running. It will not install, even if I shut down KES. I can only install the VPN client when I completely uninstall KES. After installing the VPN client, I can install KES again and both will function normally.

The logs were created on a clean installation of Windows 7.

So:

  1. Install Windows 7 Pro x64
  2. Update Windows completely
  3. Install KES and update, reboot
  4. Install Pulse Secure client

Download new trace + GSI logs here: 

https://nmddrive.twc.nl/my-pub/FileLink/7fc0f6f1-a316-1336-b476-b3828e9b8be5/false

Share this post


Link to post
Share on other sites
On 7/14/2017 at 11:09 AM, Michel-B said:

First KES is installed. After that, I try to install the VPN client with KES running. It will not install, even if I shut down KES. I can only install the VPN client when I completely uninstall KES. After installing the VPN client, I can install KES again and both will function normally.

The logs were created on a clean installation of Windows 7.

So:

  1. Install Windows 7 Pro x64
  2. Update Windows completely
  3. Install KES and update, reboot
  4. Install Pulse Secure client

Download new trace + GSI logs here: 

https://nmddrive.twc.nl/my-pub/FileLink/7fc0f6f1-a316-1336-b476-b3828e9b8be5/false

Hello

Apparently KES self-defense is interfering with the installation. Please provide VPN installation logs to confirm.
As a workaround, turning KES self-defense off until after the installation of VPN could be attempted.

Thank you.

Share this post


Link to post
Share on other sites

Thanks for the reply. You are correct that this is because of self defense. When I disable it, the setup continues succesful even with all KES components enabled.

I've created 2 install logs, one with self-defense (install fail) and the other without (install success).

Is this something that has to be fixed by Pulse or can Kaspersky create a fix for this?

pulseclient_install_logs.zip

Share this post


Link to post
Share on other sites
6 minutes ago, Michel-B said:

Thanks for the reply. You are correct that this is because of self defense. When I disable it, the setup continues succesful even with all KES components enabled.

I've created 2 install logs, one with self-defense (install fail) and the other without (install success).

Is this something that has to be fixed by Pulse or can Kaspersky create a fix for this?

pulseclient_install_logs.zip

The data has been provided to the developer for further investigation. We will provide more information as soon as we receive a reply.

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now