Jump to content
WyRe

[2317050] Kaspersky power events provider keeps asking me for system restart

Recommended Posts

I've got that notification permanently, despite of I've restarted the system several times. How can I debug why is asking my for a restart?

 

 

Thank you so much.

Edited by Rodion Nagornov
test editing

Share this post


Link to post

Please post your GetSystemInfo report link, instructions are located in the fifth (5th) Important topic.

 

Please see the small print that is located at the bottom of this message.

Share this post


Link to post

I fixed it by disabling self defense (Settings > Additional) and then restart. Re-enable self defense again.

Share this post


Link to post

Hi. I'm having this issue as well. Kaspersky Lab power events provider requires restart even though I have restarted multiple times.

Edit: I'm on Windows 10.

Edited by CodeGuru

Share this post


Link to post

@CodeGuru, hi!

1) Try to clear these messages in the list, then reboot and check the issue.

2) If the issue persists, then provide a screenshot of the GSI issue.

Most probably, the issue with GSI related to uncomplete download of the GSI tool file.

Share this post


Link to post

This is the error I get when trying to upload the GSI zip file. For some reason, the image uploaded fine.

UploadProblem.png

Share this post


Link to post

OBSERVED:  I was running KIS2017 v17.0.0.611(e) in Windows 10, then got WX Creators Edition, then got KIS2017 v17.0.0.611(f), then got the persistent notification to restart to install K Power Events Provider.

TRIED:  I downloaded the latest KIS2017, then saved my settings and removed my current installation, then installed the new version, then restarted, and still got the restart notice.  I imported my old settings: no change.  Checked system error logs: nothing obvious.

TRIED:  This thing seemed like a lost dog, because everything was working properly, so - remembering the old days of installations stuck in limbo - I did some housecleaning with Microsoft Disk Cleanup (cleanmgr.exe), twice.  On the first run, I selected (among other choices) "Downloaded Program Files" and "Temporary Files".  No joy - still got the restart notice.

SOLVED:  On the second Disk Cleanup run, I clicked the "Clean Up System Files" button, then selected (among other choices) "Device Driver Packages", which claims "This task will remove older versions of drivers that are no longer needed."  The subject restart message is gone.

Share this post


Link to post

Was having the same issue, tried all of the fixes in the thread but none worked. I went looking for "Kaspersky lab power events provider" in task manager, wasn't in Processes/Details or Services.

FIX: After some searching you have to go to Device manager -> View -> Show hidden devices -> Open up "system devices" in the device list -> Kaspersky Lab power events provider. Then right-click and disable device then restart your PC, you can the re-enable it again through the same method and you shouldn't get the message anymore.

Edited by Lightstylez

Share this post


Link to post

I also have a same issue. Is this Patch F bug?
My laptop got patch F((KIS2017 v17.0.0.611(f)) a few days ago but my desktop PCs are still Patch E (KIS2017 v17.0.0.611(e)) (there is no patch f update)
There is no problem at KIS2017 v17.0.0.611(e)

Share this post


Link to post
4 hours ago, sky7 said:

Is this Patch F bug?  My laptop got patch F((KIS2017 v17.0.0.611(f)) a few days ago ...

I wouldn't assume it's a bug in patch F.  Each new version of Windows 10 appears to lay down a full 3GB OS.  I am surprised that so few pieces of non-MS apps "fall through the cracks" - most of my existing installs seem to remain intact from version to version.

A proper install includes an uninstaller, often tailored for your system, and a registry entry to bookmark its location.  When an uninstall requires a system restart, it's usually to remove or swap objects while they are not in use.  My guess is that this couldn't happen because some new version of Windows misplaced some of the details.

Because vBDKv, Lightstylez, and I were able to solve it, it was probably a Windows bookkeeping error.  Because it remains solved for six user account swaps, shutdowns, restarts, and full power-offs of my two local systems, it's probably not a bug in patch F.

Edited by GregLauver
omitted an attribution

Share this post


Link to post

This is the issue, right?

Capture.PNG.4b5ae45273f061143113944f8e3aa47a.PNG

I shut down my computer every night, and getting this message every time I turn it on. I will try the solution @Lightstylez posted and edit this post...

Share this post


Link to post

Kaspersky Lab Power events provider shows up in my notification side bar for no reason. Asks me to restart PC but no luck of getting rid of it.

Untitled.png

Share this post


Link to post

I just received the same notification. I have NOT restarted yet, I am still looking for information on what this is.

Since we received the same notification at the same time, I will assume this is not some random malware that I happened to get infected with. However, for an official Kaspersky software/driver there is almost no information online (at least in English), other than that others have seen it in the past and some of them had hardware/software problems after installing it.

Can someone please explain what this does and if it is safe to install (i.e. functional part of Kaspersky, KIS2017 in my case?)

Thank you for any info

Share this post


Link to post

There's also an earlier discussion regarding this issue in the following thread:

 

Edited by Allsop

Share this post


Link to post

I resolved the Kaspersky power events provider requires restart notification by changing the klvssbrigde64 service to automatic and rebooting. Once restarted the klvssbrigde64 service was changed back to manual and the notification did not return.

Share this post


Link to post

I had patch F install without issue...

You guys who have issue with the restart have fast start enabled in power options?

afaik with it enabled stops the OS from completely shutting down on manually restarting

 

Share this post


Link to post
14 hours ago, petsy said:

I had patch F install without issue...

You guys who have issue with the restart have fast start enabled in power options?

afaik with it enabled stops the OS from completely shutting down on manually restarting

 

The converse is true:  Fast Start substitutes Hybrid Sleep for a real Shutdown.  Restarts, manual or not, go completely down.

Reference: howtogeek.com/243901/the-pros-and-cons-of-windows-10s-fast-startup-mode/

Share this post


Link to post

Hi!

I have a problem with my Windows 10 restart problem. There is anything connected with Kaspersky. Please see my screenshot below and give me some ideas to repair it. Thank you.

Untitled.jpg

Share this post


Link to post

I had this problem and was almost freaking out. I think it is a buggy installation of the f patch because KAV reported version e and after I fixed it, reported version f.  Here's an easier way to fix it, at least how I did it .
 

  1. Open Device Manager in Control Panel [Control Panel -> Hardware and Sound -> Device Manager (will have Blue Shield next to it].
  2. Select "View" Menu at the top -> enable "Show hidden devices".
  3. Expand the "System Devices" Tree and right-click Kaspersky Labs power events provider.
  4. Choose "Update driver" and then "Search automatically for updated driver software".
  5. Windows will search for drivers but find NOTHING. This is OK.
  6. When it tells you that you have the best drivers already, click "Search for updated drivers on Windows Update"
  7. At this point, it told me the drivers had changed and prompted me to restart. I restarted and the problem notifications were gone.

I hope this helps. It looks like a lot of steps but it's not. It also requires one less restart than disabling -> enabling. 

Cheers!

KAV power events.png

Share this post


Link to post

Hello there,

Do I understand correctly that when you click 'Clear all' button at the top right and restart computer message about 'Restart required' returns back?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.