aopromolla

KSV 4.o ligt agent for Hyper-V install error on IP address setting [In progress]

16 posts in this topic

Hi, I've got problems to install SVM to an hyper-v server because during the SVM deployment process of KVM for light agent 4.0 on Hyper-v (windows 2012 r2 with latest updates), the virtual appliance installation fail the process to get and available IP addresses for SVM (I've got the same identical error if I choose to assign a static IP address during the deployment phase).

If I start another VM on the same hosts, there are no problems for these to get a DHCP IP address correctly from an external DHCP server on the same VLAN where I'm trying to install th SVM appliance.

How to solve this error?

See screenshot uploaded for details and the log of the install task.

Thanks

post-446250-1492071639.jpg

post-446250-1492071985.jpg

post-446250-1492072284.jpg

KasperskyDeploymentWizardLog.txt

report.txt

Share this post


Link to post
Share on other sites
Hi, I've got problems to install SVM to an hyper-v server because during the SVM deployment process of KVM for light agent 4.0 on Hyper-v (windows 2012 r2 with latest updates), the virtual appliance installation fail the process to get and available IP addresses for SVM (I've got the same identical error if I choose to assign a static IP address during the deployment phase).

If I start another VM on the same hosts, there are no problems for these to get a DHCP IP address correctly from an external DHCP server on the same VLAN where I'm trying to install th SVM appliance.

How to solve this error?

See screenshot uploaded for details and the log of the install task.

Thanks

Please provide screenshot of the VM network settings.

 

Thank you!

Share this post


Link to post
Share on other sites
Please provide screenshot of the VM network settings.

 

Thank you!

 

 

Hi Konstantin, here it is the screenshots of the network settings of VM created from the SVM Deployment task on the Hyper-v machine.

 

Regards,

Antonio

post-446250-1492508037.jpg

post-446250-1492508064.jpg

post-446250-1492508073.jpg

Share this post


Link to post
Share on other sites
Any news on this problem?

How configured your public network in Hyper-V?

 

Thank you!

Share this post


Link to post
Share on other sites

Hi Konstantin,

 

I've uploaded the hyper-v switch configuration of the Public network.

 

Regards,

Antonio

post-446250-1492781201.jpg

post-446250-1492781206.jpg

Share this post


Link to post
Share on other sites
Hi Konstantin,

 

I've uploaded the hyper-v switch configuration of the Public network.

 

Regards,

Antonio

Describe scenario how you create VM for SVM. Through Create VM wizard and on one of the steps was added the ISO?(you need to do this scenario) Or you added ISO after this wizard, when machine was created?

 

Thank you!

Share this post


Link to post
Share on other sites

Hi, the VM SVM has been created by the SVM deployment task wizard, and I've used during the wizard the package for hyper-v downloaded from the following link:

https://products.s.kaspersky-labs.com/multi...4.0.46.8060.zip

 

The strange is that other machines on the same host are able to get the IP address from a DHCP server connected to the same vswitch...

 

Regards.

 

Share this post


Link to post
Share on other sites
Hi, the VM SVM has been created by the SVM deployment task wizard, and I've used during the wizard the package for hyper-v downloaded from the following link:

https://products.s.kaspersky-labs.com/multi...4.0.46.8060.zip

 

The strange is that other machines on the same host are able to get the IP address from a DHCP server connected to the same vswitch...

 

Regards.

 

Hello,

 

please check the following ports:

135 TCP / UDP

445 TCP / UDP

5985 TCP

5986 TCP

http://support.kaspersky.com/13492

Thank you.

Share this post


Link to post
Share on other sites

Hi Konstantin,

 

I've checked the ports between the hyper-v and KSC and are open between them.

To be sure that was not the firewall that block the ports, I've disabled it on hyper-v server (IP address 172.30.150.5) where I want to deploy the KSV VM and also on the Kaspersky Security Center server (IP address 172.30.150.45).

My DHCP server IP address is 172.30.150.254 (in the deployment task I've leaved the option to obtain the ip address via DHCP server).

 

I've captured the traffic from the beginning of the KSV deployment phase until the error, on the KSC server with wireshark in promiscuous mode and I don't see DHCP requests to the DHCP server during the KSV VM deployment.

I upload the the deployment job log.

 

Antonio

 

KasperskyDeploymentWizardLog.txt

Share this post


Link to post
Share on other sites

Hi Dmitry, I've tried to do the same deploy but on a esx server instead of hyper-v (using the proper image) and on this hypervisor the deploy is able to reach the end without errors.

I'm still not enable to do the same deploy on a Hyper-v host.

 

Share this post


Link to post
Share on other sites
Hi Dmitry, I've tried to do the same deploy but on a esx server instead of hyper-v (using the proper image) and on this hypervisor the deploy is able to reach the end without errors.

I'm still not enable to do the same deploy on a Hyper-v host.

 

Please try other deployment, but with static IP.

Thank you.

 

Share this post


Link to post
Share on other sites
Hi Dmitry,

the problem is always the same.

See screenshot and log file.

Regards

 

Hello!

 

Please check, if the ports 135 TCP / UDP 445 TCP / UDP are open and the connection to the Hyper-V can be established via these ports.

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Ivan,

 

on the Hyper-v host I've disabled the firewall to be sure that there are no ports necessary blocked, but the problem is as descripted in the previous post...

I've checked with neststat command on the hyper-v host and only the TCP ports 135 and 445 are in listening state, and no UDP ports are open on 135 and 445 (see schreenshot attached).

If I try to telnet these ports from another machine, (the firewall is off on both machines), I'm not able to connets to port 135 tcp o port 445 tcp of the hyper-v machine.

If I lunch again the deployment job, I have the same error (see screenshot of the part of the task job log with the error message).

But in the error message seems that the problem is due to a "mount vhd image file" exception .....is there some settings that I miss?

The problem is the same if I use the domain administrator account and if I create a domain account that is member on the hyper-v host of the Remote Management Users group and the local Administrators group of this host.

 

post-446250-1493881677.jpg

post-446250-1493881683.jpg

post-446250-1493890881.gif

Share this post


Link to post
Share on other sites
Hi Ivan,

 

on the Hyper-v host I've disabled the firewall to be sure that there are no ports necessary blocked, but the problem is as descripted in the previous post...

I've checked with neststat command on the hyper-v host and only the TCP ports 135 and 445 are in listening state, and no UDP ports are open on 135 and 445 (see schreenshot attached).

If I try to telnet these ports from another machine, (the firewall is off on both machines), I'm not able to connets to port 135 tcp o port 445 tcp of the hyper-v machine.

If I lunch again the deployment job, I have the same error (see screenshot of the part of the task job log with the error message).

But in the error message seems that the problem is due to a "mount vhd image file" exception .....is there some settings that I miss?

The problem is the same if I use the domain administrator account and if I create a domain account that is member on the hyper-v host of the Remote Management Users group and the local Administrators group of this host.

 

Hello.

 

Please check if port 22 is open between the wizard host and the SVM network.

 

To diagnose the issue further, please do the following:

 

-Modify the file C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security Center\Plugins\la.plg.4.0.0.0\DeployWizard\Kaspersky.Virtualization.Wizard.exe.config:

set "disableRollback" to true

-Start the wizard again according to your initial scenario; enable remote connection option in the wizard

-Receive the error. The SVM will not be removed this time: log into it locally as root (password as specified by you or 123456 by default) and run ifconfig to see if the IP has been assigned

-On the host where the wizard was run, use putty to connect to SVM remotely. Make a screenshot of that.

 

Afterwards, please create an incident in CompanyAccount and include:

-Description of the issue and the results of the actions described above;

-Information about Hyper-V (as presented in this topic)

-Screenshots (from this topic and as described above)

-Contents of directories /var/opt and /var/log

 

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now