Jump to content
Goldy

After upgraiding to 10.4.343, KSC not runing.[In progress]

Recommended Posts

Kaspersky support logged in my KSC server today and after a while and several checking they manage to fix the problem.

 

There was some problems encountered during the installation of Kaspersky Security Center server 10.4.343 version.

They ran a script that fixed those problems and restarted the Kaspersky Security Center Administration server service.

After that the Administration server service run successfully and the Console connected to the server.

 

Apparently it has something to with the data base (like it was mention here).

 

so for now - :bravo:

 

Glad to hear that support was able to work with you resolve this!

Share this post


Link to post

I am still experiencing the issue after the upgrade

INC000007658228

In event log I see

 

...upgrading Administration Server has completed with an error in script 2, batch 5. Error: #1963 (-2147467259) Database connection is broken " '[DBNETLIB][ConnectionRead (WrapperRead()).]General network error. Check your network documentation.' LastStatement='EXEC upgd_upgrade_virtual_machines'"

Edited by NVaZN

Share this post


Link to post
I am still experiencing the issue after the upgrade

INC000007658228

In event log I see

 

...upgrading Administration Server has completed with an error in script 2, batch 5. Error: #1963 (-2147467259) Database connection is broken " '[DBNETLIB][ConnectionRead (WrapperRead()).]General network error. Check your network documentation.' LastStatement='EXEC upgd_upgrade_virtual_machines'"

 

Hello,

 

did you try instructions from Konstantin?

Thank you.

 

Share this post


Link to post
For your problem we have two script, for MySQL and for MS SQL. Please run one of this scripts on your server where installed your sql base for KSC.

Please inform us about result.

I tried the MS SQL script on my server, which got me further into the upgrade process. However, it didn't fix the root cause which, as with NoSurf, was that the compatibility mode was set to SQL Server 2000. I changed this to SQL Server 2008 manually, then restarted the Administration Server, which allowed the upgrade process to complete successfully.

Share this post


Link to post
Hello,

 

did you try instructions from Konstantin?

Thank you.

 

Yes, but support said issue was not the same as database was 2008. No errors in the log and suggested waiting an hour for process as it may take this long for server to initialize. If this didn't work he suggested building a new server and migrating over to the new server.

Edited by NVaZN

Share this post


Link to post

I see the following after reinstalling 10.3.407

 

Event name Execution time error

Severity: Functional failure

Application: Kaspersky Security Center 10 Administration Server

Version number: 10.3.407

Task name:

Computer: Administration Server <>

Group: Servers

Time: 4/14/2017 6:52:34 PM

Virtual Server name:

Description: Execution time error: Database error occured: #1950 (-2147467259) Generic db error: " '[DBNETLIB][ConnectionWrite (WrapperWrite()).]General network error. Check your network documentation.'"

 

Error information: 1950/-2147467259 (Generic db error: " '[DBNETLIB][ConnectionWrite (WrapperWrite()).]General network error. Check your network documentation.'"), .\db_inneradoconnectionimpl.cpp, 305.

 

 

Share this post


Link to post

After waiting two hours after the upgrade the console would still not launch. In the event viewer I see upgrading Administration Server.

Share this post


Link to post

Unfortunately at this time due to the nature of our install I am unable to do this. I had to revert to version 10.3.407b due to management of non persistent VDI desktops.

 

Kaspersky Security Center 10.2.434d

Network Agent 10.2.434d

 

Kaspersky Security for Windows Server 10.0.0.486

Network Agent version: 10.3.407b

Anti-virus version: 10.0.0.486

 

Kaspersky Endpoint Security 10.2.434d

Network Agent version: 10.3.407b

Anti-virus version: 10.2.5.3201

 

Kaspersky Security for Virtualization Agentless 3.1.0.77a

Network Agent version: 10.1.0.64

Anti-virus version: 3.1.0.77

 

Kaspersky Security for Virtualization 3.0 Light Agent 3.2.99.5024

Network Agent version: 10.1.0.53

Anti-virus version: 3.2.99.5024

 

Kaspersky Security for Virtualization Light Agent 3.4.44.7179

Network Agent version: 10.1.0.87

Anti-virus version: 3.4.44.7179

 

 

Hi,

 

Please provide us with newly collected GSI report.

 

Thank you!

 

Share this post


Link to post

That is correct, when I reinstall 10.3.407b and restore the database using the KLBackup utility everything works. Doing a new install of 10.4.343 the console launches, but will not launch after the restore. In the event log message is upgrading Administration Server.

 

Kaspersky Security Center 10.3.407b

Network Agent 10.3.407b

 

Kaspersky Security for Windows Server 10.0.0.486

Network Agent version: 10.3.407b

Anti-virus version: 10.0.0.486

 

Kaspersky Endpoint Security 10.2.5.3201

Network Agent version: 10.3.407b

Anti-virus version: 10.2.5.3201

 

Kaspersky Security for Virtualization Agentless 3.1.0.77a

Network Agent version: 10.1.0.64

Anti-virus version: 3.1.0.77

 

Kaspersky Security for Virtualization 3.0 Light Agent 3.2.99.5024

Network Agent version: 10.1.0.53

Anti-virus version: 3.2.99.5024

 

Kaspersky Security for Virtualization Light Agent 3.4.44.7179

Network Agent version: 10.1.0.87

 

 

Anti-virus version: 3.4.44.7179

So at that configuration the issues does not occur?

 

Thank you!

 

Share this post


Link to post
That is correct, when I reinstall 10.3.407b and restore the database using the KLBackup utility everything works. Doing a new install of 10.4.343 the console launches, but will not launch after the restore. In the event log message is upgrading Administration Server.

 

Kaspersky Security Center 10.3.407b

Network Agent 10.3.407b

 

Kaspersky Security for Windows Server 10.0.0.486

Network Agent version: 10.3.407b

Anti-virus version: 10.0.0.486

 

Kaspersky Endpoint Security 10.2.5.3201

Network Agent version: 10.3.407b

Anti-virus version: 10.2.5.3201

 

Kaspersky Security for Virtualization Agentless 3.1.0.77a

Network Agent version: 10.1.0.64

Anti-virus version: 3.1.0.77

 

Kaspersky Security for Virtualization 3.0 Light Agent 3.2.99.5024

Network Agent version: 10.1.0.53

Anti-virus version: 3.2.99.5024

 

Kaspersky Security for Virtualization Light Agent 3.4.44.7179

Network Agent version: 10.1.0.87

Anti-virus version: 3.4.44.7179

Hi,

 

How many time passed since restore?

 

Thank you!

Share this post


Link to post

The new install took approximately 30 minutes and the restore took approximately 10 minutes.

 

Hi,

 

How many time passed since restore?

 

Thank you!

 

Share this post


Link to post
The new install took approximately 30 minutes and the restore took approximately 10 minutes.

How many time passed since restore? At this moment you cannot login in KSC?

 

Thank you!

Share this post


Link to post

I am able to now as I reverted back to version 10.3.407b of KSC but was not able to login after upgrade to 10.4.343

 

 

 

How many time passed since restore? At this moment you cannot login in KSC?

 

Thank you!

 

Share this post


Link to post
I am able to now as I reverted back to version 10.3.407b of KSC but was not able to login after upgrade to 10.4.343

You will stay on 10.3.407b version? Do you need our help, or we can consider that your problem was solved?

 

Thank you!

Share this post


Link to post

I still plan to upgrade to 10.4.343 but as it does not seem to the same cause as this thread, it can be closed. I would like further assistance on the issue we are experiencing.

 

You will stay on 10.3.407b version? Do you need our help, or we can consider that your problem was solved?

 

Thank you!

 

Share this post


Link to post
After waiting two hours after the upgrade the console would still not launch. In the event viewer I see upgrading Administration Server.

 

Hello,

 

is it acceptable to wait a completion of the upgrade process ?

Thank you.

Share this post


Link to post

Yes, as long as I have an estimated time frame of the upgrade process. During last upgrade I waited two hours and I would like to avoid database being too out of sync due to the non persistent VDI virtual machines.

Share this post


Link to post

I have decided to migrate to a new server with 10.4.343. Is it possible to migrate Virtualization SVM's to new server?

Share this post


Link to post

Kaspersky Security for Virtualization Agentless 3.1.0.77a

Network Agent version: 10.1.0.64

Anti-virus version: 3.1.0.77

 

Kaspersky Security for Virtualization Light Agent 3.4.44.7179

Network Agent version: 10.1.0.87

Anti-virus version: 3.4.44.7179

 

Hi,

 

Could you please clarify what virsion of KSV do you use?

 

Thank you!

 

Share this post


Link to post

The following has been upgraded and migrated to a new Kaspersky Security Center 10.4.343

 

Kaspersky Security for Virtualization Agentless 4.0.0.84

Network Agent version: 10.1.0.93

Anti-virus version: 4.0.0.84

 

Kaspersky Security for Virtualization Light Agent 4.0.46.8060

Network Agent version: 10.1.1.18

Anti-virus version: 4.0.46.8060

Share this post


Link to post

I have migrated some physical machines to the new console as well running but have noticed that databases are listed as not being updated on some machines sporadically.

 

Kaspersky Endpoint Security 10 for Windows 10.3.0.6294

Network Agent version: 10.4.343

Anti-virus version: 10.3.0.6294

 

 

Share this post


Link to post
I have migrated some physical machines to the new console as well running but have noticed that databases are listed as not being updated on some machines sporadically.

 

Kaspersky Endpoint Security 10 for Windows 10.3.0.6294

Network Agent version: 10.4.343

Anti-virus version: 10.3.0.6294

 

Please define sporadically. Does this happen on certain conditions/at certain times? What are the errors present in the logs?

 

Thank you.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.