Jump to content
LBVS

Tâche "Sauvegarde des données du serveur d'administration" en erreur inconnue (Accès refusé)

Recommended Posts

Bonjour,

je viens de réinstaller (donc pas un import d'une version précédente) une infra Kaspersky en version 10.3.407, sur un serveur virtuel Windows 2012 R2, avec une base MSSQL distante (SQL Serveur 2012 sur Windows 2012 R2).

Je rencontre donc un souci sur la tâche "Sauvegarde des données du Serveur d'administration" qui n'est pas fonctionnelle, et m'indique une "erreur inconnue : System error 0x5 (Access is denied)"

J'en conclus donc un problème de droits !

J'ai modifié le chemin du backup pour le faire pointer sur une partition secondaire de mon serveur d'administration, le groupe de domaine "KLAdmins" est en full control sur ce répertoire, ainsi que le compte local KL-AK* (je sais pas pourquoi je l'ai mis à vrai dire)

 

 

Les logs ne sont pas plus parlants.

 

Et dernière question, quelle est l'utilité de cette tâche? est-elle indispensable, en plus d'un backup MSSQL et d'un backup du serveur virtuel ?

 

Merci

Share this post


Link to post

Bonjour,

 

pourrais-tu vérifier que le compte KL-AK-xxxx qui fait tourner le service du Serveur d'Administration a bien les droits sur le SQL distant ?

 

Une autre alternative pourrait etre de changer le compte du Serveur d'Administration ; changer le compte KL-AK-xxxx qui est créée par défaut et le remplacer par un autre compte du domaine ayant les droits sur le répertoire cible du backup bien sur, mais aussi sur SQL.

 

> important : pour changer le compte qui fait tourner KLServer.exe il convient d'utiliser l'outil KLSRVSwch.exe qui se trouve à la racine du répertoire d'installation du Security Center.

 

article sur KLSRVSwch: https://support.kaspersky.com/fr/9293

 

Concernant la tache de backup elle meme ; oui elle est nécessaire (pendant le backup la tempdb est flushée et entre autre un DBCC check est réalisé). Par ailleurs ce backup est la seule protection possible pour parer les soucis de DB corrompues .... seul ce backup peut etre réinjecté dans le Security Center.

 

Notez qu'il est possible de manuellement lancer le backup (ou la restauration) du Serveur d'Administration à l'aide de l'outil KLBackup qui se trouve aussi dans le répertoire d'installation du Security Center).

L'outil devra etre lancé bien entendu sous un compte qui a les accès au dossier de backup mais aussi bien sur au SQL.

KLBackup : http://support.kaspersky.com/fr/13264

 

Enfin un conseil, meme si le problème n'est pas lié ; tu peux installer le patch B du Sc 10.3.407 qui vient de sortir afin de disposer de la version la plus stable du produit.

ref : http://support.kaspersky.com/fr/13356

 

bonne journée :)

 

 

Share this post


Link to post

La base SQL Server tourne avec un compte SQL local, donc ça peut expliquer pourquoi j'ai ce souci. Je suppose qu'il doit être possible de donner des droits à l'utilisateur local sur une base distante, je regarde ça avec mon DBA.

 

je préfère éviter de modifier l'utilisateur du service, j'ai eu pas mal de difficultés à installer proprement la solution (4 tentatives)

 

Je ne préfère pas lancer manuellement le backup, mais je suppose que l'utilitaire KLBackup permet l'automatisation, je regarde ça.

 

Le patch B est installé :)

Share this post


Link to post

Bonjour,

 

la solution d'ajouter l'utilisateur par votre DBA est surement la meilleure. tiens nous au courant.

 

Concernant KLBackup voici un article qui décrit son utilisation et sa syntaxe. Par defaut celui ci n'a pas l'option pour le planifier néanmoins, on pourrait envisager une planification à l'aide de taskschd ; mais la meilleure solution reste la tache de backup native.

 

KLbackup (article SC9 mais c identique en SC10) : https://support.kaspersky.com/fr/7444

 

bonne journée

 

Share this post


Link to post

On va utiliser klbackup, vu que c'est une vm, le klbackup sera lancé chaque jour sans l'option date, et avant chaque lancement une purge du répertoire.

La sauvegarde de la VM se chargera de conserver x copies de tout ça.

Merci pour les infos !

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.