Jump to content
DetroiterX

Web Protection Keeps Changing the Proxy Settings

Recommended Posts

Kaspersky has had this issue before. It appears to have returned. Most people don't use proxy servers when connected to Wi-Fi. Therefore, their proxy setting will be set to "None." However, if you enable Web Protection through the Kaspersky app, it changes your proxy settings. The proxy hostname is 127.0.0.1 (loopback address, basically your device as the proxy host), and the port opened is 3128. Having this proxy setting, the browser returns with a proxy server error and, of course, the web page you are trying to view will not show up. This issue was supposed to have been fixed, but it appears that recent updates have brought the issue back. This really needs to be fixed. I usually have Web Protection turned on, but I have to disable it now if I want to browse the web.

 

I have Kaspersky Internet Security v: 11.9.4.1342

 

The device is a Moto G with Android v: 4.4.4

 

If you guys know what file is making the changes, I'd love to know so I can edit it, or if a rewritten file can be downloaded to replace the current file, that would certainly work too.

Edited by DetroiterX

Share this post


Link to post
Hi,

Welcome to the forum.

Please contact Kaspersky support.

https://my.kaspersky.com/

:supercool:

 

I'm having the same problem with my Samsung Tablet. I followed the link above but I can't seem to find any help there. Is there like a place I can open a ticket or something of sort.

 

Share this post


Link to post
I'm having the same problem with my Samsung Tablet. I followed the link above but I can't seem to find any help there. Is there like a place I can open a ticket or something of sort.

Hi,

Welcome to the forum.

You need to have a currant Kaspersky account to use "premium version" of Kaspersky Internet Security, so you login there to contact Kaspersky Support through your Kaspersky Account.

:supercool:

 

Share this post


Link to post
Kaspersky has had this issue before. It appears to have returned. Most people don't use proxy servers when connected to Wi-Fi. Therefore, their proxy setting will be set to "None." However, if you enable Web Protection through the Kaspersky app, it changes your proxy settings. The proxy hostname is 127.0.0.1 (loopback address, basically your device as the proxy host), and the port opened is 3128. Having this proxy setting, the browser returns with a proxy server error and, of course, the web page you are trying to view will not show up. This issue was supposed to have been fixed, but it appears that recent updates have brought the issue back. This really needs to be fixed. I usually have Web Protection turned on, but I have to disable it now if I want to browse the web.

 

I have Kaspersky Internet Security v: 11.9.4.1342

 

The device is a Moto G with Android v: 4.4.4

 

If you guys know what file is making the changes, I'd love to know so I can edit it, or if a rewritten file can be downloaded to replace the current file, that would certainly work too.

Hi

 

I'm using Android vs 4.4.2 and have the same problem. So we don't all contact tech support with the same issue, if you could post back any advice tech support give you, that would be much appreciated.

 

To work around this problem, rather than disable web protection, I wait for the mob to connect to the router, then modify the network (in the mob wifi connection) by setting it from manual to none. Once this is done, it never changes back to manual until the connection is disconnected for some reason and then reconnected again. It's a bit of a faff to have to do it every connection time but at least web protection can remain enabled.

 

I see in this posting - http://forum.kaspersky.com/index.php?showtopic=260035 kasp have known about this problem for years, and KIS for android has certainly not fixed the problem, so I'm not hopeful of a quick resolution but never say never.

 

Regards

Share this post


Link to post
Hi

 

I'm using Android vs 4.4.2 and have the same problem. So we don't all contact tech support with the same issue, if you could post back any advice tech support give you, that would be much appreciated.

 

To work around this problem, rather than disable web protection, I wait for the mob to connect to the router, then modify the network (in the mob wifi connection) by setting it from manual to none. Once this is done, it never changes back to manual until the connection is disconnected for some reason and then reconnected again. It's a bit of a faff to have to do it every connection time but at least web protection can remain enabled.

 

I see in this posting - http://forum.kaspersky.com/index.php?showtopic=260035 kasp have known about this problem for years, and KIS for android has certainly not fixed the problem, so I'm not hopeful of a quick resolution but never say never.

 

Regards

 

I have the same issue.

Share this post


Link to post
Install latest version or dont put web protection to max.

 

 

I got reply from tech support: disable web protection...

Share this post


Link to post

I got the same problem, and i'm happy to know the cause of my proxy problem. Only have to wait for a solution.

Share this post


Link to post
Last update fixed the problem.

 

Hi,

Good news thanks for the update information.

:supercool:

Share this post


Link to post

I have this same issue and have had it for at least two months now. I have had to disable the Web Protection feature so that it doesn't change the proxy settings.

 

This has been a real nuisance and a disappointment as this a feature that made me choose the Kaspersky App and in turn in purchasing Kaspersky not only for my Mobile Devices but computers. I hope this gets resolved soon, it's already been too long.

Share this post


Link to post

Hi

This issue was solved in Kaspersky updates.

What Kaspersky version do you have installed?

Also what Android version is installed on your phone?

:supercool:

Share this post


Link to post
Hi

This issue was solved in Kaspersky updates.

What Kaspersky version do you have installed?

Also what Android version is installed on your phone?

:supercool:

 

This is happening on a Galaxy Tablet S2 with the latest Update Installed for both the Device itself and the Kaspersky Internet Security App, and is unfortunately still happening right now. But it doesn't seem to be an issue on my mobile phone at all (when on Wi-fi or mobile data) which is a Sony Xperia Z3 Compact. It only effects my Tablet.

Share this post


Link to post

Hi,

Try this, uninstall Kaspersky reboot reinstall from Google Play Store.

:supercool:

 

Share this post


Link to post
Hi,

Try this, uninstall Kaspersky reboot reinstall from Google Play Store.

:supercool:

 

Sadly that didnt fix it. I uninstalled, restarted my tablet, then reinstalled the app and it is still changing my proxy. Oddly it doesnt always change the proxy straight away (it can be fine for hours), but sometimes it does change it right away after enabling web protection.

Share this post


Link to post
Hi

This issue was solved in Kaspersky updates.

What Kaspersky version do you have installed?

Also what Android version is installed on your phone?

:supercool:

 

 

No it wasn't!!!! I have the latest version 11.11.4.761 - on android 4.4.2 HTC one mini - I've had the issue for two years intermittently and only found the solution today after a determined search - For a paid app this is completely unacceptable - There are posts about this that go back to 2011!!!

 

IT IS A SYSTEMIC FAILURE IN YOUR APP ACROSS ALL VERSIONS OF ANDROID AND ALL DEVICES OVER A FIVE YEAR PERIOD :angry2: :angry2: :angry2:

 

 

 

Share this post


Link to post
Android 4.4.2 HTC One Mini.

The warranty has expired long ago.

Please contact Kaspersky support.

https://m.kaspersky.com

:supercool:

 

What difference does the age of the phone make? That's like selling someone defective tires for a two year old car and then blaming the car when they fall off!

It could be argued that you've had two years to get the problem solved and still haven't managed. Also what do you think Kaspersky support is going to say exactly...?

 

yeah dude... - we totally have this ultra secret fix that we're keeping really really secret and we can only tell people who contact us directly and who promise like, really promise not to tell anyone else......as telling anyone else would be totally uncool......"

 

You are selling a product that doesn't work regardless of android version or phone make :dash1:

Share this post


Link to post

If you purchased licence online, you could try "uninstall" Kaspersky >reboot twice>reinstall Kaspersky free version from Google Play Store>reactivate "premium"

Also you could do a device factory reset>"reinstall" Kaspersky.

:supercool:

 

Share this post


Link to post
If you purchased licence online, you could try "uninstall" Kaspersky >reboot twice>reinstall Kaspersky free version from Google Play Store>reactivate "premium"

Also you could do a device factory reset>"reinstall" Kaspersky.

:supercool:

 

 

I have reinstalled Kaspersky 3 or 4 times in the last two years. Exactly as you described, and from factory resets - Not to solve this problem particularly, just cos I had to have the phone repaired, or cos it needed to be reset. The problem persists and the factory reset does not solve it. The last time I did this was a week ago.

 

This is not a phone or android issue it is a kaspersky issue!

Edited by ianmr65

Share this post


Link to post
Is WiFi "smart switch" disabled?

:supercool:

 

That's a Samsung App...

 

Anyway technical support came up with a partial solution.....

 

The issue you're describing happens because Kaspersky essentially needs to root [sic - route?] all apps that connect to the internet via its own particular proxy settings in order to scan them.

To prevent that from happening, and therefore stop the alteration of proxy server settings, you will need to go to Settings-> Web Protection and uncheck the option "Scan apps that connect to the internet"

Let us know if the above tweak resolves the issue.

Thank you.

 

Which lead me to discovering a complete one! Once you get to this.....

 

 

kisa_10212_05124-207903.png

 

......make sure you uncheck the 'scan apps' option as advised......AND make sure you do this BEFORE you 'grant access' in accessibility.

 

 

kisa_10212_04124-209248.png

 

 

Once you have granted access, THEN go back and re-enable 'scan apps' and everything should now work!

 

 

I've tested this fairly extensively, WiFi or data and across all apps even turning WiFi on and off. As Kaspersky aren't paying me unlike our 'super cool' mod - I'm not going to try to recreate the error......so YMMV... B)

 

 

 

 

 

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.