Jump to content
luanlucas

Device Control and KSM [Not a bug]

Recommended Posts

Hi,

 

I'm using KSC 10.3.295, NA 10.3.295, KES 10.2.4.649 and KSM 10.5.112.7263.

 

First suggestion would be to fix the error in Device Control, in Trusted Devices more specifically. When I try to find a device to add as a Trusted Device using the ID within the informations that was generated by device block event the research does not bring anything. The only way I can find the device is using its name or searching by host name.

 

Second suggestion would be add the possibility to add websites by using wildcards (*) in Web Protection of Kaspersky Security for Mobile when the option selected is "Only listed websites are allowed". Currently the only way I can do that is specifying each web site, but it would take a huge work in case, for example to allow every web site within kaspersky domain.

 

Thank you.

 

Regards,

Luan

Share this post


Link to post
Hi,

 

I'm using KSC 10.3.295, NA 10.3.295, KES 10.2.4.649 and KSM 10.5.112.7263.

 

First suggestion would be to fix the error in Device Control, in Trusted Devices more specifically. When I try to find a device to add as a Trusted Device using the ID within the informations that was generated by device block event the research does not bring anything. The only way I can find the device is using its name or searching by host name.

 

Second suggestion would be add the possibility to add websites by using wildcards (*) in Web Protection of Kaspersky Security for Mobile when the option selected is "Only listed websites are allowed". Currently the only way I can do that is specifying each web site, but it would take a huge work in case, for example to allow every web site within kaspersky domain.

 

Thank you.

 

Regards,

Luan

 

Hello.

 

Please collect Server + Console traces while reproducing the first scenario and describe it step by step, including the value you enter into the text field, the expected and the actual search result.

The second scenario is part of KSM functionality, which is out of scope for current testing.

 

Thank you.

Share this post


Link to post
Hello.

 

Please collect Server + Console traces while reproducing the first scenario and describe it step by step, including the value you enter into the text field, the expected and the actual search result.

The second scenario is part of KSM functionality, which is out of scope for current testing.

 

Thank you.

Hi,

 

Please find the requested files in the following link: https://www.dropbox.com/sh/4d9ub4aw2dmg3it/...Akvw9pY8Ia?dl=0 . The steps are represented by means of 3 pictures, if you still have doubts, please tell me and I will try to explain in a better way.

Sorry, I've executed Console Trace but I couldn't find any trace.

 

Thank you.

 

Regards,

Luan

Edited by luanlucas

Share this post


Link to post

Hi,

 

Could you kindly update KSC to beta2 version 10.3.303 and check whether the problem still persists?

 

BR

Share this post


Link to post
Hi,

 

Could you kindly update KSC to beta2 version 10.3.303 and check whether the problem still persists?

 

BR

Hi,

 

I made the update yesterday to KSC version 10.3.303 and the problem still happens.

Just a little note, if I make the research using Device Name I get the correct result, however Device Name is not shown when a Device is connected and an event is created.

Thank you.

 

Regards,

Luan

Edited by luanlucas

Share this post


Link to post
Hi,

 

I made the update yesterday to KSC version 10.3.303 and the problem still happens.

Just a little note, if I make the research using Device Name I get the correct result, however Device Name is not shown when a Device is connected and an event is created.

Thank you.

 

Regards,

Luan

 

Please describe the whole scenario step-by-step illustrating every step by screen shots.

Thank you.

Share this post


Link to post
Please describe the whole scenario step-by-step illustrating every step by screen shots.

Thank you.

Hi,

 

I need release access to some devices in my company using its ID, to do this I go to Trusted Devices option in Device Control. When I research in a general way, searching all devices detected, it works perfectly (Trusted_Devices_Interface.jpg) but when I specify an ID no devices are returned (First_Search.jpg and Second_Search.jpg).

 

Thank you.

 

Regards,

Luan

post-575933-1450873415_thumb.jpg

post-575933-1450873421_thumb.jpg

post-575933-1450873427_thumb.jpg

Share this post


Link to post
Hi,

 

I need release access to some devices in my company using its ID, to do this I go to Trusted Devices option in Device Control. When I research in a general way, searching all devices detected, it works perfectly (Trusted_Devices_Interface.jpg) but when I specify an ID no devices are returned (First_Search.jpg and Second_Search.jpg).

 

Thank you.

 

Regards,

Luan

 

Now the scenario is absolutely clear.

Please collect GSI utility report from client machine where these devices are located and collect console and server traces during the problem reproduction.

Thank you.

Share this post


Link to post
Now the scenario is absolutely clear.

Please collect GSI utility report from client machine where these devices are located and collect console and server traces during the problem reproduction.

Thank you.

Hi,

 

Please find the requested files in the link https://www.dropbox.com/sh/4d9ub4aw2dmg3it/...Akvw9pY8Ia?dl=0. I'm sorry but I couldn't find console trace (klakcon.txt if I'm not mistaken)

Thank you.

 

Regards,

Luan

Edited by luanlucas

Share this post


Link to post
Please explain how did you collect console traces and where did you seek traces ?

Thank you.

Hi,

 

I have downloaded trace_console-4.zip from http://support.kaspersky.com/9323, executed console-4-x64-ON (O.S. is 64 bits) and searched in Kaspersky Security Center folder.

 

Regards,

Luan

Share this post


Link to post
Hi,

 

Is it true, that console traces were not generated?

 

Thank you!

Hi,

 

Yes, I think so. As I said, I've executed console-4-x64-ON and searched for klakcon.txt file in Kaspersky Security Center folder but I couldn't find it.

 

Regards,

Luan

Share this post


Link to post
Hi,

 

Yes, I think so. As I said, I've executed console-4-x64-ON and searched for klakcon.txt file in Kaspersky Security Center folder but I couldn't find it.

 

Regards,

Luan

 

Hi,

 

The file is located in the Administration Console installation folder. Are you able to navigate to the Administration Console installation folder and run dir /s > myfile.txt command with providing us the output?

 

Thank You!

Share this post


Link to post
Hi,

 

The file is located in the Administration Console installation folder. Are you able to navigate to the Administration Console installation folder and run dir /s > myfile.txt command with providing us the output?

 

Thank You!

Hi,

 

In the server where Kaspersky Security Center is installed do I have a separated folder to Administration Console? If I do, could you tell me the path, please?

 

Regards,

Luan

Share this post


Link to post
Hi,

 

In the server where Kaspersky Security Center is installed do I have a separated folder to Administration Console? If I do, could you tell me the path, please?

 

Regards,

Luan

 

Yes, it should be in Kaspersky Security Center folder. Did you Restart the Administration Console after enabling/disabling trace file generation? Please try to execute 32bit start and stop reg file just in case.

 

Thank You!

Share this post


Link to post
Yes, it should be in Kaspersky Security Center folder. Did you Restart the Administration Console after enabling/disabling trace file generation? Please try to execute 32bit start and stop reg file just in case.

 

Thank You!

Hi,

 

Sorry for the trouble, I just restarted Administration Console and the file was created and I made all the necessary tests. Please find it in the following link https://www.dropbox.com/sh/4d9ub4aw2dmg3it/...Akvw9pY8Ia?dl=0.

 

Regards,

Luan

Share this post


Link to post
Hi,

 

Sorry for the trouble, I just restarted Administration Console and the file was created and I made all the necessary tests. Please find it in the following link https://www.dropbox.com/sh/4d9ub4aw2dmg3it/...Akvw9pY8Ia?dl=0.

 

Regards,

Luan

 

Hi,

 

Issue 1560263:[bETA] When specify an ID no devices are returned in Add trusted devices by ID search

 

was submitted and currently assigned to our developers.

 

Thank You!

Share this post


Link to post
Hi,

 

I'm using KSC 10.3.295, NA 10.3.295, KES 10.2.4.649 and KSM 10.5.112.7263.

 

First suggestion would be to fix the error in Device Control, in Trusted Devices more specifically. When I try to find a device to add as a Trusted Device using the ID within the informations that was generated by device block event the research does not bring anything. The only way I can find the device is using its name or searching by host name.

 

Second suggestion would be add the possibility to add websites by using wildcards (*) in Web Protection of Kaspersky Security for Mobile when the option selected is "Only listed websites are allowed". Currently the only way I can do that is specifying each web site, but it would take a huge work in case, for example to allow every web site within kaspersky domain.

 

Thank you.

 

Regards,

Luan

 

Hello.

 

According to the developer, both cases represent designed behaviour of the software (e.g. only Device name field is searchable). Suggestions may be submitted for future releases using CompanyAccount, but are out of the scope of the current testing.

 

Thank you.

Share this post


Link to post
Hello.

 

According to the developer, both cases represent designed behaviour of the software (e.g. only Device name field is searchable). Suggestions may be submitted for future releases using CompanyAccount, but are out of the scope of the current testing.

 

Thank you.

Hi,

 

Thank you for the answer. I have only one doubt, how could I search by Device name if this field is not shown on the event which belongs to inserting/blocking devices?

 

Regards,

Luan

Share this post


Link to post

Hi,

 

If user send a request to allow access to device you will get an event in the KSC -> Reports and notifications -> Events -> User requests.

Request will contain a device ID, computer and user names.

 

BR

Share this post


Link to post
Hi,

 

If user send a request to allow access to device you will get an event in the KSC -> Reports and notifications -> Events -> User requests.

Request will contain a device ID, computer and user names.

 

BR

Hi,

 

Thank you for your support!

 

Regards,

Luan

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.