Jump to content
Demiad

Ошибка запроса к серверу активации [В процессе] [1323938] [1629350]

Recommended Posts

Тестовая среда: MS WS2012R2 (или любая другая)

Номер сборки: 10.3.295

Шаги: прокси-сервер в настройках KSC прописан (раздел "Параметры подключения к сети Интернет"), базы на KSC обновляются, проверка подключения к KSN пишет, что всё хорошо, значит подключение KSC к интернету настроено корректно.

Открыть консоль KSC, перейти в свойства сервера KSC, раздел "Ключи", поле "Активный ключ", нажать "Изменить", в окне "Ключи" нажать "Добавить", выбрать "Ввести код активации".

В поле "Введите код активации" указать один из ключей активации предоставленных к тестированию:

JYPFD-BCAQ7-EEHJW-YQBRM

из beta_keys.zip\ ActivationCodes_13CE-151026-150933.txt

либо

ZEJN7-7KBMZ-QQSJP-528KN

release_notes_KSC10SP2_10.3.295__forum_RU.txt

1) Установите Сервер администрирования и Консоль администрирования. Для активации функциональности системного администрирования и управления мобильными устройствами введите код активации соответствующей лицензии в Мастере первоначальной настройки. Для целей первоначального ознакомления с функциональностью системного администрирования и управления мобильными устройствами используйте следующий тестовый код активации: ZEJN7-7KBMZ-QQSJP-528KN. Для использования функциональности управления антивирусной защитой дополнительный код активации не требуется.

Результат:

post-454289-1447796437_thumb.png

 

Ожидаемый результат: не ясно что значит сообщение, из него надо понимать что-то не то с подключением к серверу, но если же написать вместо предоставленных кодов активации случайных набор букв, то ошибка будет именно на некорректный код, значит подключение всё-таки есть:

post-454289-1447797191_thumb.png

 

Поэтому мне кажется текст первой ошибки неправильный, либо неполный, или не то написано, или не работает фунционал активации по кодам, или если не то и не то, то перевести сообщение забыли в любом случае.

 

Я на практике кодами активации не пользуюсь, ситуацию изложил, вам должно быть понятно.

Share this post


Link to post

Здравствуйте,

 

Пожалуйста, соберите трассировки сервера и консоли в момент воспроизведения проблемы.

 

Спасибо!

Share this post


Link to post

Добрый день!

 

Вот комментарий от разработчика:

1. Консоль адм-я использует настройки прокси из операционной системы (WPAD или "Control Panel/Internet Options"). Прокси сервер настроенный в свойствах сервера адм-я, в данном сценарии, игнорируется.

2. Из трейса консоли следует что все попытки соединиться с серверами активации ожидаемо завершились ошибкой "Couldn't connect to server".

 

Т.е. следует настроить прокси в панели управления в ОС и повторит попытки.

 

Спасибо!

Share this post


Link to post

На момент предыдущей трассировки по идее в настройках IE д.б. стоять опция "Автоматическое определение параметров", которая находит WPAD и значит доступ в инет был. Только если я вдруг это зачем-то не убрал, что маловероятно. Учётка на сервере под которой сеанс в ОС с доступом в инет через тот прокси.

На текущий момент я могу проверить только на анонимном прокси-сервере, так и сделал.

 

Сделал трассировку с видео.

Захожу в ИЕ, показываю прописанный прокси (который не требует авторизации на нём), показываю настройки прокси (доказательство), показываю как браузер открывает топик на форуме. Включаю трассировку. Иду в свойства KSC, пытаюсь выполнить активацию по коду с форума, и тут мне выдаёт запрос авторизации на прокси, а быть его не должно. Я нажимаю в окне запроса уч.данных "ОК", оно возвращается. Закрываю его. Возвращаюсь к вводу кода активации, пишу там заведомо неверный код "12345", пытаюсь по нему активировать, выдаёт соответствующий ответ от серверов ЛК о неверном коде активации.

Я выше уже писал, что с неверным кодом именно такая ситуация, а с верным не происходит подключения (на момент создания топика через проксю, которая требует Windows-авторизацию, т.е. воспроизведено через два разных прокси, подтверждается проблема).

Закрыл все окна консоли. Ещё раз в окне браузера показываю, что интернет в нём работает.

ftp://Demiad@data14.kaspersky-labs.com/t3..._2016-01-14.rar

Share this post


Link to post
На момент предыдущей трассировки по идее в настройках IE д.б. стоять опция "Автоматическое определение параметров", которая находит WPAD и значит доступ в инет был. Только если я вдруг это зачем-то не убрал, что маловероятно. Учётка на сервере под которой сеанс в ОС с доступом в инет через тот прокси.

На текущий момент я могу проверить только на анонимном прокси-сервере, так и сделал.

 

Сделал трассировку с видео.

Захожу в ИЕ, показываю прописанный прокси (который не требует авторизации на нём), показываю настройки прокси (доказательство), показываю как браузер открывает топик на форуме. Включаю трассировку. Иду в свойства KSC, пытаюсь выполнить активацию по коду с форума, и тут мне выдаёт запрос авторизации на прокси, а быть его не должно. Я нажимаю в окне запроса уч.данных "ОК", оно возвращается. Закрываю его. Возвращаюсь к вводу кода активации, пишу там заведомо неверный код "12345", пытаюсь по нему активировать, выдаёт соответствующий ответ от серверов ЛК о неверном коде активации.

Я выше уже писал, что с неверным кодом именно такая ситуация, а с верным не происходит подключения (на момент создания топика через проксю, которая требует Windows-авторизацию, т.е. воспроизведено через два разных прокси, подтверждается проблема).

Закрыл все окна консоли. Ещё раз в окне браузера показываю, что интернет в нём работает.

ftp://Demiad@data14.kaspersky-labs.com/t3..._2016-01-14.rar

 

Здравствуйте,

информация передана разработчикам.

Спасибо.

Share this post


Link to post

На момент сборки трассировки у пользователя .\KlScSvc не был разрешён Вход в качестве службы.

Значит служба "Прокси-сервер активации "Лаборатории Касперского"" (klactprx) не стартовала (и две другие от этого пользователя).

Разрешил, перегрузил ОС сервера. Проблема всё равно воспроизводится как до восстановления работы службы.

 

Но на всякий случай пересобрал трассировку по этому же сценарию с корректно работающими службами от .\KlScSvc.

 

Единственное отличие от предыдущего сценария вместо показа "настройки прокси (доказательство)", я на видео это пропустил и сделал скрин, плюс выгрузил с прокси лог и тоже его положил в архив.

ftp://Demiad@data14.kaspersky-labs.com/t3...016-01-14-2.rar

Share this post


Link to post
На момент сборки трассировки у пользователя .\KlScSvc не был разрешён Вход в качестве службы.

Значит служба "Прокси-сервер активации "Лаборатории Касперского"" (klactprx) не стартовала (и две другие от этого пользователя).

Разрешил, перегрузил ОС сервера. Проблема всё равно воспроизводится как до восстановления работы службы.

 

Но на всякий случай пересобрал трассировку по этому же сценарию с корректно работающими службами от .\KlScSvc.

 

Единственное отличие от предыдущего сценария вместо показа "настройки прокси (доказательство)", я на видео это пропустил и сделал скрин, плюс выгрузил с прокси лог и тоже его положил в архив.

ftp://Demiad@data14.kaspersky-labs.com/t3...016-01-14-2.rar

 

Судя по приложенным данным. поведение программы не изменилось. По-прежнему не настроен прокси в ОС.

 

14.01.2016 14:12:51.197 0000134C.00000CD8 L4 KLOLA: KLOLA::MyTracer::Trace - OnDetectingProxy returned 0 proxies

 

Консоль пытается законнектиться к серверам напрямую и получает ошибку.

 

Пожалуйста, проверьте воспроизведение при корректно настроенном прокси.

 

Спасибо.

Share this post


Link to post

Я думаю это не удивительно, поскольку консоль KSC пытается авторизоваться на анонимном прокси-сервере

Я писал об этом:

Сделал трассировку с видео.

Захожу в ИЕ, показываю прописанный прокси (который не требует авторизации на нём), показываю настройки прокси (доказательство), показываю как браузер открывает топик на форуме. Включаю трассировку. Иду в свойства KSC, пытаюсь выполнить активацию по коду с форума, и тут мне выдаёт запрос авторизации на прокси, а быть его не должно. <...>

На видео 57-я секунда:

post-454289-1453453223_thumb.png

Edited by Demiad

Share this post


Link to post

Добрый день!

 

Информация добавлена к issue.

 

Спасибо!

Share this post


Link to post

Добрый день!

 

У разработчиков возникли дополнительные вопросы.

Вы сможете предоставить доступ к стенду, на котором "живет" проблема?

 

Спасибо!

Share this post


Link to post
Я думаю это не удивительно, поскольку консоль KSC пытается авторизоваться на анонимном прокси-сервере

Я писал об этом:

 

На видео 57-я секунда:

cred.png

 

Альтернативно. можно собрать необходимую диагностику, используя предоставленный разработчиком модуль klakcon с расширенной трассировкой.

Необходимо подменить klakcon.dll в папке KSC версией из архива по ссылке, затем собрать воспроизведение.

 

Спасибо!

 

Share this post


Link to post

ftp://Demiad@data14.kaspersky-labs.com/t3..._2016-02-01.rar

Ранее на прокси был порт 3128, сейчас изменён на 3000, а так всё как было.

Показываю как меняю dll'ку. Включаю трассировку. Перехожу в свойства сервера\ Ключи\ Активация по коду. Перехожу в IE на форум, копирую с него код активации, вставляю окно активации, нажимаю далее. Запрос к серверу, запрос авторизации, нажал ОК, опять запрос. Закрыл все окна, выключил трассировку. Показал настройки IE (то что прокси прописан).

 

 

Share this post


Link to post

На 10.3.383 по-прежнему на анонимном прокси запрашивает авторизацию при попытке добавить лицензию в хранилище KSC при добавление через код активации.

Share this post


Link to post
На 10.3.383 по-прежнему на анонимном прокси запрашивает авторизацию при попытке добавить лицензию в хранилище KSC при добавление через код активации.

Здравствуйте!

 

Просьба подробно описать возникающую проблему, актуальный результат, ожидаемый результат и тд. Также необходимо собрать трассировки в момент воспроизведения и предоставить их нам.

На основе этих данных мы заведем новую issue.

 

Спасибо!

Share this post


Link to post

По сценарию ничего нового, на анонимном прокси KSC при добавлении лицензии по коду активации решает запросить учётные данные.

 

Видео с трассировкой:

ftp://Demiad@data14.kaspersky-labs.com/t3..._2016-02-29.rar

 

Показываю настройки IE, в котором прописан прокси hostname:3128, захожу IE на vk.com для проверки работы прокси. Включаю трассировку, открываю консоль на "Лицензии на ПО Лаборатории Касперского", нажимаю "Добавить ключ", выбрал "Активировать программу с помощью кода активации", ввёл код активации "JYPFD-BCAQ7-EEHJW-YQBRM" в поле "Введите код активации", нажал "Далее". На статусе "Соединение с сервером активации" через секунд 20 появляется диалоговое окно авторизации на прокси.

Edited by Demiad

Share this post


Link to post
По сценарию ничего нового, на анонимном прокси KSC при добавлении лицензии по коду активации решает запросить учётные данные.

 

Видео с трассировкой:

ftp://Demiad@data14.kaspersky-labs.com/t3..._2016-02-29.rar

 

Показываю настройки IE, в котором прописан прокси hostname:3128, захожу IE на vk.com для проверки работы прокси. Включаю трассировку, открываю консоль на "Лицензии на ПО Лаборатории Касперского", нажимаю "Добавить ключ", выбрал "Активировать программу с помощью кода активации", ввёл код активации "JYPFD-BCAQ7-EEHJW-YQBRM" в поле "Введите код активации", нажал "Далее". На статусе "Соединение с сервером активации" через секунд 20 появляется диалоговое окно авторизации на прокси.

Здравствуйте!

 

По вашей проблеме заведена issue 1614909.

 

Спасибо!

Share this post


Link to post
По сценарию ничего нового, на анонимном прокси KSC при добавлении лицензии по коду активации решает запросить учётные данные.

 

Видео с трассировкой:

ftp://Demiad@data14.kaspersky-labs.com/t3..._2016-02-29.rar

 

Показываю настройки IE, в котором прописан прокси hostname:3128, захожу IE на vk.com для проверки работы прокси. Включаю трассировку, открываю консоль на "Лицензии на ПО Лаборатории Касперского", нажимаю "Добавить ключ", выбрал "Активировать программу с помощью кода активации", ввёл код активации "JYPFD-BCAQ7-EEHJW-YQBRM" в поле "Введите код активации", нажал "Далее". На статусе "Соединение с сервером активации" через секунд 20 появляется диалоговое окно авторизации на прокси.

 

Проблема будет исправлена в KSC 10 SP2 MR1 (в рамках бага 1629350).

 

Спасибо.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.