Jump to content
Demiad

Нет возможности не указывать уч.данные для SMTP [Bug 1263093]

Recommended Posts

KES\ Настройка уведомлений "Уведомления"\ "Настройка почтовых уведомлений"\ "Отправка уведомлений от имени"\ поля "Имя пользователя" и "Пароль".

Нет возможности оставить их пустыми на случай, когда авторизация на SMTP-сервере не требуется.

post-454289-1442316982_thumb.png

 

Заодно тут же напишу, что если в поле "Имя пользователя" я указываю доменную учётную запись компании в любом из возможных форматов: domain\User; domain.local\User; User@domain.local - то во всех случаях при проверке отправки почтового сообщения получаю ошибку: "Сообщение не было отправлено". Если не указываю имя домена, а только имя учётной записи, всё ок, шлётся. На почтовом сервере используется Windows-авторизация.

 

Win10x64 Корп, все обновления.

Share this post


Link to post
KES\ Настройка уведомлений "Уведомления"\ "Настройка почтовых уведомлений"\ "Отправка уведомлений от имени"\ поля "Имя пользователя" и "Пароль".

Нет возможности оставить их пустыми на случай, когда авторизация на SMTP-сервере не требуется.

post-454289-1442316982_thumb.png

 

Заодно тут же напишу, что если в поле "Имя пользователя" я указываю доменную учётную запись компании в любом из возможных форматов: domain\User; domain.local\User; User@domain.local - то во всех случаях при проверке отправки почтового сообщения получаю ошибку: "Сообщение не было отправлено". Если не указываю имя домена, а только имя учётной записи, всё ок, шлётся. На почтовом сервере используется Windows-авторизация.

 

Win10x64 Корп, все обновления.

 

Здравствуйте,

 

Присылайте трассировки во время воспроизведения.

 

Спасибо!

Share this post


Link to post
Здравствуйте,

 

Присылайте трассировки во время воспроизведения.

 

Спасибо!

Открываю KES, захожу в "Настройка"\ "Дополнительные параметры"\ "Интерфейс"\ "Параметры пользовательского интерфейса"\ "Уведомления"\ "Настройка"\ "Настройка почтовых уведомлений"

Устанавливаю галку "Отправить сообщения о событиях"

В блоке "Отправка уведомлений от меня" прописываю email в поле "Адрес отправителя", сервер в "SMTP-сервер", поля "Порт", "Имя пользователя", "Пароль" не трогаю.

В блоке "Получатель уведомлений" заполняю поле "Адрес получателя", нажимаю по кнопке рядом с этим полем "Проверить" - получаю ошибку в tooltip от поля "Имя пользователя" - "Не задано имя пользователя\ Введите имя пользователя."

Затем в трёх вариантах перебираю с указанным паролем и попыткой проверки отправки написание логина с доменом в поле "Имя пользователя": domain\User; domain.local\User; User@domain.local

Трассировка, гси, евенты, скрины:

ftp://Demiad1@data8.kaspersky-labs.com/t3..._2015-09-15.rar

Share this post


Link to post
Открываю KES, захожу в "Настройка"\ "Дополнительные параметры"\ "Интерфейс"\ "Параметры пользовательского интерфейса"\ "Уведомления"\ "Настройка"\ "Настройка почтовых уведомлений"

Устанавливаю галку "Отправить сообщения о событиях"

В блоке "Отправка уведомлений от меня" прописываю email в поле "Адрес отправителя", сервер в "SMTP-сервер", поля "Порт", "Имя пользователя", "Пароль" не трогаю.

В блоке "Получатель уведомлений" заполняю поле "Адрес получателя", нажимаю по кнопке рядом с этим полем "Проверить" - получаю ошибку в tooltip от поля "Имя пользователя" - "Не задано имя пользователя\ Введите имя пользователя."

Затем в трёх вариантах перебираю с указанным паролем и попыткой проверки отправки написание логина с доменом в поле "Имя пользователя": domain\User; domain.local\User; User@domain.local

Трассировка, гси, евенты, скрины:

ftp://Demiad1@data8.kaspersky-labs.com/t3..._2015-09-15.rar

 

Здравствуйте,

уточните, пожалуйста, вы задаёте почтовый адрес отправителя, а какой учётной записи принадлежит этот адрес вы не указываете ? Так получается ?

Если вы вводите всё-таки имя учётной записи, которой принадлежит почтовый адрес, но без пароля (так как на сервере не нужно проходить аутентификацию) , то успешно всё ?

Спасибо.

 

Share this post


Link to post
уточните, пожалуйста, вы задаёте почтовый адрес отправителя, а какой учётной записи принадлежит этот адрес вы не указываете ? Так получается ?

Когда поле "Имя пользователя" не заполнено, то в таком варианте кнопка "Проверить" не активна, а "ОК" ругается на "Не задано имя пользователя\ Введите имя пользователя". Следовательно не получается.

 

Если вы вводите всё-таки имя учётной записи, которой принадлежит почтовый адрес, но без пароля (так как на сервере не нужно проходить аутентификацию) , то успешно всё ?

Если ввести учётную запись или указать любую другую, например вписать "null" (без ввода пароля в обоих вариантах), то отправка производится корректно, сообщение KES "Письмо было успешно отправлено" и письмо приходит.

 

Итого можно сделать вывод, что проблема лишь в ограничении интерфейса настроек, что требует ввода, когда на деле не всегда поле должно быть заполнено.

Share this post


Link to post

Выяснилось ещё одно обстоятельство. Предыдущее сообщение полностью верно, но дополнительно оказалось, что фразу надо продолжить:

Если ввести учётную запись или указать любую другую, например вписать "null" (без ввода пароля в обоих вариантах), то отправка производится корректно, сообщение KES "Письмо было успешно отправлено" и письмо приходит.

Это касается действия по кнопке "Проверить", а сохранить по кнопке "ОК" без ввода пароля в поле "Пароль" невозможно, пишет "Не задан пароль\ Введите пароль". Если вводишь левый пароль, то проверка по кнопке "Проверить" пишет "Письмо не было отправлено." И если сохранить с левым паролем, то письма действительно не будут отправлены и получены.

Edited by Demiad

Share this post


Link to post
Выяснилось ещё одно обстоятельство. Предыдущее сообщение полностью верно, но дополнительно оказалось, что фразу надо продолжить:

 

Это касается действия по кнопке "Проверить", а сохранить по кнопке "ОК" без ввода пароля в поле "Пароль" невозможно, пишет "Не задан пароль\ Введите пароль". Если вводишь левый пароль, то проверка по кнопке "Проверить" пишет "Письмо не было отправлено." И если сохранить с левым паролем, то письма действительно не будут отправлены и получены.

 

Здравствуйте,

 

Завел Bug 1263093:[KES10SP1MR2_FORUM] Impossible to leave empty SMTP credentials

 

Спасибо!

Share this post


Link to post

Подтверждаю исправление бага и корректную работу на KES 10.2.4.649. Заодно скажу, что в политике KSC всё также хорошо и одинаково в сравнении с интерфейсом KES.

Share this post


Link to post
Подтверждаю исправление бага и корректную работу на KES 10.2.4.649. Заодно скажу, что в политике KSC всё также хорошо и одинаково в сравнении с интерфейсом KES.

 

Здравствуйте,

 

Спасибо за информацию!

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.