Jump to content
Romeo91

Выборка - некоррекно работает при выборе из списка [В процессе] [1257184]

Recommended Posts

День добрый.

 

В KSC некорректно работает выборка по условию в "реестре оборудования"

 

Присутствуют баги.

 

1. Если менять поля с выпадающим списком, то кнопка "Применить" неактивна. Соответственно если просто нажать ОК, то изменения не сохраняются.

Если же вместе с полями списками изменить любое другое поле, то кнопка применить активируется.

 

2. Также при выборе значения из списка, если значение содержит фразу с пробелами, то поиск происходит или по первому слову из фразы, или по какому-токоличеству символов, тут непонятно.

 

Скриншоты и трассировки сервера и консоли прилагаю.

http://cloud.s-evil.ru/index.php/s/h53Aumqodlydk0t

Выборка идет по устройству - "NVIDIA GeForce 210"

Находит не один компьютер, как должно быть, а два где еще есть устройство с упоминанием NVIDIA.

 

Upd.

По трассировке сервера видно, что ищется не целиком устройство, а любое с упоминанеим слов

09.09.2015 12:38:12.682 000011F0.00001BA4 L4 KLDBADO: Starting IF OBJECT_ID('tempdb..#ftx_v_hwinv_pc16') IS NULL CREATE TABLE #ftx_v_hwinv_pc16 (nId BIGINT )...

09.09.2015 12:38:12.684 000011F0.00001BA4 L4 KLDBADO: ...IF OBJECT_ID('tempdb..#ftx_v_hwinv_pc16') IS NULL CREATE TABLE #ftx_v_hwinv_pc16 (nId BIGINT ) took 1,949689 ms (User: 0 ms, Kernel: 0 ms, FullLoad: 0 %)

09.09.2015 12:38:12.685 000011F0.00001BA4 L4 SRVFTSEARCH: Starting SRVFTSEARCH::SrvFtSearchImpl::Search...

09.09.2015 12:38:12.685 000011F0.00001BA4 L3 SRVFTSEARCH: Starting SRVFTSEARCH::SrvFtSearchImpl::SearchI...

09.09.2015 12:38:12.685 000011F0.00001BA4 L3 SRVFTSEARCH: szwIndexName:'v_hwinv_pc', szwQuery:'dev_name:NVIDIA dev_name:GeForce dev_name:210'

post-188177-1441781482_thumb.png

post-188177-1441781489_thumb.png

post-188177-1441781495_thumb.png

Edited by Romeo91

Share this post


Link to post
Здравствуйте,

 

Уточните, пожалуйста, о какой версии KSC идет речь?

 

Спасибо!

Топик изначально заводился в ветке бета-тестирования патча D (10.2.434), к данной версии и относится. Более старой у меня под рукой нет, но если тема перенесена в общий форум, то она уже не нова.

Share this post


Link to post
Топик изначально заводился в ветке бета-тестирования патча D (10.2.434), к данной версии и относится. Более старой у меня под рукой нет, но если тема перенесена в общий форум, то она уже не нова.

 

Заведена ошибка 1257184.

 

Спасибо!

Share this post


Link to post
Топик изначально заводился в ветке бета-тестирования патча D (10.2.434), к данной версии и относится. Более старой у меня под рукой нет, но если тема перенесена в общий форум, то она уже не нова.

 

Проблема будет исправлена в следующем релизе KSC.

 

Спасибо!

Share this post


Link to post
Проблема будет исправлена в следующем релизе KSC.

 

Спасибо!

День добрый.

Просьба написать чуть-чуть поточнее. Чтобы потом понимать что проверять при тестировании.

Следующий релиз это например патч E и выше?

Или же имеется ввиду SP2.

Share this post


Link to post
День добрый.

Просьба написать чуть-чуть поточнее. Чтобы потом понимать что проверять при тестировании.

Следующий релиз это например патч E и выше?

Или же имеется ввиду SP2.

 

Исправление внесено начиная со сборки 10.2.580.

Патч D основан на сборке 10.2.578. Версия SP2 будет относиться к ветке 10.3.

Таким образом, ожидать исправление следует в ближайшем патче для SP1 (патче E).

 

Спасибо.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.