Jump to content
SAJFLAD

Firefox 40/41/42/43: Kasp addons could not be verified with Firefox 40/41/42/43

Recommended Posts

It worked, thank you :ay:

 

It worked but when/if you install firefox 44 in about 5 weeks, the Kasperky addons will be permanently disabled and you wont’ be able to do any config “tricks” this time. If you want to keep Kasperky you will probably need to upgrade to KIS 2016 and wait for the rumoured version that has “signed” firefox add-ons.

 

Share this post


Link to post

The upcoming Kaspersky 2016MR1 products (now finishing beta testing stage) have the "Kaspersky Protection" add-on signed for FireFox ;)

Share this post


Link to post
Yup frustrating as FF has provided info that this was going to happen

 

May be this will help you.

 

Firefox 43: Firefox will have a preference that allows signature enforcement to be disabled (xpinstall.signatures.required in about:config).

 

Set to false

 

 

Share this post


Link to post

Many users have found that in the recent FF updates that it shows that Kas Protection extension is not signed and is now disabled.

The solution most often given here in the forum (by moderators) is to disable the verification check in FF for Add-ons.

In my opinion, this is a foolhardy solution, and is much like saying, "If your brakes squeak, just cut the brake fluid lines to the squeaky wheels and the noise will go away."

I would have hoped for a better response and if I had seen this previously I would not have bought Kas and looked for a competitor's product.

I work in customer support and I know good support when I see it. This ain't it!

Share this post


Link to post
Many users have found that in the recent FF updates that it shows that Kas Protection extension is not signed and is now disabled.

The solution most often given here in the forum (by moderators) is to disable the verification check in FF for Add-ons.

In my opinion, this is a foolhardy solution, and is much like saying, "If your brakes squeak, just cut the brake fluid lines to the squeaky wheels and the noise will go away."

I would have hoped for a better response and if I had seen this previously I would not have bought Kas and looked for a competitor's product.

I work in customer support and I know good support when I see it. This ain't it!

 

Welcome. You are looking for Tech Support? This is the user forum.

 

Here, is user to user assistance, and moderators close unresolvable flood topics. :)

 

If the issue is not resolvable here, please contact Tech Support: https://my.kaspersky.com/en/support/helpdesk

Share this post


Link to post

Firefox updated to 43.0.1 this morning and I got a notification that Kaspersky surfing protection has been disabled because it could not be verified.

Running windows 10 64 bit

Kaspersky Internet Security 16.0.0.614 (d)

I noticed the icon on the toolbar was no longer there also.

Can anyone help me with this matter?

 

Thanks in advance,

Tony G.

 

 

Share this post


Link to post

I know someone will post some other forum or something, but all i want to know is if Kaspersky is fixing this issue. Thank you.

 

 

 

//edit: merged. The fix is in the works. It will happen somewhere around WIIR.

Edited by richbuff

Share this post


Link to post

Yes, yes... I've read the other threads. However, I do not have enough knowledge to understand what they are talking about (sorry!) I need very, very simple instructions on what I need to do. Do I need to uninstall Kaspersky? Am I still protected? How do I fix this please?

 

My Kaspersky license is brand new (363 days remaining) and I am concerned about FF "disabling" my protection. What am I supposed to do please?

Share this post


Link to post

The Mozilla Firefox addons from Kaspersky:

 

"Dangerous website blocker"

 

"Safe Money"

 

"Virtual Keyboard"

 

are not verified with Firefox. Of course I'm assuming these are safe, but because they are not officially verified I think it's possible the add-ons may cause some latency or lag when in use with Firefox.

 

I suggest Kaspersky verify their addons with all web browsers--particularly Firefox--to assure optimum efficiency.

 

I'm using Firefox 43.0.1 on Windows 8.1.

 

 

Share this post


Link to post

Welcome to the forum.

 

1.- Open FireFox.

 

2.- In address bar, where You usually type the URL adress of the WebSites, type about:config and clik on [ENTER] in Your keyboard.

 

3.- A new tab with a warning will be opened, just accept it.

 

4.- In the new tab, in Search, type: xpinstall

 

5.- In the results, go to the line: xpinstall.signatures.required -> select it with a left mouse button click.

 

6.- Once selected, 1 click with right mouse button -> select Modify.

 

7.- The actual "True" value will change to "False".

 

8.- Done, close FireFox, and open it again.

 

9.- Go to FireFox Settings -> Complements/Add-ons -> Enable "Kaspersky Protection" add-on.

Edited by harlan4096

Share this post


Link to post
Welcome to the forum.

 

1.- Open FireFox.

 

2.- In address bar, where You usually type the URL adress of the WebSites, type about:config and clik on [ENTER] in Your keyboard.

 

3.- A new tab with a warning will be opened, just accept it.

 

4.- In the new tab, in Search, type: xpinstall

 

5.- In the results, go to the line: xpinstall.signatures.required -> select it with a left mouse button click.

 

6.- Once selected, 1 click with right mouse button -> select Modify.

 

7.- The actual "True" value will change to "False".

 

8.- Done, close FireFox, and open it again.

 

9.- Go to FireFox Settings -> Complements/Add-ons -> Enable "Kaspersky Protection" add-on.

 

 

Harlan, thank you so much for your very informative post!

 

I followed your instructions. However, regarding item #6, I was not given an option to "modify" but instead was given an option to "toggle" so I selected that. Is that correct? Afterwards, my setting changed to "false" (as you indicated).

 

Did I do it right please?

 

Here are my results:

post-169007-1450891141_thumb.jpg

post-169007-1450891148_thumb.jpg

Edited by SunnySouth

Share this post


Link to post

Sorry, I just translated from my Spanish FireFox :)

 

But Yes! You did it l! this is the right result :)

Share this post


Link to post

Given that I use Kaspersky Internet Security, and Firefox as my usual browser, at some point I installed Kaskersky's Dangerous Websites Blocker as an add-on for Firefox. Now that add-on is blocked for lack of a signature.

 

Is the DW Blocker redundant, or should Kaspersky be re-signing it through Firefox?

 

Here is their message and explanation:

-----

Kaskersky's Dangerous Websites Blocker 4.5.1.379 could not be verified for use in Firefox and has been disabled. Last updated October 6, 2015

 

 

If an installed add-on is disabled because it hasn't been signed, contact the add-on developer or vendor to see if they can offer an updated and signed version of that add-on. You can also ask them to get their add-on signed. Another option is to visit addons.mozilla.org to see if there's a signed version of the add-on you can install.

 

Newer versions of Firefox add protection against malware and browser hijackers by warning you about and (starting in Firefox 43) blocking third-party add-ons that are not verified and digitally signed by Mozilla.

 

While Firefox currently has a blocklist system, it is increasingly difficult to track and block the growing number of malicious add-ons. The new add-on signing process requires developers to follow Mozilla Developer guidelines and ensure that their add-ons are safe to install. Firefox warns you when an add-on did not complete the signing process. For now you can still install the unverified add-on at your own risk, but starting with Firefox 43, such add-ons will get deactivated as well.

 

 

 

 

 

 

Share this post


Link to post

Welcome to the forum.

 

In FF address bar, type: about:config, accept the warning and find: xpinstall.signatures.required, if in "true" then change it to "false"

Share this post


Link to post

The thread is locked so joined just so I can say thanks to harlan4096 for his step by step instructions on the HUGELY frustrating issue with Firefox disabling everything, no signature, safe money, virtual keyboard fiasco.

Your instructions worked perfect, green bar is back, everything is enabled and my screen doesn't go to the BSOD everytime I open safemoney.

 

Thanks again, not all of us are computer wizards.

 

Smoove :cb_punk:

Share this post


Link to post

OK, I'm aware of the fact that there's been many topics on that, later all merged into a single one which was concluded with an advice of disabling FF addons signature verification (see here).

 

However with all respect, this is NOT a solution - by disabling this feature you also loosen your overall FF security and face a risk of malicious addons being installed. This is definitely not a type of advice I would expect from a security software developer!

 

So, my question is - do we have to stick to this risky workaround or do the developers plan to truly fix this one (cooperating with Mozilla I presume)?

Share this post


Link to post

Welcome to the forum.

 

The upcoming Kaspersky 2016MR1 products (now in Release Candidate stage) have already the "Kaspersky Protection" add-on signed for FireFox, probably will be released in January/February 2016.

Edited by harlan4096

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.