Jump to content
Sign in to follow this  
851d229

[En cours] Poste ne s'accroche pas à la console

Recommended Posts

Bonjour,

 

Nous avons une console Kaspersky Security Center 10. Nos postes sont protégés avec le client Endpoint Security 10.2.1.23 et avec l'agent 10.1.149. Nous avons souvent des postes qui ne s'accrochent pas à la console, en fait l'agent est bien installé, l'objet de l'ordinateur apparait sur la console, et informe même que la connection est active depuis x minutes mais lorsqu'on va sur le poste, ça n'indique pas que l'utilisateur "travaille sous une stratégie"... les stratégie ne sont donc pas poussées et les mises à jour ne se font pas selon les stratégies de la console.

 

Pour tenter de régler le problème, je lance sur l'ordinateur l'utilitaire klmover -dupfix qui tente de réinitialiser l'identificateur de la machine mais parfois ça marche et parfois ça ne marche pas. Parfois je détruit l'objet sur la console et ça aide, mais parfois non. Mais je n'ai pas trouvé de solution "ultime" qui marche à tout coup.

 

Dans un cas comme celui-ci, existe t-il une façon simple et efficace qui permet à un ordinateur de se "raccrocher" à la console? et ce sans devoir faire des "accrobaties" comme désinstaller l'agent réinstaller l'agent ou réinstaller le client.... aussi je voudrais faire en sorte que les techniciens responsables des ordinateurs ne soient pas obligés de demander à détruire les objets sur la console afin de régler les problèmes....

 

je suis sûr qu'il existe une ligne de commande qui permet de régler ce genre de problème mais laquelle commande ?

 

merci !

DM

Share this post


Link to post

Bonjour 851d229,

 

le fait que le poste client protégé par un antivirus (ex: KES) remonte au travers la console Security Center avec un agent d'administration correctement installé (+/+)

ne valide pas le fait qu'une stratégie KES est bien appliquée ou pas à la protection antivirus.

 

En effet afin qu'un poste client puisse absorber correctement sa stratégie antivirus,

il doit être présent dans un groupe/sous-groupe logique de la branche "ordinateurs administrés",

dans lesquel une stratégie antivirus adaptée est bien appliquée et active.

 

D'une autre part et concernant les opérations de diagnostic du Network agent,

nous te conseillons de consulter cet article de notre KB :

http://support.kaspersky.com/7493

 

Attention, il n'est pas conseillé d'utiliser la commande klmover -dupfix à profusion qui a pour but de générer un nouvel ID de l'ordinateur,

sans risque de générer de multiples postes fantômes au sein de la console d'administration. (~1, ~2, ~3 ...)

 

Si malgré cela, l'agent a toujours un statut instable ou la stratégie KES n'est pas correctement réceptionné par le client, alors les causes probables sont les suivantes :

 

1 - service du NA stoppé ou instable/planté :

- Lancez la commande "scquery klnagent" afin de vérifier l'état du service.

Consultez les Kaspersky Events logs et si des dumps du NA ont été générés à la racine de son dossier et sous-dossier "~dumps".

 

- Appliquer le dernier correctif patch D au serveur Sc et Network agent des clients, disponible ci-dessous :

http://support.kaspersky.com/us/11604#block1

 

2 - composant connector (avpcon.dll) instable. Celui ci assurant la bonne communication et la transmission d'informations entre l'agent et l'antivirus.

- Vérifiez si celui ci est correctement chargée par le processus "klnagent.exe" à l'aide d'outil tel que Process explorer par exemple :

http://technet.microsoft.com/fr-fr/sysinternals/bb896653

 

 

 

 

Bon courage et bonne journée. :)

Share this post


Link to post

Ok merci des infos, je vais probablement commencer par mettre à jour la console avec le patch D.... ou la dernière version de la console

 

 

 

Bonjour 851d229,

 

le fait que le poste client protégé par un antivirus (ex: KES) remonte au travers la console Security Center avec un agent d'administration correctement installé (+/+)

ne valide pas le fait qu'une stratégie KES est bien appliquée ou pas à la protection antivirus.

 

En effet afin qu'un poste client puisse absorber correctement sa stratégie antivirus,

il doit être présent dans un groupe/sous-groupe logique de la branche "ordinateurs administrés",

dans lesquel une stratégie antivirus adaptée est bien appliquée et active.

 

D'une autre part et concernant les opérations de diagnostic du Network agent,

nous te conseillons de consulter cet article de notre KB :

http://support.kaspersky.com/7493

 

Attention, il n'est pas conseillé d'utiliser la commande klmover -dupfix à profusion qui a pour but de générer un nouvel ID de l'ordinateur,

sans risque de générer de multiples postes fantômes au sein de la console d'administration. (~1, ~2, ~3 ...)

 

Si malgré cela, l'agent a toujours un statut instable ou la stratégie KES n'est pas correctement réceptionné par le client, alors les causes probables sont les suivantes :

 

1 - service du NA stoppé ou instable/planté :

- Lancez la commande "scquery klnagent" afin de vérifier l'état du service.

Consultez les Kaspersky Events logs et si des dumps du NA ont été générés à la racine de son dossier et sous-dossier "~dumps".

 

- Appliquer le dernier correctif patch D au serveur Sc et Network agent des clients, disponible ci-dessous :

http://support.kaspersky.com/us/11604#block1

 

2 - composant connector (avpcon.dll) instable. Celui ci assurant la bonne communication et la transmission d'informations entre l'agent et l'antivirus.

- Vérifiez si celui ci est correctement chargée par le processus "klnagent.exe" à l'aide d'outil tel que Process explorer par exemple :

http://technet.microsoft.com/fr-fr/sysinternals/bb896653

 

 

Bon courage et bonne journée. :)

 

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.