Jump to content
Oleg3d

Обновление до Kaspersky Security Center 10: Service Pack 1 (версия 10.2.434) [В процессе]

Recommended Posts

Добрый день. Не подскажете, обновил сервер администрирования и в конце обновления сервер ругался на консоль администрирования. Пытаюсь установить новую консоль и мне предлагают сначала удалить сервер. При запуске сервера кнопка добавить сервер не активна - не реагирует на нажатие. Что можно предпринять ?

 

Share this post


Link to post
Добрый день. Не подскажете, обновил сервер администрирования и в конце обновления сервер ругался на консоль администрирования. Пытаюсь установить новую консоль и мне предлагают сначала удалить сервер. При запуске сервера кнопка добавить сервер не активна - не реагирует на нажатие. Что можно предпринять ?

 

Здравствуйте.

 

Пожалуйста, уточните, как выглядела ошибка во время обновления.

При установке консоли и подключении к серверу с другой машины проблема присутствует?

Под какой учетной записью запускается консоль, есть ли админские права?

 

Спасибо.

Share this post


Link to post
Здравствуйте.

 

Пожалуйста, уточните, как выглядела ошибка во время обновления.

При установке консоли и подключении к серверу с другой машины проблема присутствует?

Под какой учетной записью запускается консоль, есть ли админские права?

 

Спасибо.

Ошибки как таковой не было. Было предупреждение, что консоль не соответствует установленному серверу и не будет работать.

На другую машину ещё консоль не ставил.

Запускал под учётной записью администратора.

Share this post


Link to post
Ошибки как таковой не было. Было предупреждение, что консоль не соответствует установленному серверу и не будет работать.

На другую машину ещё консоль не ставил.

Запускал под учётной записью администратора.

 

Пожалуйста, создайте инцидент в CompanyAccount, приложите туда скриншот консоли, отчет GSI с машины и логи установки KSC SP1.

Сообщите нам номер инцидента.

 

Спасибо!

Share this post


Link to post
Да, у меня тоже было такое, что-то 3.0, не помню как решилось, kavremover-ом кажись, точно не помню.

 

Здравствуйте,

а если попробовать сначала консоль обновить, а потом сервер.

Спасибо.

Share this post


Link to post
Пожалуйста, создайте инцидент в CompanyAccount, приложите туда скриншот консоли, отчет GSI с машины и логи установки KSC SP1.

Сообщите нам номер инцидента.

 

Спасибо!

Была сохранена резервная копия сервера. Поступил так. Удалил сервер при помощи утилиты cleaner.exe. Затем установил новую версию сервера и сделал восстановление из резервной копии. Пока все работает. Поставить новую консоль без удаления установленного сервера не важно какой версии сервер - никак нельзя. Причина установки новой версии сервера антивирус на машинах с win 8.1 иногда ломается и на раб. станции пропадает доступ в интернет из браузеров. Сам антивирус изчезает из сис. трея. Лечится удалением антивируса - установкой локально - сносом и установкой уже с сервера. Может в новой версии такого бага не будет... :dash1:

Share this post


Link to post
Была сохранена резервная копия сервера. Поступил так. Удалил сервер при помощи утилиты cleaner.exe. Затем установил новую версию сервера и сделал восстановление из резервной копии. Пока все работает. Поставить новую консоль без удаления установленного сервера не важно какой версии сервер - никак нельзя. Причина установки новой версии сервера антивирус на машинах с win 8.1 иногда ломается и на раб. станции пропадает доступ в интернет из браузеров. Сам антивирус изчезает из сис. трея. Лечится удалением антивируса - установкой локально - сносом и установкой уже с сервера. Может в новой версии такого бага не будет... :dash1:

 

 

Уточните пожалуйста, а кейс создавали?

 

Спасибо.

Share this post


Link to post

поделюсь результатами экспериментов:

накатить SP1 на боевой сервер пока не рискнул

- сделал бекап боевого KSC

- на чистом сервере развернул чистый KSC10SP1

- накатил рабочий бекап на чистый KSC10SP1

по крайней мере сервер поднялся, рабочая конфигурация восстановилась, консоль работает

в сетку пока не подключал.. пока поднял в изолированном режиме.

Share this post


Link to post
поделюсь результатами экспериментов:

накатить SP1 на боевой сервер пока не рискнул

- сделал бекап боевого KSC

- на чистом сервере развернул чистый KSC10SP1

- накатил рабочий бекап на чистый KSC10SP1

по крайней мере сервер поднялся, рабочая конфигурация восстановилась, консоль работает

в сетку пока не подключал.. пока поднял в изолированном режиме.

:bt:

А напрямую обновление у вас не вышло, верно?

Share this post


Link to post
:bt:

А напрямую обновление у вас не вышло, верно?

 

почитал отзывы и напрямую пока не рискнул.. не хочется потом танцевать с бубном для реанимации покойника :)

попробовал пока на отдельном нулевом сервере

Share this post


Link to post

У меня, если разворачивать чистый KSC10SP1 и на него восстановить резервную копию, то после восстановления копии сервер перестаёт запускаться. Стоит сервис KSC10 с потребление 15 MB. Иногда перезагружается, и снова, дальше 15 MB не прогружается. Консоль, при попытке подключиться, ругается на неверное имя пользователя и пароль.

Share this post


Link to post

У меня не обновился. K249 & SQL 2008R2 Express.

Неужто вариантов по обновлению базы нет? Нужно с нуля поднимать и старую базу восстанавливать в новую? За что этот геморрой нам? ))

Edited by itdimko

Share this post


Link to post
У меня, если разворачивать чистый KSC10SP1 и на него восстановить резервную копию, то после восстановления копии сервер перестаёт запускаться. Стоит сервис KSC10 с потребление 15 MB. Иногда перезагружается, и снова, дальше 15 MB не прогружается. Консоль, при попытке подключиться, ругается на неверное имя пользователя и пароль.

 

у меня была такая-же фигня, тоже консоль не запускалась и ругалась, поскольку на новом сервере локальный админ не входит в локальную группу KLAdmins

добавил учетку локального админа в локальную группу KLAdmins и нормально зашел под ним в консоль

 

 

Edited by Aigir

Share this post


Link to post
У меня не обновился. K249 & SQL 2008R2 Express.

Неужто вариантов по обновлению базы нет? Нужно с нуля поднимать и старую базу восстанавливать в новую? За что этот геморрой нам? ))

:bt:

Я ожидал проблемы еще задолго до релиза. И не ошибся, теперь тоже не рискну на рабочий сервер обновление ставить. Даже не знаю что делать - ждать какого-нибудь KSC 10 SP1 MR2 или с импортом бэкапа заморачиваться. :unsure:

Edited by Zandatsu

Share this post


Link to post
у меня была такая-же фигня, тоже консоль не запускалась и ругалась, поскольку на новом сервере локальный админ не входит в локальную группу KLAdmins

добавил учетку локального админа в локальную группу KLAdmins и нормально зашел под ним в консоль

Все членства правильные. Сервер KSC, даже если судить по памяти которую занимает его сервис, не запускается. :(

Share this post


Link to post
Все членства правильные. Сервер KSC, даже если судить по памяти которую занимает его сервис, не запускается. :(

:bt:

Возможно вопрос прозвучит странно, но у вас локальный админ действительно имеет всю полноту привилегий? Вы пробовали использовать учетку администратора домена (если она вам доступна, разумеется)?

Share this post


Link to post
:bt:

Возможно вопрос прозвучит странно, но у вас локальный админ действительно имеет всю полноту привилегий? Вы пробовали использовать учетку администратора домена (если она вам доступна, разумеется)?

Да. С ней и устанавливал и подключался. Также пробовал подключаться со своей учётной записью, не входящей в группу админов АД-а :) , но входящих в группу KLAdmins, также не подключается и с учёткой, созданной специально для работы сервисов KSC.

Share this post


Link to post

А кто-нить пробовал:

- снести всю эту радость

- установить старый KSC10MR1

- восстановить БД и настройки из бэкапа?

 

Пускай будет работающий KSC10MR1, чем частично работающий KSC10SР1

 

Пока имею вот такую красоту

:

Database error occured: #1950 (3726) Generic db error: "3726 'Could not drop object 'nac_hosts' because it is referenced by a FOREIGN KEY constraint.' LastStatement='IF ([dbo].[upgd_if_table_exists]('nac_hosts') <> 0)

DROP TABLE nac_hosts;'"

KSC10SР1 + MSSSQL2008 (на выделенном сервере), обновлялся путем полной деинсталляции KSC10MR1, последующей установки KSC10SР1 и накатыванием бэкапа. Само обновление прошло успешно, но не взлетает...

Share this post


Link to post
А кто-нить пробовал:

- снести всю эту радость

- установить старый KSC10MR1

- восстановить БД и настройки из бэкапа?

Пока так и работает. Т.к. обновиться не получилось, пришлось возвращать MR1. :)

Share this post


Link to post

На тестовой среде (восстановленный бакап с реальной системы - ksc 10 mr1 abcd) обновление прошло успешно.

Share this post


Link to post
А кто-нить пробовал:

- снести всю эту радость

- установить старый KSC10MR1

- восстановить БД и настройки из бэкапа?

 

Пускай будет работающий KSC10MR1, чем частично работающий KSC10SР1

 

Пока имею вот такую красоту

 

KSC10SР1 + MSSSQL2008 (на выделенном сервере), обновлялся путем полной деинсталляции KSC10MR1, последующей установки KSC10SР1 и накатыванием бэкапа. Само обновление прошло успешно, но не взлетает...

 

Здравствуйте,

а Вы пробовали в тестовой среде накатить СП1 поверх МР1 ?

Спасибо.

Share this post


Link to post
Здравствуйте,

а Вы пробовали в тестовой среде накатить СП1 поверх МР1 ?

Спасибо.

:bt:

А вы можете пояснить какой в этом тайный смысл? Ведь обновлять-то все равно надо рабочий KSC, а не тестовый. Даже если тестовый обновится без запинки.

Share this post


Link to post

Рискнул, запустил обновление и все получилось.

Учетка включена в группы KLadmins и DomainAdmins.

Перед установкой обновил Windows(т.к. висело уведомление).

Edited by Vakudon

Share this post


Link to post
Рискнул, запустил обновление и все получилось.

Учетка включена в группы KLadmins и DomainAdmins.

Перед установкой обновил Windows(т.к. висело уведомление).

 

То есть на боевом сервере всё у Вас нормально прошло?

Спасибо.

Share this post


Link to post

Я вижу хоть в чемто мне свезло, обновление прошло на ура.. чисто

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.