Jump to content
Sign in to follow this  
george.h

KES 8.1.0.1042 Unprocessed Objects [In progress]

Recommended Posts

Is there EVER going to be a fix to get rid of the awful "Unprocessed Objects" bug?

 

Even adding exception to stop erroneous reports from regular software I still find that I get Unprocessed Objects which I have to MANUALLY connect to EACH CLIENT, clear out and yet STILL KSC shows damned Unprocessed Objects

 

Come on Kaspersky FIX THE DAMNED THING!

Share this post


Link to post
Even adding exception to stop erroneous reports from regular software I still find that I get Unprocessed Objects which I have to MANUALLY connect to EACH CLIENT, clear out and yet STILL KSC shows damned Unprocessed Objects

If KSC still shows the message after clearing them out from the client, I've noticed that removing the clients from KSC (Managed and Unassigned folders) clears the message.

Share this post


Link to post
If KSC still shows the message after clearing them out from the client, I've noticed that removing the clients from KSC (Managed and Unassigned folders) clears the message.

 

Nice tip, I'll try it, I've the same problem, a lot of items on KSC but cleared on clients

Share this post


Link to post
Is there EVER going to be a fix to get rid of the awful "Unprocessed Objects" bug?

 

Even adding exception to stop erroneous reports from regular software I still find that I get Unprocessed Objects which I have to MANUALLY connect to EACH CLIENT, clear out and yet STILL KSC shows damned Unprocessed Objects

 

Come on Kaspersky FIX THE DAMNED THING!

Hello!

Please kindly clarify, which version of KSC and nagent do you use?

Thank you!

Share this post


Link to post
Hello!

Please kindly clarify, which version of KSC and nagent do you use?

Thank you!

 

KSC is 9.3.75 running on Windows Server 2003. Network Agent on the endpoints is 9.3.75. The endpoints had been all XP SP3, now almost all Win 7 SP1 64 bit. Both have always shown the same problem.

 

There are three issues with this which have been present, if memory serves, for at least 3 years now - certainly as long as I've been looking after this installation. None have ever been properly addressed through several releases of KES, KSC and NAGENT.

 

1. If you view an endpoint in KSC showing as having unprocessed objects and click on the "Unprocessed Objects" link in the right hand panel where the endpoints details are shown, all you get is a list of events on that endpoint. NONE of which (as far as I have ever seen) says "Unprocessed object". Unless of course I'm meant to read through every single event entry to find it - which I won't.

2. There is NO WAY to clear this without direct interaction with the affected endpoint's desktop. Either by doing Remote Desktop or physically visiting it.

3. Even after clearing the "Unprocessed objects" from the endpoint(s) their status doesn't change in KSC. It does, EVENTUALLY, after at least 12 hours. However that means KSC is wrongly reporting the endpoint's status for a VERY LONG TIME.

 

So, are Kaspersky EVER going to fix this? Properly!

 

Share this post


Link to post
KSC is 9.3.75 running on Windows Server 2003. Network Agent on the endpoints is 9.3.75. The endpoints had been all XP SP3, now almost all Win 7 SP1 64 bit. Both have always shown the same problem.

 

There are three issues with this which have been present, if memory serves, for at least 3 years now - certainly as long as I've been looking after this installation. None have ever been properly addressed through several releases of KES, KSC and NAGENT.

 

1. If you view an endpoint in KSC showing as having unprocessed objects and click on the "Unprocessed Objects" link in the right hand panel where the endpoints details are shown, all you get is a list of events on that endpoint. NONE of which (as far as I have ever seen) says "Unprocessed object". Unless of course I'm meant to read through every single event entry to find it - which I won't.

2. There is NO WAY to clear this without direct interaction with the affected endpoint's desktop. Either by doing Remote Desktop or physically visiting it.

3. Even after clearing the "Unprocessed objects" from the endpoint(s) their status doesn't change in KSC. It does, EVENTUALLY, after at least 12 hours. However that means KSC is wrongly reporting the endpoint's status for a VERY LONG TIME.

 

So, are Kaspersky EVER going to fix this? Properly!

Hello!

Did you try solving these issue through CompanyAccount?

If yes, please give us your INC numbers.

Thank you!

Share this post


Link to post
Hello!

Did you try solving these issue through CompanyAccount?

If yes, please give us your INC numbers.

Thank you!

 

No - because we don't qualify for that and the UK support "outlet" are frankly a waste of time. However it is an issue that has appeared in this forum numerous times...

Share this post


Link to post
No - because we don't qualify for that and the UK support "outlet" are frankly a waste of time. However it is an issue that has appeared in this forum numerous times...

Each issue should be investigated carefully. As for unprocessed objects needed to be processed manually on each host - this is product design, and thus it probably won't be changed in KSC9 at least; as for delayed host status delivery - this should be investigated, and we could begin with klnagchk output from the problematic host and GSI report from it as well. Please add Kaspersky event log from this host too.

Thank you!

Share this post


Link to post
Each issue should be investigated carefully. As for unprocessed objects needed to be processed manually on each host - this is product design, and thus it probably won't be changed in KSC9 at least; as for delayed host status delivery - this should be investigated, and we could begin with klnagchk output from the problematic host and GSI report from it as well. Please add Kaspersky event log from this host too.

Thank you!

 

Thanks Ivan.....

 

Interestingly this is the first time I've heard it stated that having to manually deal with unprocessed objects on each endpoint individually is by design. Bit of a major design flaw (to my mind).

 

I'll have to manually trigger an unprocessed object on one of the endpoints (I know which applications I can use to do this) and send you the results of klnagchk from it. GSI? Could you clarify what you mean for this please? Also the Kaspersky event log, is that from KSC or the endpoint? I'm assuming you mean the endpoint.

 

Regards

George

 

EDIT: I've just looked up GetSystemInfo (GSI) report..... I'll collect that on the endpoint for you also. Do you need anything from the server running KSC?

Edited by george.h

Share this post


Link to post
Thanks Ivan.....

 

Interestingly this is the first time I've heard it stated that having to manually deal with unprocessed objects on each endpoint individually is by design. Bit of a major design flaw (to my mind).

 

I'll have to manually trigger an unprocessed object on one of the endpoints (I know which applications I can use to do this) and send you the results of klnagchk from it. GSI? Could you clarify what you mean for this please? Also the Kaspersky event log, is that from KSC or the endpoint? I'm assuming you mean the endpoint.

 

Regards

George

 

EDIT: I've just looked up GetSystemInfo (GSI) report..... I'll collect that on the endpoint for you also. Do you need anything from the server running KSC?

Hello!

Please kindly provide kaspersky event logs from KSC as well.

Thank you!

Share this post


Link to post
Hello!

Please kindly provide kaspersky event logs from KSC as well.

Thank you!

 

Will do.....

 

Typical though, I've just tried reproducing it and couldn't. I could get the "Unprocessed Object" notification email ok (I'm configured to receive these) but I think I may have cleared the unprocessed object of the client PC too quickly as when I went into KSC there were no unprocessed objects showing. I'll have to uninstall the test software, retrigger the unprocessed object event then wait for it to appear in KSC. Then I'll be able to try clearing it on the client PC and capture the log files.

 

George

 

Share this post


Link to post
Will do.....

 

Typical though, I've just tried reproducing it and couldn't. I could get the "Unprocessed Object" notification email ok (I'm configured to receive these) but I think I may have cleared the unprocessed object of the client PC too quickly as when I went into KSC there were no unprocessed objects showing. I'll have to uninstall the test software, retrigger the unprocessed object event then wait for it to appear in KSC. Then I'll be able to try clearing it on the client PC and capture the log files.

 

George

Hello!

 

So the problem is now solved for You?

 

Thank you!

Share this post


Link to post
Hello!

 

So the problem is now solved for You?

 

Thank you!

 

Unfortunately I don't think so. When I tried to reproduce the problem to capture the event logs and other information, I don't think I allowed enough time for the unprocessed object to register with KSC on the server before I cleared it on the endpoint. So now I have to find another opportunity to commandeer a endpoint PC to try again.

 

George

Share this post


Link to post
Unfortunately I don't think so. When I tried to reproduce the problem to capture the event logs and other information, I don't think I allowed enough time for the unprocessed object to register with KSC on the server before I cleared it on the endpoint. So now I have to find another opportunity to commandeer a endpoint PC to try again.

 

George

 

Hello.

 

Please provide the requested logs at your convenience.

 

Thank you.

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.