Jump to content
TechnoMag

Дополнения Kaspersky Antivirus не совместимы с версией FireFox 19.0.2

Recommended Posts

Дополнения Kaspersky Antivirus 2013 не совместимы с версией FireFox 19.0.2.

Пробная версия Kaspersky Antivirus 2013.

post-457922-1362931568_thumb.png

 

Share this post


Link to post

+1, плагины KIS несовместимы с лисой пожизненно. Заколебали. Чес слово. На клиентов совсем наплевать что ли?

Share this post


Link to post
+1, плагины KIS несовместимы с лисой пожизненно. Заколебали. Чес слово. На клиентов совсем наплевать что ли?

Вы правы, мозилле наплевать на клиентов. :icon22:

Лично меня заколебал FF- каждую неделю новые версии. Дополнения от ЛК в файерфоксе мне не нужны.

Проблема номер один в мире, что ли, что дополнения с выходом новой "лисы" не совместимы? Я вообще Оперой по умолчанию пользуюсь. :rolleyes:

Edited by Drru

Share this post


Link to post

уже не первая тема по данному поводу.пора, наверно тоже на др. браузер переходить

Share this post


Link to post
уже не первая тема по данному поводу.пора, наверно тоже на др. браузер переходить

Из-за дополнений? А они нужны?

Share this post


Link to post
Вы правы, мозилле наплевать на клиентов. :icon22:

Лично меня заколебал FF- каждую неделю новые версии. Дополнения от ЛК в файерфоксе мне не нужны.

Проблема номер один в мире, что ли, что дополнения с выходом новой "лисы" не совместимы? Я вообще Оперой по умолчанию пользуюсь. :rolleyes:

Что то другие модули у меня не отваливаются от версии к версии, только от KIS стабильно отваливаются.

Share this post


Link to post
Дополнения Kaspersky Antivirus 2013 не совместимы с версией FireFox 19.0.2.

Пробная версия Kaspersky Antivirus 2013.

post-457922-1362931568_thumb.png

 

Тут не знают как писать дополнения для FF.

 

Дополнение, использующее бинарные компоненты:

1) должно быть выложено на AMO;

2) при выходе каждой новой версии браузера должно разработчиком проверяться на совместимость с этой версией;

3) если совместимо, то разработчик должен вручную изменить информацию о совместимости в install.rdf и залить новую версию дополнения на AMO, где она будет проверена автоматическим сервисом.

 

В папке с каждым дополнением есть такая папочка (там их три, одну пишу для примера): linkfilter@kaspersky.ru\components\ff** где ** это номер поддерживаемой версии FF.

Внутри лежит файлик kavlinkfilter**.dll, это специальная dll, которая проверяет версию FF и если она не совместима, то отказывается работать, притом подмена DLL и правка конфигов ничего не дают, т.е. каспер проверяет, чтобы версии DLL соответствовали версии FF.

 

Следовательно это именно он не позволяет работать дополнениям на более старших версиях FF.

 

А в дополнении сделанном, например, для Chrome, такой проверки нет, там всего одна DLL и она пашет со всеми версиями без разбору.

 

+ Касперский - единственный антивирус, не умеющий самообновляться до актуальной версии автоматически. :angry:

 

Так что проблема совсем не в FF, проблема у разработчика антивирусного ПО.

Я вот кстати плачу за это ПО деньги, и хочу получать качественный продукт!

 

Эту версию ставьте, там все работает. http://www.mozilla.org/en-US/firefox/organizations/all.html

И не надо отсылать пользователя на устаревшие версии FF.

 

Вы правы, мозилле наплевать на клиентов. :icon22:

Лично меня заколебал FF- каждую неделю новые версии. Дополнения от ЛК в файерфоксе мне не нужны.

Проблема номер один в мире, что ли, что дополнения с выходом новой "лисы" не совместимы? Я вообще Оперой по умолчанию пользуюсь. :rolleyes:

Mozilla FF тут не при чем! Не надо на них грешить.

Edited by Kordax

Share this post


Link to post

 

Такая же проблемма firefox выдаёт сообщение обновиться до новой версии 19.02 видно устраняют уязвимости

в старых версиях оперативно,но при обновлении выдаёться информация,что плагины для KIS работать не будут -

печально KL постоянно тормозит с выпуском совместимости своих плагинов с браузером Firefox, что ставит под угрозу

безопасность пользователей использующих браузер firefox и это уже не единичный случай,/ а система KL.

 

P.S. на банкеты хватает - на исправление финансов нет?

Share this post


Link to post

каждый раз..каждый раз одна и та же хрень..вам не надоело.. ну не работают они не работают!!!

ставьте хром там все работает или не обновляйте лису

 

Share this post


Link to post
каждый раз..каждый раз одна и та же хрень..вам не надоело.. ну не работают они не работают!!!

ставьте хром там все работает или не обновляйте лису

Лису можно обновлять ;)

У меня стоит актуальная 17ESR и все плагины работают

Share this post


Link to post
...

А в дополнении сделанном, например, для Chrome, такой проверки нет, там всего одна DLL и она пашет со всеми версиями без разбору.

Так что проблема совсем не в FF, проблема у разработчика антивирусного ПО.

...

:laugh3:

Edited by Maratka

Share this post


Link to post

Если я правильно помню, то согласно политике Мозилла, во вторник-среду вместе с обновлением Виндовс выйдет очередная стабильная версия Лисы (20.0) и "всё вернётся на круги своя..."

Или я попутал и обновится Адобе?

Хотя задолбали и те и другие :angry2:

Share this post


Link to post
Тут не знают как писать дополнения для FF.

 

Дополнение, использующее бинарные компоненты:

1) должно быть выложено на AMO;

2) при выходе каждой новой версии браузера должно разработчиком проверяться на совместимость с этой версией;

3) если совместимо, то разработчик должен вручную изменить информацию о совместимости в install.rdf и залить новую версию дополнения на AMO, где она будет проверена автоматическим сервисом.

 

В папке с каждым дополнением есть такая папочка (там их три, одну пишу для примера): linkfilter@kaspersky.ru\components\ff** где ** это номер поддерживаемой версии FF.

Внутри лежит файлик kavlinkfilter**.dll, это специальная dll, которая проверяет версию FF и если она не совместима, то отказывается работать, притом подмена DLL и правка конфигов ничего не дают, т.е. каспер проверяет, чтобы версии DLL соответствовали версии FF.

 

Следовательно это именно он не позволяет работать дополнениям на более старших версиях FF.

 

А в дополнении сделанном, например, для Chrome, такой проверки нет, там всего одна DLL и она пашет со всеми версиями без разбору.

 

+ Касперский - единственный антивирус, не умеющий самообновляться до актуальной версии автоматически. :angry:

 

Так что проблема совсем не в FF, проблема у разработчика антивирусного ПО.

Я вот кстати плачу за это ПО деньги, и хочу получать качественный продукт!

И не надо отсылать пользователя на устаревшие версии FF.

Mozilla FF тут не при чем! Не надо на них грешить.

 

Это мозг у Вас устаревший,извинияюсь за выражение. С чего Вы взяли, что это устаревшая версия ? )

Share this post


Link to post

Заявленные функции Антивируса:

* Веб-фильтр блокирует опасные веб-сайты.

* Анти-Фишинг обеспечивает защиту ваших личных данных.

Реализованы посредством дополнений к браузерам?

 

Функции KIS:

* Веб-фильтр блокирует опасные веб-сайты.

* Анти-Спам и Анти-Баннер блокируют нежелательный контент.

* Виртуальная клавиатура и Анти-Фишинг обеспечивают защиту ваших личных данных. Улучшено!

Реализованы также?

Share this post


Link to post
Заявленные функции Антивируса:

* Веб-фильтр блокирует опасные веб-сайты.

* Анти-Фишинг обеспечивает защиту ваших личных данных.

Реализованы посредством дополнений к браузерам?

нет, указанные функции реализованы путем перехвата трафика до попадания оного в любой браузер

 

Функции KIS:

* Веб-фильтр блокирует опасные веб-сайты.

* Анти-Спам и Анти-Баннер блокируют нежелательный контент.

* Виртуальная клавиатура и Анти-Фишинг обеспечивают защиту ваших личных данных. Улучшено!

Реализованы также?

Аналогично

 

Дополнения позволяют просто удобнее управлять, прямо из браузера

Share this post


Link to post

Решил проблему совместимости плагинов следующим образом. Установил Firefox ESR., и нет проблем. :rolleyes:

Share this post


Link to post
Решил проблему совместимости плагинов следующим образом. Установил Firefox ESR., и нет проблем. :rolleyes:

 

Так я об этом и твержу им.)

Share this post


Link to post
Решил проблему совместимости плагинов следующим образом. Установил Firefox ESR., и нет проблем. :rolleyes:

 

Firefox Extended Support Release - расширенная поддержка? зачем она нужна и без неё можно справиться, если

плагины работают от KIS в предыдущей версии.Будет совместимость с новой версией тогда поставим,а пока прихо -

диться пыркаться через настройки KIS, что не очень удобно и при незнании может повлиять на безопасность PC.

Share this post


Link to post
А чем ESR мешает? ;)

А в нем нет двух фенечек, добавленных в версии 18, и одной рюшечки, из 19-й. ;)

Share this post


Link to post

И без чего я так не страдаю

Share this post


Link to post
Так я об этом и твержу им.)

просто до них туго доходит. не обращайте внимания))

Share this post


Link to post
просто до них туго доходит. не обращайте внимания))

это ,конечно, выход из ситуации. Но это костыль. А давайте заставим всех бабушек пользующихся связкой кис+FF перейти на эту версию. Ну или сразу на Хром. Это уже манипуляция на рынке браузеров со стороны лк получается ахаха

Edited by Kolyan01

Share this post


Link to post
это ,конечно, выход из ситуации. Но это костыль. А давайте заставим всех бабушек пользующихся связкой кис+FF перейти на эту версию. Ну или сразу на Хром. Это уже манипуляция на рынке браузеров со стороны лк получается ахаха

Не-а.

Это манипуляция на рынке браузеров со стороны Мозиллы.

Плановый выпуск бета-версий под видом релиза, на которых релиз (т.е. тот самый ESR), выходящий раз в год и обкатывается. Дабы не было бы в нем найдено два десятка уязвимостей на третий день после выпуска.

Share this post


Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.