Jump to content
jiska78

Java is completely blocked by KES 10 and renders it useless.

Recommended Posts

jiska78

 

Thank you so much for the feedback provided.

 

Could you please try the following:

 

got to main window settings > Anti-virus protection > Monitored ports > Settings.

post-244951-1362056747_thumb.png

 

Disable http ports monitoring 80-83, 1080, 3128, 7900, 8000, 8080, 8088, 8888, 11523 and https 443.

 

Please inform about the result.

Share this post


Link to post

I briefly tested JAVA in my lab with KES 10 on a Windows 7 VM, with JAVA 7 Update 15 using IE and I was able to load the DO I HAVE JAVA applet and the TIME.GOV java applet without problems.

 

(But I'll admit that I don't have the latest AV definitions/updates, since I never gave my lab copy of my KSC server any GATEWAY IP address....for fear of causing problems with my production Key/License.) A bit off-topic, but does any know if it's safe to allow a duplicated (lab) VM to connect to the internet? Must I install a trial license instead? I just want to make sure things work, and the less things that are 'different' from production, the better the test results.

Share this post


Link to post
jiska78

 

Thank you so much for the feedback provided.

 

Could you please try the following:

 

got to main window settings > Anti-virus protection > Monitored ports > Settings.

post-244951-1362056747_thumb.png

 

Disable http ports monitoring 80-83, 1080, 3128, 7900, 8000, 8080, 8088, 8888, 11523 and https 443.

 

Please inform about the result.

 

Hi Mikhail,

 

i had the same problem with KES10 and Windows 8 (Couldn't run the test-applet).

After disabling the ports you mentioned it worked.

Share this post


Link to post
jiska78

 

Thank you so much for the feedback provided.

 

Could you please try the following:

 

got to main window settings > Anti-virus protection > Monitored ports > Settings.

post-244951-1362056747_thumb.png

 

Disable http ports monitoring 80-83, 1080, 3128, 7900, 8000, 8080, 8088, 8888, 11523 and https 443.

 

Please inform about the result.

is this considered a bug that will be fixed by Kaspersky? Although functional, I'd hardly call this an acceptable workaround.

 

Share this post


Link to post
jiska78

 

Thank you so much for the feedback provided.

 

Could you please try the following:

 

got to main window settings > Anti-virus protection > Monitored ports > Settings.

post-244951-1362056747_thumb.png

 

Disable http ports monitoring 80-83, 1080, 3128, 7900, 8000, 8080, 8088, 8888, 11523 and https 443.

 

Please inform about the result.

 

 

Thank you, it helped me.

Our licence expires soon and because of many-many (!) issues and problems with KAV products in the last year we will not pay for that anymore.

Share this post


Link to post
Thank you, it helped me.

Our licence expires soon and because of many-many (!) issues and problems with KAV products in the last year we will not pay for that anymore.

 

 

Hey!

After disabling the mentioned ports It was working for a few days, but now it still blocks Java running, however the "unwanted" (?) ports are unchecked. What the hell is going on ?

Share this post


Link to post
Hello!

 

The bug was submitted № 214714.

We are awaiting for fix soon.

 

If you have already submitted request for TS (https://companyaccount.kaspersky.com/arsys/shared/login.jsp?/arsys/) then tell us its №.

 

If you haven't then please submit incident in remedy with detailed description.

 

Thank You!

 

We have incident 1521877 open with Kaspersky. They provided a document that detailed the minimum policy exclusions to get Java working, but their instructions did not fix it: Java is still not working. I requested that a private fix be released to mitigate the issue until CF1 comes out, especially given that they've got a working beta patch for a different version of their product. Two months (starting from now) is a long time for a corporation to deal with this until the release, as many network switches and equipment use Java applets, and requires us to turn off Kaspersky to use them. Compounding the issue is another problem that prevents the user from disabling Kaspersky on Windows 8: if too much time has passed since booting up, attempting to disable Kaspersky results in a quick flash of Windows 8 warning that states that the application will be turned off, and does the user agree to this. The warning disappears before the user can interact, and KES10 interface becomes unresponsive; disabling AV can only be done from Security Center until reboot occurs. So not only do we have to disable Kaspersky to use Java, many times we can't even do that without opening KSC first!

Share this post


Link to post
We have incident 1521877 open with Kaspersky. They provided a document that detailed the minimum policy exclusions to get Java working, but their instructions did not fix it: Java is still not working. I requested that a private fix be released to mitigate the issue until CF1 comes out, especially given that they've got a working beta patch for a different version of their product. Two months (starting from now) is a long time for a corporation to deal with this until the release, as many network switches and equipment use Java applets, and requires us to turn off Kaspersky to use them. Compounding the issue is another problem that prevents the user from disabling Kaspersky on Windows 8: if too much time has passed since booting up, attempting to disable Kaspersky results in a quick flash of Windows 8 warning that states that the application will be turned off, and does the user agree to this. The warning disappears before the user can interact, and KES10 interface becomes unresponsive; disabling AV can only be done from Security Center until reboot occurs. So not only do we have to disable Kaspersky to use Java, many times we can't even do that without opening KSC first!

 

 

nice.

it seems the best way if you want your problem to be solved to get another AV software.

Share this post


Link to post
Compounding the issue is another problem that prevents the user from disabling Kaspersky on Windows 8: if too much time has passed since booting up, attempting to disable Kaspersky results in a quick flash of Windows 8 warning that states that the application will be turned off, and does the user agree to this. The warning disappears before the user can interact, and KES10 interface becomes unresponsive; disabling AV can only be done from Security Center until reboot occurs. So not only do we have to disable Kaspersky to use Java, many times we can't even do that without opening KSC first!

 

Hello.

 

It is not normal behavior with disabling KES.

For further investigation please create a new ticket in kaspersky support, send them KES traces http://support.kaspersky.com/9343 collected during the issue reproduction, GSI, event logs, screenshots of the issue.

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.