Jump to content
pkolasa

KSC 10 doesn't want to update repositories itself

Recommended Posts

Hello,

 

I've just upgraded to Kaspersky Security Center 10 from KSC 9. In version 9, I had a task, performed automatically every hour, that checked with Kaspersky Lab servers for update availability and after a successful update downloading on the server machine, it triggered the task of automatic update on client computers, which then downloaded databases from server machine. It worked just great.

Now, that task just doesn't work, despite the server being powered on all the time and having Internet access. In the Event log of the task, I can see, that it starts only when I manually click Start button, not on its own, every hour, like it's supposed to. I deleted it, created a new one - but to no avail, still doesn't run itself.

Another thing - have you removed the functionality to start a client update task after updating server's repository? When I first opened the client task, and opened the Schedule tab, KSC displayed an error message, telling me, that the schedule is unknown.

 

What can I do to restore the previous functionality of KSC? I can't sit in front of computer and click Start all the time...

Share this post


Link to post
Hello,

 

I've just upgraded to Kaspersky Security Center 10 from KSC 9. In version 9, I had a task, performed automatically every hour, that checked with Kaspersky Lab servers for update availability and after a successful update downloading on the server machine, it triggered the task of automatic update on client computers, which then downloaded databases from server machine. It worked just great.

Now, that task just doesn't work, despite the server being powered on all the time and having Internet access. In the Event log of the task, I can see, that it starts only when I manually click Start button, not on its own, every hour, like it's supposed to. I deleted it, created a new one - but to no avail, still doesn't run itself.

Another thing - have you removed the functionality to start a client update task after updating server's repository? When I first opened the client task, and opened the Schedule tab, KSC displayed an error message, telling me, that the schedule is unknown.

 

What can I do to restore the previous functionality of KSC? I can't sit in front of computer and click Start all the time...

Hello. Please attach Kaspersky event log.

Share this post


Link to post
Here it is (if you meant the log from Windows Event Viewer): https://www.dropbox.com/s/q82ijvdn5l9lobe/Kaspersky.evtx

Have the logs been any helpful, do you need anything to be posted more about that issue?

Or would it be better to contact Kaspersky Helpdesk in order to have it repaired?

Sorry for this form of 'bumping', but it really is a unnerving issue, as I have to connect to server every day to manually click Start in order for databases to update...

Edited by pkolasa

Share this post


Link to post
Have the logs been any helpful, do you need anything to be posted more about that issue?

Or would it be better to contact Kaspersky Helpdesk in order to have it repaired?

Sorry for this form of 'bumping', but it really is a unnerving issue, as I have to connect to server every day to manually click Start in order for databases to update...

 

 

Hi colleague!

Kaspersky Helpdesk will help you with this issue ASAP

 

 

 

 

Share this post


Link to post
Hello,

 

I've just upgraded to Kaspersky Security Center 10 from KSC 9. In version 9, I had a task, performed automatically every hour, that checked with Kaspersky Lab servers for update availability and after a successful update downloading on the server machine, it triggered the task of automatic update on client computers, which then downloaded databases from server machine. It worked just great.

Now, that task just doesn't work, despite the server being powered on all the time and having Internet access. In the Event log of the task, I can see, that it starts only when I manually click Start button, not on its own, every hour, like it's supposed to. I deleted it, created a new one - but to no avail, still doesn't run itself.

Another thing - have you removed the functionality to start a client update task after updating server's repository? When I first opened the client task, and opened the Schedule tab, KSC displayed an error message, telling me, that the schedule is unknown.

 

What can I do to restore the previous functionality of KSC? I can't sit in front of computer and click Start all the time...

 

 

We have run into this issue as well. I'm having to go in and start the admin task manually. I've even had a few times where it gets to a point of the update and stops. I then have to start/stop the task to get it going.

Share this post


Link to post

pkolasa

 

Please get server traces and updater traces as described in the KB article.

 

1. go to the update task settings.

2. schedule its start to 17.00 for instance.

3. at 16.58 turn on server traces and updater traces. (two minutes before the task starts)

4. wait until the task starts.

5. wait for 15 minutes then.

 

6. get traces

7. post traces

8. post the exact time you turn on traces, start the update task, turn off traces etc.

Upon request through private message we can provide you with access to our ftp.

 

thank you for cooperation.

Share this post


Link to post
pkolasa

 

Please get server traces and updater traces as described in the KB article.

 

1. go to the update task settings.

2. schedule its start to 17.00 for instance.

3. at 16.58 turn on server traces and updater traces. (two minutes before the task starts)

4. wait until the task starts.

5. wait for 15 minutes then.

 

6. get traces

7. post traces

8. post the exact time you turn on traces, start the update task, turn off traces etc.

Upon request through private message we can provide you with access to our ftp.

 

thank you for cooperation.

I have collected the logs, zipped them, and sent to you via PM.

Time of scheduling the task: 20:54:17

Time of starting logging: 20:58:01 - 03.

Time of starting the task: 21:00:01

Time of competing the task: 21:03:33

Time of stopping logging: 22:13

I have been waiting for so long to stop the logging, because I wanted the logs to show the moment, when the next start of task should occur and (as I thought) when the server still didn't run the task as scheduled. Task should be started again at 22:00, which didn't happen.

I couldn't find files $up2date-KLSCU.log and $klnacserver-1093.log - but there were other files, like $klactprx-1093.log, $klakupd.log, $klfc-1093.log and $klFILECAT-eka-1093.log. Everyone have been attached to the PM sent to you.

If you were interested - I have also submitted a ticket to KL helpdesk this morning, concerning that topic.

Share this post


Link to post

thank you , well done!

 

Still the server traces and update task traces are very important to investigate the issue.

We would kindy ask you to repeat one more time steps mentioned above.

 

Refer to article http://support.kaspersky.com/9323.

 

Before reproducing the issue please turn on one after another

 

Administration server traces trace_server-4.zip

Nagent (installed on the Administration server) traces trace_nagent-4.zip

Administration server update task traces updatelog.zip

Task history how to get the task history

 

wait until the task starts.

wait for 15 minutes then.

get traces

post traces

 

Thank you for cooperation!

 

Share this post


Link to post
thank you , well done!

 

Still the server traces and update task traces are very important to investigate the issue.

We would kindy ask you to repeat one more time steps mentioned above.

 

Refer to article http://support.kaspersky.com/9323.

 

Before reproducing the issue please turn on one after another

 

Administration server traces trace_server-4.zip

Nagent (installed on the Administration server) traces trace_nagent-4.zip

Administration server update task traces updatelog.zip

Task history how to get the task history

 

wait until the task starts.

wait for 15 minutes then.

get traces

post traces

 

Thank you for cooperation!

OK, done and sent to you via PM.

I attach the task history to that post, because I have forgotten to include it in the PM.

As before, the timing was:

Turning tracing on: 09:48:01 - 20

The time of scheduled task start: 09:50:00

Task started: 09:50:01

Task finished: 09:55:02

Turning tracing off: 10:11:30 - 10:12:00

 

I have noticed, that there also frequently occurs an error (and it did occur also when I was using KSC 9), named in the task history: Error verifying file signature 'http://dnl-14.geo.kaspersky.com/bases/wmuf/wmuf0000.dat' - usually that causes a major error on workstations with KES 8, that shows after updating, that databases are corrupted, so I have to go there, change settings from updating from our server to updating from your servers and then execute an update, which corrects the corruption - how to avoid such corruption issues in the future?

History.txt

Share this post


Link to post

According to data we have got the update task has completed successfully.

 

Here is the log (pay attention to the time line):

 

26 lutego 2013 21:03:33 Completed Operation completed successfully 26 lutego 2013 21:03:35

26 lutego 2013 21:00:01 Running Updates source selected 'http://dnl-06.geo.kaspersky.com/' 26 lutego 2013 21:00:04

26 lutego 2013 21:00:01 Running Task started 26 lutego 2013 21:00:04

 

you wrote

 

Now, that task just doesn't work,

 

Actually it does work.

 

Could you please explain the issue. Thank you.

Share this post


Link to post
Could you please explain the issue. Thank you.

It does work, indeed, but as I initially wrote - only when I start it, clicking Start button, or, after scheduling, but only for the first time. To be more precise - look at the example:

I schedule the task for starting every 1 hour, beginning, for example, at 21:00. Server, indeed, starts it, but only once, at 21:00. After an hour, at 22:00, the task should be started again, but it is not being started, nor it is at 23:00 and so on.

This is the problem, because it should start automatically, and it doesn't.

Share this post


Link to post
It does work, indeed, but as I initially wrote - only when I start it, clicking Start button, or, after scheduling, but only for the first time. To be more precise - look at the example:

I schedule the task for starting every 1 hour, beginning, for example, at 21:00. Server, indeed, starts it, but only once, at 21:00. After an hour, at 22:00, the task should be started again, but it is not being started, nor it is at 23:00 and so on.

This is the problem, because it should start automatically, and it doesn't.

Hello. Please export task(Download updates to the repository) and attach *klt file on forum.

Share this post


Link to post

We need traces at the moment the task is supposed to start but fails ( the second time after being scheduled)

 

So please perform the following steps in this order

 

1.Turn on the following traces

 

Administration server traces trace_server-4.zip

Nagent (installed on the Administration server) traces trace_nagent-4.zip

Administration server update task traces updatelog.zip

Task history

 

2. Set the schedule for the task.

3. Wait until the moment (second scheduled start) when the task is supposed to start but fails. Make sure it fails.

4. Turn off traces.

5. Post / attach trace files.

 

Thank you!!

Share this post


Link to post
We need traces at the moment the task is supposed to start but fails ( the second time after being scheduled)

 

So please perform the following steps in this order

 

1.Turn on the following traces

 

Administration server traces trace_server-4.zip

Nagent (installed on the Administration server) traces trace_nagent-4.zip

Administration server update task traces updatelog.zip

Task history

 

2. Set the schedule for the task.

3. Wait until the moment (second scheduled start) when the task is supposed to start but fails. Make sure it fails.

4. Turn off traces.

5. Post / attach trace files.

 

Thank you!!

 

this is happening in my organization as well. nor do the other admin server scheduled tasks start on their own - not the report delivery, not the backup of admin server data. they go through successfully when i run them manually, but that is quite burdensome to do every day, or multiple times a day.

Share this post


Link to post
We need traces at the moment the task is supposed to start but fails ( the second time after being scheduled)

I have sent the traces to you via a PM.

I have decided to let the tracing run for a little bit longer, so you could be sure, that I'm correct, telling you that the task doesn't start as planned after the first occurence.

As before, the timing:

Turn on tracing: 15:30 - 15:31

Task scheduled time: 15:45, and every 1 hour after that time

First start time: 15:45:01

First finish time: 15:51:56

Second planned start time: 16:45 (did not occur, just nothing happened)

Third planned start time: 17:45 (just like before)

Fourth planned start time: 18:45 (just like before)

Turn off tracing: 19:12

I let it collect traces in time needed for four possible occurences, from which only the first one (like before), occured, but the second, third and fourth did not. I know, the logs might be a bit huge after such a long period of time, but I thought that the more data you receive, the easier you can find the answer.

 

Hello. Please export task(Download updates to the repository) and attach *klt file on forum.

I'm very sorry, but the option of exporting the task (All tasks --> Export) is greyed out. I checked on how to do that in the manual, but it says, that: "Administration Server tasks and local tasks are not available for export" (page 69 of Administrator guide). So, if you know where to look for the file of that task - let me know, and I'll look for it.

Share this post


Link to post

Hello

Have the traces been any helpful? Is there any hope for me to repair with your help that task? :unsure:

Share this post


Link to post

Thank you very much for information provided.

 

The traces are being investigated.

 

we'll let you know asap.

 

 

 

Share this post


Link to post
Thank you very much for information provided.

 

The traces are being investigated.

 

we'll let you know asap.

OK, I'll be waiting for your response.

Sorry for, so-called, bumping it up, but I just wanted to know if are there any new informations.

Share this post


Link to post

Hi I have a similar problems. the update task if it is sheduled to go every 1h it wont run at all unless i start i manual.

if i change the update time to every 5min , 15min or 30min the update time will be dubbled. if i put in 5min it will update every 10m min if i set it to 15min it vill uppdate every 30 minutes and if I set it to 30min it will update every 1h.

 

i havent sent this case to kaspersky support yet.

 

 

Share this post


Link to post

Hi I have a similar problems. the update task if it is sheduled to go every 1h it wont run at all unless i start i manual.

if i change the update time to every 5min , 15min or 30min the update time will be dubbled. if i put in 5min it will update every 10m min if i set it to 15min it vill uppdate every 30 minutes and if I set it to 30min it will update every 1h.

 

i havent sent this case to kaspersky support yet.

 

 

Share this post


Link to post

The option Run missed tasks is already unchecked and it has not been checked since creating the task.

Some time earlier, I tried to create a new task, with Run missed tasks checked, but my problem still occured.

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.