Jump to content
invip

Проблема с KES 8 после установки патча b

Recommended Posts

у меня проблемы наблюдались только на тестовых ПК c XPsp3

сначала я подумал что виноваты политики безопасности запрещающие установку не подписанных драйверов и ПО...

из нескольких ПК проблема подтвердилась на только на 2-ух... запрос в CA не стал делать так как думал что проблемы внутренние (из-за жестких политик для OC) http://forum.kaspersky.com/index.php?s=&am...t&p=1980394

 

в политиках для KES увидел что patchmanager.exe и файлы логов установки патча в контроле активности программ поместились в группу слабые ограничения...

ослабил политики, перенес patchmanager.exe и лог файлы в группу доверенных и ПК стали вести себя нормально, но на "боевые" ПК обновление модулей пускать не стал. Странно что модули не стали подписывать подписью от ЛК - подписанные бы помещались в группу доверенных автоматом.

 

при этом на тестовых ПК Win7 заметил только проблему отключения антивируса при logoff, на ХР наблюдалось падение производительности ПК и отсутствие значка в трее. Вообщем то по этим причинам патч не стал распространять во внутренней сети.

 

Думаю что тестирование как минимум автопатчей обязательно на группе тестовых перед распространением на все ПК (по аналогии с WSUS), возьмите для себя это как обязательное условие.. от человеческого фактора не застрахована ни одна антивирусная компания... такие проколы были есть и будут всегда...

 

 

Так что пока kavremover признана мною лучшей программой за февраль 2013 :)

в безопасном режиме достаточно просто отключить атозапуск KES и потом в режиме нормальной загрузки можете уже задачей удаления удалить c KSC антивирус на проблемных ПК.

 

 

для всех у кого проблемы проверьте все ли файлы патча b имеют версию 8.1.0.898???

http://support.kaspersky.ru/9684

так как патчинг происходит в момент перезагруки возможно не все модули корректно обнвляются в этот момент.. или нетерпеливые пользователи уходящие домой просто не дожидаясь корректного выключения просто тыканьем кнопки выключали ПК.

Edited by mvs

Share this post


Link to post
Да с какой стати пользователи должны решать Проблемы разработчиков? Вы идете в магазин и покупаете колбасу, чтобы ее можно было есть, а не для того чтобы перед использованием вытащить и описать размер, вес и химический состав гвоздей и кирпичей в нее попавших.

Вы считаете что на данный момент проблемы у разработчиков? или у вас? Обсуждать ваш бред не стану

Share this post


Link to post

MVS может ли это быть связано с тем что у вас быть может включен "эвристический анализ группы"

Share this post


Link to post
MVS может ли это быть связано с тем что у вас быть может включен "эвристический анализ группы"

да его использую (KSN при этом отключен)... а у вас в какой группе patchmanager.exe? помещаете автоматом в слабые через политики?

 

да и еще мне показалось что патч выходил два раза (второй раз нас не предупреждали), так как на тестовых ПК с проблемами через день после выпуска патч встал без проблем, хотя 6-го сразу после выхода "b" были симптомы как у большинства выше. Хотя может это всего лиш мои домыслы. :), так как в хранилище баз на сервере дата модулей в день выпуска.

Edited by mvs

Share this post


Link to post

Вижу в сети на 400 машин одну с похожими симптомами.

 

В kaspersky event log ругань такая:

Connector for the product KES 8.1.0.0 failed to respond for 600 seconds and considered to be hung. Restarting.

После серии таких сообщений

Product integration failure (freeze) occured! Product: 'Kaspersky Endpoint Security 8 для Windows'. Restaring.

Making dump for killed-klnagent.exe

Аналогичная серия событий была днем, когда я еще не знал о массовости проблемы - и просто рестартнул службу агента

 

В KSC машина имеет статус Не включена защита, и на вкладке Программы с свойствах компьютера - только агент, KES не значится

Машина Windows 7 SP1 x86

 

Дампы падения агента сейчас выложу

Edited by katbert

Share this post


Link to post

Проверил версии файлов на двух зависающих ПК. Все файлы новых версий.

Share this post


Link to post
да его использую (KSN при этом отключен)... а у вас в какой группе patchmanager.exe? помещаете автоматом в слабые через политики?

У меня эвристик отключен в контроле программ. Файл patchmanager.exe ни в одной группе не обнаружен.

 

PS: сделал логофф - логон, - все ОК, полностью запущен касперский

Edited by DWState

Share this post


Link to post
Вы считаете что на данный момент проблемы у разработчиков? или у вас? Обсуждать ваш бред не стану

хмм. А я почему-то всегда думал, что тестированием платного продукта должен заниматься разработчик, а не пользователь. Тем более у нас крупное предприятие на 1000+ компьютеров, и мы потратили немаленькие деньги на продукты ЛК. Я понимаю, если бы это был какой-то бесплатный софт от любителя...

Лично я свое мнение выразил, скорее всего будем переходить на другой продукт.

Share this post


Link to post
У кого проблема с зависанием устанавливали ли вы новый плагин к Kaspersky Security Center версии 8.1.0.898 ?http://support.kaspersky.ru/downloads/utils/klcfginst.zip

Я вчера установил.

Сегодня на 2-х рабочих компах проблемы.

 

P.S. Как раз на этих 2-х и тестировал, хотел далее массово ставить новую версию. )) и хорошо что глюк вылез, теперь точно никто не даст внедрять эту версию)))

 

Остаюсь на 6.0.4.1424/1611.

ОС Windows XP SP3 + все патчи.

 

Share this post


Link to post
Я вчера установил.

Сегодня на 2-х рабочих компах проблемы.

 

P.S. Как раз на этих 2-х и тестировал, хотел далее массово ставить новую версию. )) и хорошо что глюк вылез, теперь точно никто не даст внедрять эту версию)))

 

Остаюсь на 6.0.4.1424/1611.

ОС Windows XP SP3 + все патчи.

Вы тут наверное путаете, вы ставили просто KES8 , а я говорю про плагин для KSC, но дело не в нем уже как выяснилось

Share this post


Link to post
Вы тут наверное путаете, вы ставили просто KES8 , а я говорю про плагин для KSC, но дело не в нем уже как выяснилось

Нет, я всё верно сказал.

Я поставил плагин для KSC вчера вечером. Но дело в нём не может быть, так как никакие политики я после этого не менял.

 

Share this post


Link to post

У кого нибудь получилось решить вопрос с остановкой службы антивируса после логаута пользователя?

Share this post


Link to post
в политиках для KES увидел что patchmanager.exe и файлы логов установки патча в контроле активности программ поместились в группу слабые ограничения...

ослабил политики, перенес patchmanager.exe и лог файлы в группу доверенных и ПК стали вести себя нормально

 

У нас контроль запуска и активности программ отключены политикой, но проблема присутствует.

Share this post


Link to post
Вчера в 18:25. Пришел стандартный ответ - прислать логи.

ОС всякие: XP Prof SP3, Win7 Prof

Добавлю windows 2008 standard 64 bit

Удивительно что пока не пишут о серверах.

Хотелось бы получить решение для исправления ситуации когда автопатч установился, но не было перезагрузки (антивирус требует перезагрузку).

Откат баз не предлагать - уже прошло следующее обновление.

Share this post


Link to post

А если подцепить логон-скрипт с одной единственной командой net start avp. Может сработает?

Share this post


Link to post

Вчера залетет с обновлением "С", никто не пробовал?

 

patch_c_x64.msp 857 182 08.02.2013 21:32 -a--

patch_c_x86.msp 857 182 08.02.2013 21:32 -a--

Share this post


Link to post

У меня два вопроса:

1. Что будет с рабочими станциями где патч b еще не встал? сначала установится патч b, все сломается, потом накатится патч c и все починится?

2. Есть рабочие станции, где значка антивируса не видно в трее, хотя оба процесса avp работают (при этом системный процесс avp потребляет подозрительно мало ресурсов). Как понимать такое поведение программы? Установится ли на нее автопатч?

Share this post


Link to post

У меня автопатч "b" тоже как-то коряво начал автораспростараняться. Сделал следующее:

 

Из статьи http://support.kaspersky.ru/9684

необходимо установить новый плагин к Kaspersky Security Center версии 8.1.0.898 (русская, английская версия плагина). В случае, если установлен старый плагин, то необходимо предварительно удалить старый плагин перед установкой нового плагина.

 

Далее по мотивам этой статьи http://support.kaspersky.ru/8975 сделал:

- нашел patchmanager.exe (370792байта) на сервере администрирования

- создал инсталляционный пакет с параметром "/when now"

- создал задачу установки пакета

- запустил задачу на все KES8

 

После перезагрузки на всех машинах светится версия "8.1.0.831 (a.b.c)".

Edited by Segr

Share this post


Link to post

http://pic2net.ru/view/v/201302115f720b8d2...654dfd07843.jpg

 

На одном из комп-ов стоял только a-патч, запустил обновление и после ребута пишет, что стоит a,b,c-патчи(скрин сверху) - т.е. все поправили и можно обновляться с а на с сразу и как быть если криво встал b патч, только переустановка KES или можно накатить с-патч поверх?

Share this post


Link to post
...как быть если криво встал b патч, только переустановка KES или можно накатить с-патч поверх?

 

Если удастся запустить задачу обновления баз (или установить патч вручную), то встанет и поверх.

Share this post


Link to post

Вспомнил, что похожая проблема возникла у меня недели 3 назад, т.е. еще до выхода автопатча b. Готовил эталонную машину для разворачивания в сети: на KSC закинул компьютер в группу, применил задачу с лицензией и обновлением баз, удалил компьютер из группы, чтобы корректно разворачивались образы из разных подсетей, неоднократно перезагружался, но после установки порядка 30 обновлений для WinXP и перезагрузки компьютера так же, как и описано многими выше в этой теме, не появлялся значок антивируса и через пару минут блокировался запуск всех программ.

Тогда я списал это все на временный глюк или конфликт программ, но теперь все грешат на автопатч b. Не было времени экспериментировать и отключать службу Агента я не догадался, а похоже какая-то связь здесь есть: может в связке АВ-Агент, может - Агент-Сервер, может - в политиках дело, но что тогда, что сейчас они не менялись...

Share this post


Link to post

Выработал для себя такое решение:

 

1) В момент загрузки компа, пока не стартовал антивирус(до 2 минут) нужно остановить службу агента - после этого касперский стартует

2) Устанавливается патч-с, запускается агент, ребут

 

Все ок :)

Share this post


Link to post

Нет, ребята. Не все ОК. Завтра опять получите тормоза. Комп XP SP3. Служба агента администрирования включена. В субботу накатан патч С. То есть сейчас версия 8.1.0.831 (a.b.c). После установки по требованию касперского произведена перезагрузка компа. Запустилось все нормально. Пробовал для эксперимента еще раз комп перезагружать. Все нормально. Сегодня утром при загрузке компа получаю тормоза и висюн, которые было при установке патча B. Перезагружаю комп, и пока касперский еще не успел стартовать, отключаю службу агента администрирования. Комп запускается нормально. Кстати, если после появления значка касперского в панели задач службу агента включить, то все продолжает нормально работать, и копм становится виден на сервере администрирования. Но до очередной перезагрузки.

Share this post


Link to post

1) Может надо на сервер администрирования обновление установить(плагин) или что писали?

2) Надо чтобы служба агента запускалась после самого антивируса...

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.