Jump to content
Poldy

KAV 2013 MS SQL 2008 R2

Recommended Posts

Hallo,

 

KAV 2013 blockiert MS SQL 2008 R2.

 

System ist ein Win7 64 Rechner, auf dem ein Desktop SQL 2008 R2 64 läuft.

Sobald KAV installiert ist, gibt es keine möglichkeit diese Db im LAN zu erreichen.

Regeln und Ports sind freigegeben.

 

Auch nur das zeitweise Abschalten von KAV brachte keinen Erfolg.

 

Nach der Deinstallierung ging alles ohne Probleme.

 

Zum Test habe ich KAV nochmal installiert und siehe da, nichts geht mehr.

Desweiteren hab ich auf einem Vista 64 das selbe getestet, Ergebnis das selbe.

 

 

Gruß Poldy

Share this post


Link to post

N'Abendt Poldy,

 

auf 'System' liegt die DB? Und Du verwendest KAV2013 auf 'System'?

 

KAV enthält keine Firewall, so dass Du die von Dir genannten Regeln und Portfreigabe (# 1433 ?) wohl mit der Windows-Firewall oder einer anderen FW vorgenommen haben wirst. Sollte es nicht die Windows-FW sein, welche FW (ggf. auch die Versionsnummer nennen) verwendest Du?

 

Können sich 'System' und die zugreifenden Rechner jeweils in 'Netzwerk' bzw. im Windows-Explorer gegenseitig 'sehen', wenn KAV auf dem Rechner ist? Wechselseitiges Ping geht auch?

 

Bye.

KM

 

 

Share this post


Link to post

Hallo,

 

haben exakt das gleiche Problem und derzeitig leider keine Lösung dazu.

Gibt es denn tatsächlich niemanden, der hierzu eine Lösung parat hat? Selbst der Kaspersky-Support rührt sich leider zu dem Thema überhaupt nicht. Auf Anfragen leider keinerlei Reaktion.

 

Schönen Gruß

 

Share this post


Link to post
Selbst der Kaspersky-Support rührt sich leider zu dem Thema überhaupt nicht. Auf Anfragen leider keinerlei Reaktion.

 

Dann schicke @Bluna eine PN:

Wir möchten euch jederzeit mit Rat und Tat zur Seite stehen. Daher könnt Ihr mir gerne alle offenen Serviceanfragen mit Verweis auf die INC Nummer oder eurer E-Mail-Adresse per PN zusenden.

Ich leite die Infos dann direkt an den Support weiter, damit ihr schnellstmöglich eine Antwort erhaltet.

Quelle: http://forum.kaspersky.com/index.php?showtopic=245830

 

 

 

Share this post


Link to post

N'Abendt lolecundbolec,

 

das 'exakt gleiche Problem' wie in Beitrag #1? In Ergänzung Deines Beitrages zu diesem Thema an anderer Stelle --> http://forum.kaspersky.com/index.php?s=&am...t&p=1921131 trotzdem noch die Frage, ob das System mit der SQL-DB und die Clients sich gegenseitig sehen können (ist ein wechselseitiger Ping erfolgreich?) und ob die Clients auf irgendwelche Dateien auf dem Rechner zugreifen können oder ob sich das Problem ausschließlich darin beschränkt, dass nicht auf die SQL-DB zugegriffen werden kann?

 

KAV hat ja eigentlich keine Firewall-Komponente, die solche Effekte hervorrufen könnte. Allerdings sind die Installationsmedien von KAV und KIS (Kaspersky Internet Security) identisch. Es ist möglich, in KAV einen KIS-Aktivierungscode einzugeben, es wird ein sog. Migrationsassistent gestartet, das System rödelt ein bisschen rum und anschließend ist KIS aktiv. Das kann man auch vorübergehend als Testlizenz betreiben, muss es aber nach den üblichen 30-Tagen wieder zurückbauen oder einen entsprechenden KIS-Aktivierungsschlüssel eingeben (KAV-Benutzerhandbuch S. 21, 54 - 56).

 

Wurde dieser Wechsel auf dem Rechner mit der SQL-DB mal ausprobiert und war während dieses Versuchs der Zugriff durch die Clients möglich? Denkbar wäre in diesem Fall, dass die FW-Komponente während des Rückbaus nicht vollständig abgeschaltet wurde, aber die vorgenommenen Einstellungen gelöscht wurden.

 

Ebenfalls wäre denkbar, dass diese latent vorhandene FW-Komponente, die ja mit installiert wird aber bei der Verwendung der Installation mit einem KAV-Aktivierungsschlüssel lediglich nicht aktiv gesetzt werden soll, auf der Grundlage eines Fehlers im Installationsprozess mit ihren Grundeinstellungen aktiv ist. Das würde bedeuten, dass die für SQL zu öffnenden Ports geschlossen und sonstige benötigte Ausnahmen nicht gesetzt sind. In einem solchen Fall müsste wohl eine fehlerbereinigte Installationsroutine abgewartet werden.

 

Vielleicht wäre es aber auch möglich, vorübergehend KIS als Testversion aus der vorhandenen Installation zu aktivieren (dazu mal das Handbuch konsultieren), dann dort die Firewall zu deaktivieren und anschließend wieder auf KAV zurück zu bauen.

 

Bevor man diesen Versuch unternimmt, sollte man aber die Logdateien (pre-install, install und update, vollständige Bezeichnung z.B. "kl-install-yyyy-mm-dd-hh-mm-ss.log"), die während der ursprünglichen KAV-Installation in das Verzeichnis 'C:\Users\<benutzername>\AppData\Local\Temp\' geschrieben wurden, in ein Archiv packen und an den Support von KL weiterleiten. Den Bezug zu dem bereits aufgegebenen Ticket nicht vergessen.

 

Bye.

KM

 

 

Share this post


Link to post

Hallo KleinerMuck,

 

danke erstmal für die Antwort.

 

Der PC hatte nie etwas mit KIS zu tun gehabt. Ich teste zwischenzeitlich mit neu installierten Win 7prof. 64-Bit Systemen, die alle aktuellen Windows-Updates enthalten und dem SQL-Server Express 2008 R2 als auch 2012. Nach Installation der Testversion von KAV2013 ist von einem weiteren Client der Zugriff blockiert. Nach Deinstallation von KAV2013 geht es wieder. Die beiden Clients können sich gegenseitig anpingen und problemlos auf Freigaben zugreifen.

 

Mit KIS habe ich das ganze noch überhaupt nicht probiert. Könnte ich aber mal machen und schauen, ob irgendwelche Einstellungen in der Firewall ev. verantwortlich sein könnten. Andere Firewalls, auch nicht die von Windows, sind nicht aktiviert.

 

Immerhin gibt es aber auch in KAV2013 die Möglichkeit Ports zu kontrollieren und mein Verdacht geht auch soweit, dass sich in der KAV-Installation irgendeine Firewall-Komponente eingeschlichen hat, die nicht deaktiviert werden kann. Immerhin gibt es mit KAV2012 und Vorgängern überhaupt keine Probleme in der Hinsicht.

 

Inzwischen habe ich das Problem soweit analysiert: Der Client stellt eine Anfrage über UDP an den SQL-Server über den Port 1434 und erhält vom SQL-Dienst (Browser) eine Antwort, unter welcher dynamischen Port-Adresse der Client über TCP SQL-Anfragen an den SQL-Server stellen darf. Die Anfrage kommt beim SQL-Server-PC an, wird jedoch vom Browser nicht mehr beantwortet bzw. die Antwort wird blockiert.

 

Die Blockierung tritt erst nach einem Neustart nach der Installation auf und verschwindet erst nach einem Neustart nach der Deinstallation.

 

Und wie ich es gerade sehe, verhält sich KIS 2013 in der Testversion exakt genauso. Selbst wenn ich alle Schutzkomponenten deaktiviere wird der Zugriff blockiert. Ich habe die EXE des SQL-Servers und des Browser in die Ausnahmen eingetragen und sämtliche Paketregeln zugelassen die es gibt. Es gibt leider kein durchkommen. Es ist zum Mäuse melken.

 

Gruß

olecundbolec

Edited by olecundbolec

Share this post


Link to post
Immerhin gibt es aber auch in KAV2013 die Möglichkeit Ports zu kontrollieren (...)

 

Die Anfrage kommt beim SQL-Server-PC an, wird jedoch vom Browser nicht mehr beantwortet bzw. die Antwort wird blockiert.

N'Abendt lolecundbolec,

 

kannst Du sagen, welches Protokoll bei der Antwort verwendet und welcher Port angesprochen wird? In einer KIS-Installation solltes Du dann die FW-Komponente durch entsprechende Regeln soweit öffnen können, das die SQL-DB vom Client aus angesprochen werden kann.

 

Zur Portkontrolle bei KAV könntest Du noch ein paar Informationen geben - Neugier auf meiner Seite.

 

Bye.

KM

Share this post


Link to post

Hallo KleinerMuck,

 

die Antwort erfolgt normalerweise ebenfalls über UDP. Mit dem Prozessmonitor von den sysinternals kann ich auf dem SQL-Server erkennen, dass die UDP-Pakete ankommen, jedoch bleibt die UDP-Antwort leider aus. Demzufolge kann der Client sich nicht korrekt anmelden. Den Antwortport weiss ich jetzt nicht genau, kann ich aber nachschauen. Aber selbst das freigeben sämtlicher Ports hat weder in KAV noch in KIS eine Änderung gebracht.

 

In KIS kann ich hier in der Tat sehr viel einstellen, aber leider in KAV nicht. In KIS habe ich sämtliche Paketregeln (lokale UDP und was es da alles gibt) freigegeben, es werden keine relevanten Ports von KIS beschnüffelt und wie bei KAV ist selbst das komplette abschalten sämtlicher Schutzfunktionen ohne Erfolg.

 

Die Portregeln in KAV habe ich übrigens in den Einstellungen über die erweiterten Einstellungen (der Pappkarton in der Symbolauswahl oben) unter der Gruppe "Netzwerk" gefunden. Dort kann man einstellen, dass bestimmte Ports oder das alle Ports für bestimmte Programme überwacht werden sollen. Aber selbst hier ist kein SQL-Port zu finden.

 

Schönen Gruß

olecundbolec

Share this post


Link to post

Hallo olecundbolec,

 

wenn ich die Problembeschreibung von Dir und Poldy richtig verstehe, dann funktioniert die Kommunikation mit dem SQL-Server selbst dann nicht korrekt, wenn KAV ausgeschaltet ist. Nach einer Deinstallation von KAV ist die Kommunikation mit dem SQL-Server wieder okay.

In diesem Fall könntest Du testweise einmal den "Kaspersky Anti-Virus NDIS 6 Filter" im verwendeten Netzwerk-Adapter deaktivieren (sicherheitshalber danach PC-Neustart durchführen), dann sollte KAV den Netzwerkverkehr nicht mehr analysieren. Auch eine Deinstallation von nur dem "Kaspersky Anti-Virus NDIS 6 Filter" wäre eine Test-Option. Weitere Informationen dazu findest Du unter http://support.kaspersky.com/de/faq/?qid=207621363

 

Allerdings würde ich das System nicht dauerhaft ohne diesen NDIS-Filter betreiben, sondern nur zur Eingrenzung der Fehlerursache als Hilfe für eine schnellere Lösung durch den Kaspersky-Support.

 

Viel Erfolg,

Kurt

Share this post


Link to post

Hallo Kurt,

 

danke für den Tipp. Tatsächlich hatte ich auch das schon ausprobiert. Leider war auch diese Maßnahme ohne Erfolg.

 

Gruß

olecundbolec

 

Share this post


Link to post

N'Abendt olecundbolec,

 

schon mal dem Hinweis von FH in Beitrag #4 gefolgt und eine PN an Bluna geschrieben? Dann sollte der KL-Support eigentlich in Wallung kommen ...

 

Bye.

KM

Share this post


Link to post

Hallo KleinerMuck,

 

auch diesen Rat habe ich befolgt und der Support hat sich tatsächlich auch gemeldet. Bislang waren die Ratschläge jedoch leider ebenfalls nicht zu gebrauchen. Immerhin scheine ich dort jetzt in den nächsten Level gekommen zu sein, denn ich darf nun mit einem KAV-Diagnose-Tool Dateien erzeugen und an Kaspersky schicken.

 

Schönen Gruß

olecundbolec

 

Share this post


Link to post
Hallo KleinerMuck,

 

auch diesen Rat habe ich befolgt und der Support hat sich tatsächlich auch gemeldet. Bislang waren die Ratschläge jedoch leider ebenfalls nicht zu gebrauchen. Immerhin scheine ich dort jetzt in den nächsten Level gekommen zu sein, denn ich darf nun mit einem KAV-Diagnose-Tool Dateien erzeugen und an Kaspersky schicken.

 

Schönen Gruß

olecundbolec

 

Gibt es schon eine Lösung für das Problem? taucht bei mir jetzt leider auch auf

Share this post


Link to post
Gibt es schon eine Lösung für das Problem? taucht bei mir jetzt leider auch auf

 

Hallo,

 

nein, leider noch nicht. Das ursächliche Problem ist, dass der SQL-Browser nach Installation von KAV und einem Systemneustart diverse Fehlermeldung in das Ereignisprotokoll einträgt. Der SQL-Browser antwortet nicht mehr auf die Clientanfragen und demzufolge kann der Client den SQL-Server nicht mehr erreichen.

 

Wir hoffen noch auf eine konstruktive Rückmeldung des Kaspersky-Supports.

 

Gruß

olecundbolec

Edited by olecundbolec

Share this post


Link to post

Hallo zusammen,

 

nachdem wir nun einen höheren Support-Level bei Kaspersky erreicht haben, wurde uns mitgeteilt, dass die Kaspersky-Entwicklung das Problem als Fehler im Programm identifiziert hat. Man arbeitet jetzt, so hoffen wir zumindest, an einer Lösung.

 

Schönen Gruß

 

olecundbolec

 

Share this post


Link to post

Ich habe das gleiche Problem mit DATEV. DATEV hat den MSSQL Server von der 2005er auf die 2008er gewechselt. Und jetzt hatte ich mit der Kombination MSSQL Server 2008 + Kaspersky Anti-Virus 2013 Fehlermeldungen bei SQL Browser und Performance Probleme.

 

Problembild Beschreibung von DATEV: Beim Verbindungstest im DATEV SQL-Manager antwortet der SQL-Browser nicht. Netzarbeitsplätze können nicht auf den Quasi-/Fileserver zugreifen. Auf Einzelarbeitsplätzen kann es zu Performance-Problemen beim Arbeiten in der DATEV-Software kommen.

 

genau so war es bei mir!

 

Diese Info stammt aus der Informationsdatenbank von DATEV. Dok. Nr. 1080028

 

 

Übergangslösung ist 2013er deinstallieren und Kaspersky Anti-Virus 2012 Version installieren. Mit der 2012er habe ich noch keine Probleme festgestellt. Die Feststellung basiert aber auch erst auf 3 Tage Laufzeit...

Edited by user176

Share this post


Link to post

Hallo zusammen,

 

mit dem Patch G, welches seit dem 22.04.2013 freigegeben ist, sind die probleme zwischen KAV2013 und SQL-Server 2008 nun endlich Geschichte.

Ich hoffe, dass wiederholt sich mit KAV 2014 nicht wieder.

 

Gruß an alle die helfen wollten.

 

olecundbolec

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.