Sign in to follow this  
Followers 0
mossie

Windows 7 gadgets not working after uninstalling KIS 2011

2 posts in this topic

I'm attempting an upgrade from KIS 2011 to KIS 2012. After uninstalling KIS 2011, my Windows 7 gadgets have quit working, and are not being displayed correctly. Some are cropped, some are only partially displayed. I've tried reinstalling some gadgets and have tried running from the cmd line the following to attempt to reset the sidebar gadgets, but it didn't fix the issue:

 

taskkill /im sidebar.exe /f

regsvr32 msxml3.dll

regsvr32 scrrun.dll

regsvr32 jscript.dll

regsvr32 atl.dll

Regsvr32 "%ProgramFiles%\Windows Sidebar\sbdrop.dll"

Regsvr32 "%ProgramFiles%\Windows Sidebar\wlsrvc.dll"

reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones" /f

"%ProgramFiles%\Windows Sidebar\sidebar.exe"

 

I followed this procdure when uninstalling KIS 2011:

 

Right clicked the Kaspersky icon in system tray and selected Exit

Uninstalled Kaspersky> rebooted into safe mode, then ran the kaspersky removal tool for KIS anti-virus and Internet Security 2011.

Rebooted after using removal tool

Generated the GSI link

 

Visit My Website

 

I really want to be able to use the gadgets even if it means to continue using KIS 2011 although my license has expired, and I've already purchased KIS 2012. I tried installing KIS 2012 but the gadgets still don't work.

 

Any ideas on how to fix?

Share this post


Link to post
Share on other sites

For anyone else who may run across this problem, I got it fixed.

 

I noticed 2 remnant files in the gsi link for AVG & ask toolbar. I restored a disk image that I made just before uninstalling KIS 2011 (Thank God!) when the gadget problems started. I restored that disk image. I downloaded and ran removal tools specifically for AVG & Ask toolbar. I then closed every gadget on my desktop. I removed KIS 2011 with the windows control panel, and ran the KIS removal tool, then rebooted. Right clicked on the desktop and added the gadgets back without any problems. Then I installed KIS 2012 and it went smoothly.

 

Then I made another disk image with Acronis and migrated it over to a new SSD and that went smoothly. My 4 year old machine not boots in 1/3rd the time, and is lightning fast in comparison to the 5400 rpm HDD I replaced.

 

 

I'm attempting an upgrade from KIS 2011 to KIS 2012. After uninstalling KIS 2011, my Windows 7 gadgets have quit working, and are not being displayed correctly. Some are cropped, some are only partially displayed. I've tried reinstalling some gadgets and have tried running from the cmd line the following to attempt to reset the sidebar gadgets, but it didn't fix the issue:

 

taskkill /im sidebar.exe /f

regsvr32 msxml3.dll

regsvr32 scrrun.dll

regsvr32 jscript.dll

regsvr32 atl.dll

Regsvr32 "%ProgramFiles%\Windows Sidebar\sbdrop.dll"

Regsvr32 "%ProgramFiles%\Windows Sidebar\wlsrvc.dll"

reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones" /f

"%ProgramFiles%\Windows Sidebar\sidebar.exe"

 

I followed this procdure when uninstalling KIS 2011:

 

Right clicked the Kaspersky icon in system tray and selected Exit

Uninstalled Kaspersky> rebooted into safe mode, then ran the kaspersky removal tool for KIS anti-virus and Internet Security 2011.

Rebooted after using removal tool

Generated the GSI link

 

Visit My Website

 

I really want to be able to use the gadgets even if it means to continue using KIS 2011 although my license has expired, and I've already purchased KIS 2012. I tried installing KIS 2012 but the gadgets still don't work.

 

Any ideas on how to fix?

Edited by mossie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0