Jump to content
JohnH2O

Help and vulnerability links in PURE 2.0

Recommended Posts

For some time none of the help links in PURE are working anymore. It is not a big deal; I have added a desktop shortcut to the CHM file. What I do not have available, is the context-sensitive help.

 

I hoped patch C should resolve the problem, but no, the links are still dead on my Win7 x64 computer; everything is fine on Win XP 32 bit.

 

Today I learned that the <Details>-link in vulnerable applications do not work anymore. I have to make a note of the URL to redirect.kaspersky.com to read the message.

 

If you advice me to reinstall PURE 2.0: I have already performed the operation (a clean install), to no avail. Is there a problem with basegui.ppl that cannot be resolved? (Check http://forum.kaspersky.com/index.php?showt...p;#entry1858040, where it is written: “It will be corrected in KIS/KAV/Pure 2013.”)

 

Share this post


Link to post
What happens when you try?

Nothing happens.

 

Is this primarily a basegui.ppl issue?

I do not know; I am just guessing after reading in the KIS topic: “The error occurs at the moment the user is clicking a link (e.g. Support or Help) in the main frame of the product.”

 

There is no problem with the support link.

 

Am I the only (lucky) one with this problem?

 

BTW, before the reinstall, I tried to reset all settings, no difference.

 

Share this post


Link to post
It looks like you are not receiving the basegui.ppl error.

 

Pending hopeful possible resolution of this issue here at this forum, please contact Tech Support: https://my.kaspersky.com/en/support/helpdesk

I created a request to the help desk at 19.06.2012. The same day they answered:

 

Run kavremover in Safe Mode, twice.

Open control panel and Folder options, klick the second tab and choose to show hidden files and folder.

Search for Kaspersky and delete all you find.

Try to set antoher browser as you main browser.

and

Did you use KavRemover in Safe Mode?

Try both firefox and Google Chrome.

Yes, I ran KAVremover in safe mode, my last re-installation was 14.07.2012. I have tried other browsers. Still the help links do not work.

 

I am searching in the dark, but could other fellow users tell me what registry entry you have for the Kaspersky Gui Controller 1.0 Type Library? Please look for an entry in this key:

HKEY_CLASSES_ROOT\TypeLib\{2F2A90B9-19CA-4070-9CB8-11CACD74F023}\1.0\HELPDIR

 

Is a folder listed in this entry?

 

Share this post


Link to post
1. Please see: http://support.kaspersky.com/faq/?qid=208286550

 

2. If still no go, please continue with Tech Support.

 

3. If you wish to continue with this issue here, please post your GSI report link.

Thanks, richbuff. Yes, I have read the referenced article. I do not receive the RunDLL message. I have not Free Studio 5.5.0 installed. I have also read the latest posts in the KIS topic. I have reinstalled MS .NET Framework (07.07.2012). The issue is continued, nothing happens when I click a link. (If the vulnerability scan reports that an update is needed, the web link does not work. That is my main problem.)

 

I have added my answers to the support ticket (#313967278), but they do not respond any more. I shall try to add a reminder, but it has not worked with other more serious support requests.

 

It is a pleasure to post a link to a new GSI report

 

Still I should like to know whether other users have any entry in the HELPDIR key.

Share this post


Link to post

You're welcome. Have you tried with Ashampoo Burning Studio uninstalled > rebooted?

Share this post


Link to post
You're welcome. Have you tried with Ashampoo Burning Studio uninstalled > rebooted?

I have uninstalled Ashampoo Burning Studio and rebooted. Unfortunately: No change.

 

I have 7 objects in the Registry (group COM/OLE/Active(X)) with subkeys without data. All of them are related to Kaspersky PURE:

C:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\klwtbbho.dll

HKEY_CLASSES_ROOT\TypeLib\{05018BC9-67AE-4669-B755-5C86C1911B7E}\1.0\HELPDIR

C:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\abhelper.dll

HKEY_CLASSES_ROOT\TypeLib\{12D603CF-CF45-46CD-9851-FBD4CEE75CC6}\1.0\HELPDIR

C:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\basegui.ppl

HKEY_CLASSES_ROOT\TypeLib\{2F2A90B9-19CA-4070-9CB8-11CACD74F023}\1.0\HELPDIR

C:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\mcou.dll

HKEY_CLASSES_ROOT\TypeLib\{38DD516D-5C7C-47DB-A922-3796CA8CFE34}\2.0\HELPDIR

C:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\klwtblfs.exe

HKEY_CLASSES_ROOT\TypeLib\{3B61E439-3873-4B7A-98DD-AC58F1BEA23E}\1.0\HELPDIR

C:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\avpapplication.dll

HKEY_CLASSES_ROOT\TypeLib\{4ED2EAB3-019D-4E15-8A37-DC7FD9CEBBA8}\1.0\HELPDIR

C:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\klwtbcl.dll

HKEY_CLASSES_ROOT\TypeLib\{5EF63066-5EEE-4E29-9424-D5916E04DC45}\1.0\HELPDIR

 

This might be as it should be, I don't know. That's why I kindly ask other users to check their registry.

 

The empty data strings are reported by Ashampoo Win Optimizer 9, not by CCleaner or jv16 Power Tools.

 

PS: I have sent a reminder to Tech Support

Edited by JohnH2O

Share this post


Link to post

Please, do YOU have 2 minutes free to check your registry for the key

HKEY_CLASSES_ROOT\TypeLib\{2F2A90B9-19CA-4070-9CB8-11CACD74F023}\1.0\HELPDIR

 

Is there an entry in the HELPDIR subkey, or is it empty?

 

Share this post


Link to post

I have the same problem. Click on Help or Details after a vulnerability scan, and nothing happens.

 

(I mentioned this is my thread about XP2 SP3 hanging on shutdown, before I saw this thread).

Edited by benbaaa

Share this post


Link to post
I have the same problem. Click on Help or Details after a vulnerability scan, and nothing happens.

 

(I mentioned this is my thread about XP2 SP3 hanging on shutdown, before I saw this thread).

There is a workaround: Open the detailed report (Detected threats/Vulnerability), use copy and paste. In this manner I today found after a vulnerability scan:

 

http://redirect.kaspersky.com/?hl=en&t...es&VN=50285

with the advice:

Update to version 11.3.300.271 for Windows, Mac, and Chrome or version

Flash Player 11.3.300.271 for Windows and Macintosh: http://www.adobe.com/go/getflash

 

 

post-134351-1345107358_thumb.jpg

Share this post


Link to post

Yes, thanks John. I actually stumbled upon the Ctrl-C Ctrl-V workaround by myself, more by luck than anything else.

 

Just wish they'd fix the broken links and buttons though.

Share this post


Link to post

Hello, please try next:

1. Disable Pure's Self Defense, completely exit product.

2. Cut off all files inside C:\Program Files (x86)\Kaspersky Lab\Kaspersky Pure 2.0\ somewhere on computer, then delete C:\Program Files (x86)\Kaspersky Lab folder (If you are using 32-bit version of Windows, Look into C:\Program files\ folder).

3. Start registry editor (Win+R ~> regedit) and locate the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem

Select the NtfsDisable8dot3NameCreation entry. Set its value to 0, then reboot computer

4. After reboot, manually create C:\Program files (x86)\Kaspersky Lab\Kaspersky Pure 2.0\ folders back and move files back into it.

Run Pure and check for problem resolution.

Tell me about results, thank you.

Share this post


Link to post
Hello, please try next:

1. Disable Pure's Self Defense, completely exit product.

2. Cut off all files inside C:\Program Files (x86)\Kaspersky Lab\Kaspersky Pure 2.0\ somewhere on computer, then delete C:\Program Files (x86)\Kaspersky Lab folder (If you are using 32-bit version of Windows, Look into C:\Program files\ folder).

3. Start registry editor (Win+R ~> regedit) and locate the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem

Select the NtfsDisable8dot3NameCreation entry. Set its value to 0, then reboot computer

4. After reboot, manually create C:\Program files (x86)\Kaspersky Lab\Kaspersky Pure 2.0\ folders back and move files back into it.

Run Pure and check for problem resolution.

Tell me about results, thank you.

SORRY, it did not work.

 

I was unable to delete these files:

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\prremote.dll

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\shellex.dll

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\prremote.dll

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\scrchpg.dll

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\shellex.dll

 

Boot into safe mode: Deleted scrchpg.dl, but prremote.dll and shellex.dll still write protected.

 

I performed the registry modification, changed the value from 1 to 0.

 

Rebooted (twice), enabled self-defense. The help links do not work; only one single help link functions, the link inside Password Manager (as before).

 

Additionally, Windows has lost the connection to PURE, tells me that I have no AV/FW.

Edited by JohnH2O

Share this post


Link to post
SORRY, it did not work.

 

I was unable to delete these files:

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\prremote.dll

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\shellex.dll

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\prremote.dll

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\scrchpg.dll

c:\Program Files (x86)\Kaspersky Lab\Kaspersky PURE 2.0\x64\shellex.dll

 

Boot into safe mode: Deleted scrchpg.dl, but prremote.dll and shellex.dll still write protected.

 

I performed the registry modification, changed the value from 1 to 0.

 

Rebooted (twice), enabled self-defense. The help links do not work; only one single help link functions, the link inside Password Manager (as before).

 

Additionally, Windows has lost the connection to PURE, tells me that I have no AV/FW.

 

Goal is to delete this folders, please try to change owner settings on Kaspersky Lab folder and repeat instruction again or completely re-install Pure (and again, after removing, make sure that Kaspersky Lab folder doesn't exist).

Share this post


Link to post
Goal is to delete this folders, please try to change owner settings on Kaspersky Lab folder and repeat instruction again or completely re-install Pure (and again, after removing, make sure that Kaspersky Lab folder doesn't exist).

The owner settings (c:\Program Files (x86)\Kaspersky Lab) are like this:

Administrators (my account): All permissions (like SYSTEM and TrustedInstaller)

Owner: SYSTEM

 

I have tried to change owner to my account; still the mentionned files are undeletable.

 

What settings should I modify?

 

 

Share this post


Link to post
The owner settings (c:\Program Files (x86)\Kaspersky Lab) are like this:

Administrators (my account): All permissions (like SYSTEM and TrustedInstaller)

Owner: SYSTEM

 

I have tried to change owner to my account; still the mentionned files are undeletable.

 

What settings should I modify?

In safe-mode change owner settings to Administrators, and check "Replace owner .." box. You should be able to easily delete this files.

Share this post


Link to post
In safe-mode change owner settings to Administrators, and check "Replace owner .." box. You should be able to easily delete this files.

Well, I changed owner to Administrators, but to no avail. But I performed the operation in Normal Mode. Before reading VenZe's post about Safe Mode, I started to uninstall PURE 2.0:

 

As usual: Hang on DrvInstaller.exe, stopped Uninstaller through Task Manager. Started Kavremover ver. 1.0.278 in NORMAL mode. First run: Selected PURE 2.0, second run: Selected All known products. Some files (prloader.dll, prremote.dll, scrchpg.dll, shellex.dll) were left int the program folder, but obviously the deletion process was registered as a pending operation. After reboot the folder c:\Program Files (x86)\Kaspersky Lab with subfolders were completely removed! And with this version of Kavremover, PURE 2.0 was correctly removed from the Control Panel's list of installed applications.

 

Still a lot of Kaspersky entries in the registry, 176 entries in HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\Folders pointing to a non existing program folder. This might not be of any importance, but I cleaned the registry.

 

I reinstalled PURE 2.0, “Error 1705: Previous installation of this application is in progress”, confirmed “undo the changes” and the installation completed. Activated on-line, updated from local distribution folder, rebooted. Ver 12.0.1.288 successfully installed with patches a.b.c. Installed pure2.0_hf4_signed.exe according to the instructions.

 

THE RESULT:

 

1 The help links are now working! Thanks VenZe!

2 Virtual Keyboard is still not working with Firefox 14.0.1

 

Share this post


Link to post
THE RESULT:

1 The help links are now working! Thanks VenZe!

2 Virtual Keyboard is still not working with Firefox 14.0.1

Glad to know that it helps! Thank you.

Share this post


Link to post

So I seem to have the same problem. Which of all the above steps do I need to do to fix my links?

 

Cheers,

 

benbaaa

Share this post


Link to post
So I seem to have the same problem. Which of all the above steps do I need to do to fix my links?

Focus on VenZe's post (#14). It's like a 3-stage rocket:

 

1 Remove the application (PURE) completely

2 Modify the registry entry

3 Bring the application back

 

VenZe suggested a new method for stage 1 & 3, namely (1) to copy the folder to a temporary storage area and then delete the program folder (C:\Kaspersky Lab) and at last (3) copy the folder/files back to the original area.

 

I had some problems with the file deletion, I used the traditional method: Uninstall PURE (1) and Reinstall PURE (3). (There are hundreds of posts about the un- and reinstall procedure at this forum, be sure you have available: The PURE setup file, the activation code and the latest version of Kavremover.)

It is important that the program folders are completely removed at stage 1. If the normal uninstall procedure does not work, try Kavremover. If necessary, run the remover after booting into safe mode.

 

 

Share this post


Link to post

OK, thanks, John. But before I embark on this little procedure, how to I ensure that I retain my Password Manager details?

 

PM is bundled with PURE, and I'm concerned that I will lose all the passwords and whatever if I do a complete uninstall and remove all folders.

Share this post


Link to post
OK, thanks, John. But before I embark on this little procedure, how to I ensure that I retain my Password Manager details?

 

PM is bundled with PURE, and I'm concerned that I will lose all the passwords and whatever if I do a complete uninstall and remove all folders.

Yes, I too have become addicted to PURE's password manager.

 

Please read my post http://forum.kaspersky.com/index.php?showt...t&p=1878385 and ARC99's reply in the subsequent post.

 

My last run with Kavremover did not touch the password db (default.pws). And remember, PURE automatically creates backups of the passwords. Check PM > Settings > My passwords to find where the backup storage is located on your computer.

 

BTW, It feels good to have working links again, both for the help file and the vulnerability check.

 

Share this post


Link to post

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.