Jump to content
Sign in to follow this  
101

KIS 2012: Menüauswahl "Ruhezustand/Standby nach Scan" vertauscht

Recommended Posts

Man kann ja einstellen, was nach einer vollständigen Untersuchung geschehen soll. Zur Auswahl stehen dabei:

Computer nicht ausschalten

Computer ausschalten

In den Standby-Modus wechseln

In den Ruhezustand wechseln

Computer neu starten

Nachdem der Ruhezustand einfach nicht funktionieren wollte und er immer im Standby-Modus landete, hatte ich lange Zeit Windows' agressive Energieverwaltung in Verdacht. Völlig zu unrecht, wie ich nach etlichen Tests gerade festgestellt habe.

 

In KIS 2012 (mit Patch h) sind die Auswahlmodi Ruhezustand und Standby schlichtweg vertauscht.

Edited by 101

Share this post


Link to post

Ich kann diese Beobachtung auf meinem Windows-XP-System bestätigen. Kannst du dich vielleicht erinnern, ob sich das Verhalten von KIS 2012 mit einem der Hotfixes geändert hat?

Share this post


Link to post

Ich habe KIS 2012 erst im November 2011 installiert, da habe ich Windows 7 x64 neu aufgesetzt, und nutze zum Ausschalten des Rechners in der Regel den Ruhezustand - auch mit anderer Software wie TOff oder WinOFF. Unter der Einstellung Ruhezustand hat KIS den Rechner von Anfang an in den Standby versetzt. Die Einstellung Standby hatte ich bis heute nie getestet.

 

Wie ich hier schon angemerkt hatte, funktionierte der Ruhezustand auch mit anderer Software schon einige Zeit nicht mehr, per konfiguriertem Netzschalter aber weiterhin. Das heißt, dass der Rechner auch mit TOff oder WinOFF plötzlich immer im Standby statt im Ruhezustand landete, weshalb ich Windows Energieverwaltung und nicht KIS in Verdacht hatte.

 

Da ich nun festgestellt habe, dass es mit TOff und WinOFF plötzlich wieder geht, mit KIS aber immer noch nicht, kam ich auf die Idee, dass es in KIS vertauscht sein könnte, was sich bei einem Test mit beiden Einstellungen jetzt bestätigt hatte.

 

Ab wann über TOff und WinOFF der Rechner nur noch im Standby statt im Ruhezustand landete, kann ich nicht mehr sagen, Es ist aber durchaus möglich, dass dies mit dem Patch g kam und mit dem Patch h nun wieder behoben wurde. Ob die beiden Modi dabei jetzt erst vertauscht wurden, kann ich leider nicht sagen, da ich die Standby Einstellung vorher nie getestet hatte.

 

Das Wichtigste ist jetzt erst einmal, dass beide Modi nutzbar sind und funktionieren. Die Frage ist allerdings auch, ob es nur in der deutschen Version vertauscht ist. Ich habe schon nach sleep und hibernate recherchiert, aber in Bezug auf dieses Problem nichts finden können.

Edited by 101

Share this post


Link to post

Meines Erachtens ist die deutsche Lokalisierung korrekt, weswegen wahrscheinlich kein einfacher Übersetzungsfehler vorliegt. In der englischen Lokalisierung hat man übrigens die Bezeichnungen "standby mode" und "sleep mode" gewählt. Dies halte ich nicht für optimal, da soweit ich weiß in aktuellen Windows-Versionen die Bezeichnungen "sleep" (Standby) und "hibernate" (Ruhezustand) verwendet werden.

 

Ich konnte das Problem mit Hotfix B reproduzieren, es handelt sich also nicht um einen Fehler in einem der letzten Hotfixes.

Share this post


Link to post

N'Abendt 101, JanRei,

 

meldet das jemand von Euch an den Support, damit das von KL korrigiert wird?

 

Bye.

KM

Share this post


Link to post
In der englischen Lokalisierung hat man übrigens die Bezeichnungen "standby mode" und "sleep mode" gewählt. Dies halte ich nicht für optimal, da soweit ich weiß in aktuellen Windows-Versionen die Bezeichnungen "sleep" (Standby) und "hibernate" (Ruhezustand) verwendet werden.

 

Ich konnte das Problem mit Hotfix B reproduzieren, es handelt sich also nicht um einen Fehler in einem der letzten Hotfixes.

Ja, in der englischen Windows 7 Version steht Standby für den Standby-Modus (bei uns "Ernergie sparen") und Sleep für den Hibernate-Modus (bei uns Ruhezustand). Wenn Kaspersky in der englischen Version Standby und Sleep verwendet, ist das ja zusätzlich verzwickt, da beide Begriffe unter Windows 7 das gleiche bedeuten. Da Standby in beiden Lokalisierungen verwendet wird, wird es auch die gleiche, falsche Auswirkung haben. Demnach wird der Rechner auch in der englischen Version mit der Aktion Standby-Mode in den Hibernate-Mode gehen.

 

Wenn das Verhalten schon mit Hotfix b so ist, wird es wohl von Anfang an so sein. Dass das noch niemandem aufgefallen ist, kann mir aber fast nicht vorstellen. Entweder nutzt das keiner, was ich auch nicht so richtig glauben kann, oder die meisten nutzen auch nur einen von beiden Modi und haben sich immer nur gewundert, dass es nicht wie gewünscht funktionierte, und das dann auf andere Verursacher geschoben (Mainboard/Bios, Treiber, Windows).

 

Wie KleinerMuck schon angemerkt hat, sollte man das melden. Sonst bleibt das womöglich auch in KIS 2013 so. Da Du ja auch die englische Version und mit Hotfix b getestet hast, wäre es villeicht am besten, wenn Du das meldest.

Edited by 101

Share this post


Link to post

Ich beabsichtige momentan, dies Kaspersky gegebenenfalls im Rahmen des Beta-Tests von Version 2013 vorzulegen.

Share this post


Link to post
Ja, in der englischen Windows 7 Version steht Standby für den Standby-Modus (bei uns "Ernergie sparen") und Sleep für den Hibernate-Modus (bei uns Ruhezustand).

Das widerspricht der Aussage von JanRei und kann ich so nicht bestätigen. Die deutschen bzw. englischen Bezeichnungen in Windows 7 sind:

Energie sparen = Sleep

Ruhezustand = Hibernate

Beim deutschen Windows XP respektive "Standby" und "Ruhezustand".

 

Bei Kaspersky ist zumindest "Standbymodus" nicht entsprechend Duden übersetzt, denn es müsste "Stand-by-Modus" heißen.

Und bevor es jetzt einen "Aufschrei" gibt, ja auch Microsoft übersetzt es nicht korrekt. <_<

Share this post


Link to post

So lange das Produkt den Energiesparmodus von Windows nicht unterstützt halte ich das für eine sinnlose Diskussion, egal ob da was vertauscht ist oder nicht.

 

Folgendes Beispiel:

- Betreibe Dein PC im Energiesparmodus, nach 5 Minuten Bildschirm aus und nach 20 Minuten geht der PC in den Energiesparmodus (Ruhezustand oder Standby).

- Starte eine Vollständige Untersuchung, lege dann den einen Betriebszustand (PC ausschalten, Standby oder Ruhezustand) für nach der Untersuchung fest.

 

Was wird passieren??

Dauert die Vollständige Untersuchung länger als 20 Minuten geht der PC in den von Windows festgelegten Betriebszustand, die Vollständige Untersuchung wird bis auf weiteres angehalten. Die Fortsetzung der Untersuchung erfolgt mit dem erwachen aus dem bei Windows festgelegten Energiesparmodus. Das macht doch keinen Sinn.

 

Das Kaspersky Programm müsste dafür sorgen, dass so lange eine Aufgabe läuft (Update, Vollständige Untersuchung, Untersuchung wichtiger Bereiche, Rootkitsuche und Systemanalyse) das Windows nicht in den Energiesparmodus gehen kann, die Untersuchung abgeschlossen werden kann und erst nach dez abgeschlossenen Untersuchung dann in den festgelegten Betriebszustand geht.

Bei dieser Gelegenheit sollte man nochmal darüber nachdenken ob man die Auswahl in einen anderen Betriebszustand nicht in der Scheduler zu vor ab planen mit aufnimmt.

 

Das könnte dann so in etwa aussehen:

post-13554-1330540743_thumb.jpg

 

 

 

 

 

Share this post


Link to post

@dorsch: Das gehört a.) nicht wirklich zum hier berichteten Fehler und sollte b.) vor allem an Win7 liegen (unzählige Programme haben dort Probleme den systemkonfigurierten Ruhezustand hinauszuzögern)

Edited by SebastianLE

Share this post


Link to post

Energie sparen = Sleep

Ruhezustand = Hibernate

Bei Kaspersky ist zumindest "Standbymodus" nicht entsprechend Duden übersetzt, denn es müsste "Stand-by-Modus" heißen.

Und bevor es jetzt einen "Aufschrei" gibt, ja auch Microsoft übersetzt es nicht korrekt. <_<

Stimmt, da bin ich jetzt auch durcheinander geraten.

Energie sparen = Sleep = Stand by

 

Dass Microsoft Stand by durch Sleep ersetzt hat, war eigentlich völlig unnötig. Es sei denn, in Windows 8 wäre ein weiterer Zustand geplant. Da soll sich ja in diese Richtung etwas ändern.

 

Wie jetzt Stand by geschrieben ist, ist aber wirklich nur Nebensache.

 

 

Folgendes Beispiel:

- Betreibe Dein PC im Energiesparmodus, nach 5 Minuten Bildschirm aus und nach 20 Minuten geht der PC in den Energiesparmodus (Ruhezustand oder Standby).

- Starte eine Vollständige Untersuchung, lege dann den einen Betriebszustand (PC ausschalten, Standby oder Ruhezustand) für nach der Untersuchung fest.

 

Was wird passieren??

Dauert die Vollständige Untersuchung länger als 20 Minuten geht der PC in den von Windows festgelegten Betriebszustand, die Vollständige Untersuchung wird bis auf weiteres angehalten. Die Fortsetzung der Untersuchung erfolgt mit dem erwachen aus dem bei Windows festgelegten Energiesparmodus.

 

Bei mir läuft immer Internetradio über Winamp und das verhindert das Auslösen sämtlicher Energiesparmodi durch Windows 7. Programme wie TOff, WinOFF oder auch KIS 2012 fahren den Rechner dann aber trotzdem in den von mir festgelegten Ernergiesparmodus. Insofern ist das bei mir mit KIS 2012 also brauchbar. Kaspersky sollte die künftige Version aber so gestalten, dass es Windows daran hindert in die automatischen Ernergiesparzustände zu wechseln, solange ein Scan läuft. Noch besser wäre eine Wahlmöglichkeit. Winamp kann das ja auch (das Verhindern) und das ist immerhin Freeware. Ansonsten gibt es noch die Freeware "Don't Sleep", die zur Verhinderung der automatischen Energiesparzustände geschaffen wurde. Ich habe das allerdings in Verbindung mit KIS noch nicht getestet. Es sollte aber funktionieren.

Edited by 101

Share this post


Link to post

Das Problen, dass Windows während eines Vollscans in den Energiesparmodus wechselt, wenn der Scan länger dauert als die in Windows eingestellte Wartezeit, gab es unter Windows 2000 mit KIS 7 übrigens noch nicht. Wie man hier lesen kann, besteht das Problem unter Windows 7 schon mit KIS 2010. Dass es für Windows 7 nie zugelassen war, weiß ich. Es ist für dieses Problem aber eher irrelevant.

 

Ich nehme an, dass es an einem verändertem Verhalten von Windows 7 gegenüber früheren Windowsversionen liegt. Entweder zählt die Prozessorlast nicht mehr oder sie wurde untergewichtet, oder der Scan verursacht einfach zu wenig Last. Ich wundere mich ohnehin, dass der wöchenliche Vollscan so wenig Last verursacht und drei Stunden dauert. "Ressourcen für andere Programme freigeben" ist übrigens nicht aktiviert. Norton (NIS 2011) hat den Prozessor recht stark beansprucht, aber nicht so stark, dass es beinträchtigt hätte, und war dafür viel schneller fertig.

 

Wahrscheinlich verhindert auch nicht Winamp erfolgreich den Energiesparmodus, sondern Windows 7 entscheidet das selbst. Wie schon im verlinkten Beitrag des Techarena-Forums erwähnt wurde, gibt es wahrscheinlich in Windows 7 ein neues Flag, das der Kaspersky-Scan setzen müsste. Wie "Don't sleep" das macht, weiß ich nicht. Über simulierte Prozessorlast jedenfalls nicht. Das wäre auch nicht gut. :-)

 

Wie ist das eigentlich unter Vista? Wird da der Energiesparmodus bei einem Scan mit KIS 2012 verhindert, wenn er länger dauert als die eingestellte Wartezeit in Vista? Wenn ja, würde das die obigen Vermutungen erhärten.

Share this post


Link to post

Prinzipiell können Anwendungen Windows mitteilen, dass das System momentan in Benutzung ist. Windows sollte dann nicht von sich aus in einen Energiesparmodus wechseln. Mir ist nicht bekannt, ob es in diesem Zusammenhang Probleme mit bestimmten Windows-Versionen gibt. Wer sich für technische Einzelheiten interessiert, findet beispielsweise eine englischsprachige Erläuterung in der Dokumentation von Microsoft: http://msdn.microsoft.com/library/windows/...p/aa373233.aspx

 

KAV/KIS ist übrigens seit Version 9.0.0.736 (2010 Critical Fix 2) offiziell mit Windows 7 kompatibel.

Share this post


Link to post

Ah, danke! Demnach liegt es dann doch an Kaspersky. Die von Dir verlinkte Seite beschreibt die Funktion als gültig für alle Windows Klient-Versionen ab XP. Nach dieser Unterseite müsste es das Flag ES_CONTINUOUS sein, das der Scan setzen, und nach Beedigung des Scan wieder löschen sollte. Dass das nicht gemacht wird, würde ich als BUG einstufen.

 

Das sollte dann zusammen mit der Korrektur der Vertauschung ebenfalls behoben werden. Das dürfte für Kaspersky weniger als eine Kleinigkeit sein. :-)

 

Vielleicht wünschen manche Benutzer den zwischenzeitlichen Energiesparmodus auch. Schließlich passiert währenddessen nichts. Eine Wahlmöglichkeit wäre deshalb optimal.

Edited by 101

Share this post


Link to post

Danke JanRei & 101

für eure Links, ich stimme dem zu, das Kaspersky mal endlich in dieser Richtung was tun sollte.

 

Offensichtlich wird der Energiesparmodus nur von wenigen genutzt, sonnst wäre diesbezüglich schon einige Problemberichte aufgetaucht.

 

Also Ran Kaspersky, tu was Sinnvolles für Deine Anwender!

Share this post


Link to post
@dorsch: Das gehört a.) nicht wirklich zum hier berichteten Fehler und sollte b.) vor allem an Win7 liegen (unzählige Programme haben dort Probleme den systemkonfigurierten Ruhezustand hinauszuzögern)

 

@ Sebastian,

bei Dir habe ich immer das Problem ob Du bewusst Beiträge versuchst zu blocken.

Edited by dorsch

Share this post


Link to post

Ich habe nichts geblockt :) könnte dir aber aus dem Securitysoftware und Videosoftwarebereich eine recht lange Liste von Programmen nennen, wo es bis auf Win7 unter jeder Windows Version funktioniert.

 

Du hast das Problem ja auch im Vorschlägeforum sehr nachvollziehbar beschrieben, in diesem Thread passt es m.M. nach nicht ganz.

Share this post


Link to post

Nimm es doch ein fach mal hin, das Kaspersky den Energiesparmodus nicht unterstützen will bzw. nicht kann, andere Ausreden lasse ich nicht gelten.

Share this post


Link to post
Nimm es doch ein fach mal hin, das Kaspersky den Energiesparmodus nicht unterstützen will bzw. nicht kann, andere Ausreden lasse ich nicht gelten.

 

Was heißt Ausrede? Ich gehe bei dem nicht kann mit - über die Ursache kann ich jedoch nichts sagen.

Kannst du belegen, dass es auch auf anderen Betriebssystemen als Win7 nicht geht??? Weil wenn es dort geht, dann liegt es womöglich doch an Win7, zumal dort viele andere Programme dasselbe Problem wie KL haben.

 

Wie dem auch sei, der Fehler ist gemeldet und es heißt abwarten.

Share this post


Link to post

Wir sind ein kleines Kollektiv und haben das Produkt, das bei gebracht, was es nie konnte bzw, nie wollte, die Unterstützung des Energiesparmoduses. Da dürften Deine GUI Kenntnisse nicht reichen , in Deutschland gibt es nur drei Programmierer die das Kaspersky Produkt beherrschen , nur keiner will wirklich was mit Kaspersky zu tun haben wollen.

Edited by dorsch

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.