Jump to content
Sign in to follow this  
amalsp

Open port 1433 on Kaspersky server

Recommended Posts

hi,

 

I am trying to open port 1433 on my Kaspersky server (admin kit along with sql server is installed on this server). This has to do with Kaspersky as my sql server (with kaspersky av) has port 1433 open. Windows firewall is disabled and I have tried with tcp/ip filtering on the network card. I tried to enable this port as the mobile connection port but still it does not work. Please help.

 

Thanks

 

Amal

 

Share this post


Link to post

if the firewall is off and there are no firewalls between you and the Kaspersky server then it isnt likely to be a port blocking issue.

 

are you trying to get it to connect to your SQL server ?

tcp/1433 is MS SQL Server and it isnt configured to listen for remote connections by default.

 

if you are trying to configure something else to listen on that port you may experience conflicts and problems

 

this ms kb for enabling it for sql 2005 should point you in the right place if you are intending to publish SQL server remotely

http://support.microsoft.com/kb/914277

 

if you are not trying to publish SQL server then I would pick a different port number for what you need.

 

hope that helps some. if not, can you expand on what you are doing and I'll help as much as I can

 

robert

 

 

 

Share this post


Link to post

Hi,

 

Thanks for the reply. I had followed the settings suggested to allow remote connections, but still does not work. netstat -a does not show the server listening on port 1433.

 

Amal

Share this post


Link to post

Hi,

 

This what worked for me.

 

But also, the following seem to need to be changed as well:

** 64bit ** HKLM\SOFTWARE\ Wow6432Node \ Microsoft \ Microsoft SQL Server \ MSSQL.1 \ MSSQLServer \ SuperSocketNetLib \ Tcp \

** 32bit ** HKLM\SOFTWARE\ Microsoft \ Microsoft SQL Server \ MSSQL.1 \ MSSQLServer \ SuperSocketNetLib \ Tcp \

 

Each "IP"# folder up to and including IPAll:

Name: TcpDynamicPorts

Type: REG_SZ

Data: (should be empty)

 

Name: TcpPort

Type: REG_SZ

Data: 1433

 

Thanks to brainbone

 

http://forums.majorgeeks.com/showthread.php?t=189094

 

Amal

Share this post


Link to post
Sign in to follow this  

×
×
  • Create New...

Important Information

We use cookies to make your experience of our websites better. By using and further navigating this website you accept this. Detailed information about the use of cookies on this website is available by clicking on more information.